Turn off LED bar without turning off smart bulbs

I have a dimmer installed before the smart bulbs. The only way I found to keep smart bulbs always on is:

  1. turn on dimmer (with relay on) so the smart bulbs are on
  2. disable local&remote relays - so nothing will ever cut the power to smart bulbs
    Unfortunately at this point LED bar will always stays ON effectively blocking any notifications on that dimmer - they won’t play while the dimmer is ON.
    How do I turn off the LED bar while keeping the power to smart bulbs?

If I understand your goal correctly…

You want to power the smart bulbs 100% of the time.
You want to control them via Z-Wave from your dimmer

If this is the case, consider rewiring the dimmer so the line goes directly to the smart bulb and have nothing on the dimmer “load” and “traveler”

I haven’t tried this, but the manual indicates it should be possible: just set parameter 14 to 0 (and parameter 15 to the same if you want it when the switch is “off,” too–perhaps you don’t so you have an easy way to tell whether it is really off).

I’m not sure what hub you’re using, but on SmartThings and Hubitat, those are are also both options on the device page if you’re using Inovelli’s DTH/driver.

That being said, regardless of what you have switch state or “regular” LED settings configured for, notifications should override the “regular” LED when they are activated until they expire or you physically manipulate the dimmer (which will show the level and override the notification–something people have requested to change). Is that not the behavior you’re seeing?

I considered doing that but decided not to do because in case of hub failure or whatever I won’t be able to use the switch by turning back the local relay on a switch

Yes, I’m not seeing this behavior on my Hubitat - if LED bar is on (and it will be always on in case you need to turn off local relay) notifications won’t display on the switch. Do you see it working differently?

Could you please try to turn the switch on, disable local&remote relay and see if you can play the notification on the dimmer? I can’t do that on any of my switches.

@Eric_Inovelli Here is the error I’m getting - according to other comments I believe that’s not an expected behavior.

dev:202019-12-29 20:56:14.161 debug Kitchen Dimmer: Unhandled: ApplicationRejectedRequest(status:0)
dev:202019-12-29 20:56:13.729 info  Kitchen Dimmer: Setting parameter 16 with a size of 4 bytes to 87820970
dev:202019-12-29 20:56:13.670 info  Kitchen Dimmer: childOn(0A-ep1)
dev:202019-12-29 20:55:50.503 info  Kitchen Dimmer: Protection report received: Local protection is on & Remote protection is on
dev:202019-12-29 20:55:50.476 debug Kitchen Dimmer: Kitchen Dimmer: ProtectionReport(localProtectionState:1, rfProtectionState:1)

I am able to replicate this behavior, but it has nothing to do with the LED bar brightness as suggested previously. It is just disabling remote control that makes the child notification switches not work. I’ve read about this before, but I’m not sure if it was for the switches or dimmers or both or if they have a plan to address this.

(Personally, I only disable local control–the only place someone who isn’t me is likely to mess something up. If I want to control it remotely, I assume I know what I’m doing.)

You are totally right. Reenabling remote control allowed me to use notifications.
My original plan was to have hubitat groups with bulbs and dimmers. I thought that dimming the group will dim every smart bulb and dimmer in a group. And changing the level of the dimmer won’t change the voltage on the bulbs because, as I thought, the relay is disabled.
In fact relay is never disconnected - instead “Disable local/remote control” limits the commands you can send to the dimmer. Since you can’t send the commands - the dimmer won’t react to commands - same effect.

I wish there was a way separate relay logic from dimmer control logic. For example by introducing a new setting “Relay control” with values “Always ON/Defined by dimmer state(default)”.

Disable Local/Remote Control=false, Relay control=“Defined by dimmer state” - current default behavior
Disable Local/Remote Control=true, Relay control=“Defined by dimmer state” - current behavior (because nothing can change dimmer’s state)
Disable Local/Remote Control=false, Relay control=“Always ON” - always keeps smart bulbs powered. Dimmer state can be changed using buttons but that won’t have any effect on connected lights. However user can setup a custom app to match dimmer level to smart bulbs for example. Or Hubitat group will set level on the dimmer based on current level. Or use dimmer’s level to display current temperature in the pot. Or current moon phase. Or whatever - the state of the dimmer is not affecting the load.
Disable Local/Remote Control=true, Relay control=“Always ON” - mostly current behavior but dimmer can also be in OFF state while keeping power to bulbs.

It will (assuming you manipulate the group device it creates). However, if you’re using the Inovelli with smart bulbs (and therefore want the switch/dimmer always “on” or at level 99), I don’t see why Groups and Scenes is a problem: put the actual smart bulbs that you want to control in that group. Leave the Inovelli switch/dimmer out — it’s not serving that function for you, with it being now only a button device.

That’s what I ended up doing - still feel bad for wasting that beautiful LED bar.

So I guess I don’t understand what you’re trying to do. Sounds like you’re trying to make the lights in the bar rise or fall as they would if dimming a “real” load? Since that is tied to the actual dimmer level, I don’t think that will work in this case. (That is not what I understood you wanting to do from the previous post.) I’ve never cared much for that since I can see just as well how dark/light the room looks and if I’m happy with that, but I understand some people still like this kind of feedback. :slight_smile: There’s no way to manipulate the bar in that manner via Z-Wave, either, so I think it would take firmware changes on their side to implement. You could dim/brighten the LED bar or change its hue/color to correlate with another level…

I did this by connecting the load directly to the line so the bulbs are powered all the time, and leaving the load on the switch empty. I then made the bulbs mirror the switch. Bulbs turn on/off with the switch and dim with the switch as well and the LED indicator still functions as normal to show the dim level.

The downside is in case of hub failure the switch won’t function, but if that does happen and it’s urgent I can just hookup the load wire again, only takes a few minutes to flip the breaker, pull the switch out and reconnect 1 wire.

I’m looking for the exact same thing! Coming from the HomeSeer WD200, I bought the Inovelli thinking it would work exactly as you also want: (1) Turn off the relay control while keeping the load powered and then (2) the switch still functions as a dimmer sending the appropriate on/off dim level messages to the hub as well as reflecting the dim leve on the switch’s LED. Then, I can easily configure the hub so my smart bulbs mirror the dimmer switch state.

Hardwiring the load on and capping off the load on the switch works except for the downside you mentioned: hub failure. In that case I was hoping I could press configure 8x to turn the relay back on and control the switch.

Is this likely to make it into a firmware update?


I’ll chime in here too since I posted about similar behaviors that I found (see https://community.inovelli.com/t/red-series-dimmer-lzw31-sn-observations-and-comments/2046/5).

I didn’t play with parameters 14 and 15 so I was never locked out of the LED control but what I will say is that it is a p.i.t.a. to program around. That said, having the LED bar track a bulb level is the easiest part.

Generally speaking (because I’m using OpenHAB and not everyone does), when there is a change in the bulbs brightness, you can send a command to the switch’s dimmer channel. That will set the LED level. So for example, when I run a scene to a group that has my 4 Kasa bulbs- setting them to 5000K and 75% brightness, the 2 red dimmers (for 2 of those bulbs) will eventually get a command to set their dimmer channel to 75%. Another example… if run a scene to turn the iLumin bulb to 100% color temp (2700K) and 30% brightness, that switch eventually gets a dimmer command to go to 30%.

By triggering updates this way, the LED bar will always track regardless of how you set the brightness- software control or switch control (which is the p.i.t.a. part if the relay is disabled).

1 Like

This is what I was hoping for too when I purchased four dimmers. The ability to control the load on/off, and have a faux dim-level to have my smart bulbs follow (Lifx, Hue, Tradfri).

The dimmer interface is slick! I would like to be able to use that interface with my smart bulbs. For my application disconnecting the relay is an excellent first step - that definitely helps keep smart bulbs powered. In addition, I’d like to be able to configure a dimmer to have electrical dimming disabled making it effectively a simple on/off switch from an electrical perspective. I’d want the switch to still maintain a virtual ‘level’ that the LED strip and zwave ‘level’ value tracks with but no change in the electricity provided to the load. Is this already a requested feature?

Wouldn’t this virtual dimming functionality be needed for dimming ilumin bulbs too?

My switches have firmware 1.35 on them.

Same here. Lots of Hue bulbs on dimmers and I’d like the LEDs to match. Right now with remote control disabled (because Google Home, mostly) and the load on the dimmers, it doesn’t work.

I’m confused by this: the HomeSeer doesn’t support disabling local control on the dimmer, and their staff seem quite confused in their forums why anyone would want this feature. Unless they’ve changed something recently (I haven’t checked), you can’t use the HS at all like the Inovelli with local control disabled. If you use them without it disabled (the only way you can use both with the same configuration), the they behave identically. :slight_smile: The only way you could trick the HS into doing this — which would work on the Inovelli, too, but make sure it’s not violating code in your area — would be to hardwire line and load, effectively disabling local control (but unfortunately also the air gap). Then “dimming” or turning on/off the dimmer/switch will get the desired result on the LED bar without affecting the load.