ZigBee Fan Switch | Project Zephyr (Blue Series)

Okay, found an issue… I can’t edit the LED intensity in home assistant. It does not seem to be an option. I like to sleep with the fan on, and the LED is very bright at night.

Same. Using HA + ZHA and, like other users also mentioned, missing attributes and the switch type still shows as a light. The “quirk” seema to be applied, too.

I don’t know about other platforms (Hubitat/etc), but this specific configuration is rough. I consider it as alpha, and hoping updates address some of this

1 Like

I haven’t gotten to a chance to install the new ones but my beta one, on Hubitat, I’m able to adjust led brightness. I’ll try to get one installed today and test, but pretty confident it’s not a firmware issue.

This is all I see on mine:

There’s a github issue tracking support for the Zephyr on ZHA. It looks like someone tried to mostly reuse the one for the 2-1 switch to get it working quickly. Obviously it’s not quite right yet.

I see comments from Inovelli on the github issue, can we assume they are working on it, or is that something the ZHA community will need to fix?

Just as an FYI to everyone @EricM_Inovelli is currently out of office (and the country!) so he will be a little slower to respond to some of these issues. I believe he returns mid next week and we can work further on addressing issues then.


Yeah, the parameter isn’t shown in the UI, probably due to that bug that poptart911 mentioned; however, you can still set the parameter directly: Settings → Devices & services → the “… Devices” under Zigbee Home Automation → click on the fan switch → Device info card, the ⋮ to the right of Reconfigure → Manage Zigbee Device. Change the Cluster to Inovelli_VZM35SN_Cluster, select the attribute you want to change, such as led_intensity_when_on or led_intensity_when_off, enter a Value, then click Write Attribute.


Worked great! Thanks!

1 Like

Still need a way to get the switch to be read as a fan, and not a light though. Being read as a light causes issues with Google Home integration.

1 Like

ZHA has a cool option that will let you change the device type (note even with the type being fan, it shows up as a switch at first but you can change that too, see below starting from the device page).



Then you can just exclude the old entity from Google Home if it’s also showing up.

1 Like

I dont see a “show as” option…

The switch is on the “light” domain, not the “switch” domain like yours.

Wow this is awesome. I had no idea. I don’t see the option in the UI either, so I tried using the YAML instructions in the ZHA documentation you linked to. Unfortunately it doesn’t seem to convert it to a fan.

Here’s what I tried:

     84:71:27:ff:fe:93:17:24-1:    # format: {ieee}-{endpoint_id}
       type: "fan"              # corrected device type

In the meantime, I created a second entity that takes the fan switch “light” and creates a new dedicated fan entity. I wish I didn’t have to have a second entity, but it works well in the interim. Here’s what I did in case anyone else wants to do it too:

- platform: template
      friendly_name: "Bedroom Fan"
      value_template: "{{ states('light.bedroom_fan_switch') }}"
      percentage_template: >
        {{ (state_attr('light.bedroom_fan_switch', 'brightness') / 255 * 100) | int }}
        service: homeassistant.turn_on
        entity_id: light.bedroom_fan_switch
        service: homeassistant.turn_off
        entity_id: light.bedroom_fan_switch
        service: light.turn_on
        entity_id: light.bedroom_fan_switch
          brightness: >
            {{ ( percentage / 100 * 255) | int }}
      speed_count: 3
1 Like

Does anyone know (or even better, has anyone tested) whether these will work for florescent lights when run in the on/off configuration? Mine came in yesterday and I have spots picked out for 4/5 but still trying to figure out what to do with that 5th one.

They are not compatible with ballasts. In theory you could rip out the ballasts and install ballast bypass bulbs (LEDs).

Edit: @jetpacktuxedo Did you mean to comment on the Light Switch or the Fan Switch?

I meant the fan switch, as I was already 99% sure that the light switch wouldn’t work for the same reason that DC motors don’t work with those (high startup current I think?).

I figured the tweaks that allow the fan switch to work with DC motors (like bathroom vent fans) might also allow for turning florescent ballasts on/off but was hoping for confirmation before I tried it.

I get what you saying since it handles the load differently. Based on this graphic I think it’s a no go with the fan switch.

I understand your logic and this might be one of those cases that is officially NOT supported but might actually work. HOWEVER…

I would seriously consider converting your old ballast fluorescents to the non-ballast LED tubes as suggested by @stu1811. It’s an easy process and allows you to keep the existing fixture/hood/shroud. And it would be officially supported with a smart light (not fan) switch.

I did this several years ago and never looked back. Like it so much better.


I have installed one fan switch so far and noticed that the LED’s on the Fan switches are much brighter than that of the 2-in-1 blues. Has anyone else noticed this?

And it uses less power saving you money to buy more toys :smiley:

1 Like

Yes. There might be settings to control this, haven’t had time to look into it.