3 way and 4 way wiring with dumb switch woes

I am using the Blue Series Smart 2-1 in on-off mode.

I followed the guide below

Here’s a diagram of my wiring situation
Red is line/load, green is traveler.

S1, S2A, and S3A are Inovelli switches
S2B and S3C are way dumb switches, common is the top left terminal
S3B is a 4 way dumb switch, common is both left side terminals

There are 2 circuits, 3 smart switches, 3 dumb switches, 3 light groups. Note: I didn’t mark the ‘common’ terminals on the 3/4 way switches in the diagram, but they are wired correctly.

From the bottom of the diagram:

Circuit 1 has 2 light groups; a set of 4 room lights, and a single wall light.

The set of 4 room lights is marked as L1 in the diagram controlled by the switch marked as S1.

S1 is an Inovelli switch and working as expected.

The single wall light is controlled by the switches marked as S2A and S2B.

I put another Inovelli switch at S2A
I wired it up as described here

S2B is a 3 way switch - Leviton Decora 15 Amp 3-Way Switch White R62-05603-2WS

This setup doesn’t work at all. The Inovelli switch doesn’t affect the light, but the dumb 3-way S2B turns the light on and off. The Inovelli switch is setup as 3-way dumb in HA. The Inovelli switch does react to changes in HA such as turning the notification LED on/off, color, etc.

Circuit 2 has 1 light group; a set of 3 lights controlled by 3 switches.

S3A is the Inovelli switch.

S3B is Leviton Decora 15 Amp 4-Way Switch White R58-05604-2WS
S3C is Leviton Decora 15 Amp 3-Way Switch White R62-05603-2WS

I have it wired up as shown here

The first time I wired this, I had the 4-way wired wrong and popped one of the Inovelli switches. I fixed the wiring, and when I tried again with the Inovelli switch I had in S2A the switch didn’t get blown but the up paddle felt stuck. I could press the down paddle and hear a click, but the up paddle won’t click at all.

The switch is setup as 3-way dumb in HA and again it reacts to HA changes.

The other two dumb switches sorta work, some combinations of on/off work but others case one of the lights to quickly turn on/off. I had a similar issue with the S2 light group, but replacing the LED bulb in the fixture fixed that issue.

What am I doing wrong here? When I replace the Inovelli switches with dumb 3 way switches both light groups work as expected without any obvious issues. I even took out my phone to see if the lights were flickering weirdly in a unnoticeable way.

Check to make sure that you did not push the ground wire in too far. Try backing it out some. If it’s pushed in too far it will interfere with the paddle’s operation, causing the issue you described.


Did the ground wire hack fix the issue? Is this one on the the 3-way? 3-way now working?

Hey Bry,

I haven’t had a chance to test that yet. Planning to do it this weekend, I’m dealing with Zigbee network woes also so that’s been my main focus during the week.

But I think you’re right, I do remember the ground wire going really far in and hitting something. I’ve had similar issues with other switches and it was stupid late when I was dealing with this and completely forgot to check that.

so I think you’re right on that issue, but still confused about what I did wrong with the simpler 2 switch 3 way setup for S2/L2.

Okay, circle back when you get the other stuff unhosed and we’ll see if we can figure it out.

1 Like

Hey sorry for the late reply, you were correct about the ground wire being too far in.
That solved the stuck up paddle issue, but now the L3/S3 circuit is behaving weirdly.

The switch is powered on and connected to my zigbee network and accessible from HA.
I have it setup as 3 way dumb, on/off, smart bulb mode off, and everything else default.

Hitting the paddle doesn’t do anything, I don’t hear the relay clicking on and off but the notification LED goes up and down. The switch state also changes as expected in HA.

The lights on the other hand don’t change at all. Flipping S3B and S3C’s state turns the lights off, but one light flashes quickly on and off repeatedly until the switch is returned to its previous state.

I have it wired exactly as described in the diagram below

Ok, just to recap/confirm, this is a 4-way, right?

What are the L3’s? All the same?

How did you set the switch’s settings in HA? HA makes my head hurt, so I’m going to defer to someone else to ensure your settings are correct. The reason I’m asking is because I suspect that they may be incorrect. You believe that the switch is set as on/off, yet your LED bar “goes up and down”. It shouldn’t . . in the on/off mode, it should just go on and off.

So you may be in the dimmer mode, which depending on your bulbs may not be bad. But if that parameter is set incorrectly, the switch type . .i.e 3-way dumb may be set incorrectly as well.

I’ll take you at your word that the switches are wired correctly . . . for now.

Correct this is the 4 way, and all the L3s are the same LED light bulb below.

I’m using ZHA to get the switches into HA, the switch comes up as a device in HA and I changed the settings from there. That works with the other switches, but I realized I can using the config button to change those settings too. I will try that soon.
Edit: nvm, seems like the instructions I found were for older switches.
Edit 2: Found how to program the 2-1 switch without HA, tried that and no dice still same problem.

The weird thing is I had to hold the DOWN paddle + 5x config for purple/violent lights. Up paddle + 5x config gives me like a blue-ish white blinking light. I have the switch mounted with the config button on top so I assume the paddle that’s next to the config button is “up”.

I quadruple checked the wiring, I also used a tracing tool to make sure it was the correct wire on both ends. BUT I’m not going to rule out the human factor either.

The bulbs you are using are non-dimmable. So if your switch is acting like a dimmer, that will cause an issue. Do you have a dimmable bulb that you can swap in temporarily? That will confirm if the Inovelli is acting as a dimmer.

If your LED bar is still going up and down as you press the paddle, then you are not yet in the on/off mode.

Yes, that’s correct.

@chack @stu1811 ZHA help?? ^^

1 Like

I will get some dimmable bulbs and test out later this week.

When I tried again I noticed the notification strip doesn’t dim down, it does go from fully lit to mostly off when I click the paddle buttons.

Ok, that suggests to me you are in the on/off mode. When off, the strip may be illuminated dimly.

Let’s see what happens with the bulb swap.

In the meantime, someone will help you double-checking settings.

I’m using z2m on my production network. If no one else knows i might be able to resurrect my zha coordinator on my test bench after racing tomorrow. :sailboat::sailboat::sailboat:

I tried Z2M last week and unfortunately it was giving a ton of trouble with the Juno canless lights, ikea usb repeater, and a couple of my aqara sensors. Ahh I hope I’m not stuck between a rock and a hard place due to my choice of end devices.

To swap between dimmer and on/off it’s just a matter of going to the device page and swapping the output mode option, same as the three way dumb option, etc -



Yup this is exactly what I did when I setup the switch again yesterday, still have the weirdness of the switch not being able to change the state of the lights, and flipping the dumb switch causes two of the three lights to turn off, and one of the three lights flashes on and off. Note this isn’t flickering, the light turns off quickly turns back on and then turns off, it repeats this for ever.

1 Like

All three of your lights are powered together. So when the switch set sends power to the lights, you should expect the same reaction out of each. The fact that the bulbs are not doing the same thing suggests a bulb incompatibility. See what happens when you swap them out.

What firmware are you running?

Or a wiring issue from what was presented. Have you tested sufficiently to KNOW the wiring is as you’ve shown on the schematic?

Based off ZHA and home assistant the firmware is 0x01020208

Will be swapping the bulbs out sometime this week, is there any specific bulbs you recommend other than dimmable?

I traced each individual conductor (hot, neutral, and traveler) to verify the diagram I made, the whole group works as expected once I replace the inovelli switch with a dumb 3 way switch.

Wondering if you were able to get some dimmable bulbs. The problem above will sometimes happen when there is interference on the traveler from the light load and it causes the Inovelli to get confused. The solution is to lower the max level a little at a time until it stops. You can usually do this with non-dimmable bulbs and it doesn’t cause issues, but dimmable bulbs would be better.