Anyone manage to add the LZW45 using ZWaveJS?

I am trying to get everything moved over to ZwaveJS + Zwavejs2MQTT, but am having some issues with the LED light strip. Every time I add the device, it doesnt seem to get through the node interview, and the zwave network seems to get saturated with traffic (zwave logs grow by about 1MB per minute).

Has anyone else had trouble? I know there is no config file yet, and I started working on creating one, but I cant add the device to test anything.

I think until there is a driver created specific to the device, you are out of luck. @EricM_Inovelli would be the one to know how to make that happen, BUT he is really busy and adding yet another “platform” of drivers is going to take a bit I believe. We also need one for the multi-endpoint LZW36 Fan/Light.

I was able to add it to the same configuration on my network after pulling the JavaScript file from this active pull request.

I will admit it took some perseverance and honestly I don’t know why it took as long as it did.

Here is how I solved it for my docker setup

  1. Clone or download and extract the ZwaveJS repo node repo
  2. Merge the branch in question from the pull request. Optionally, you could just create the file if that’s more your speed.
  3. Update volumes with mapping to the node repo
      - ./store:/usr/src/app/store
      - ../node-zwave-js/packages/config/config/devices:/usr/src/app/node_modules/@zwave-js/config/config/devices
      - ../node-zwave-js/packages/config/config/devices:/usr/src/app/node_modules/@zwave-js/server/node_modules/@zwave-js/config/config/devices
  1. Restart the docker container
  2. Remove the device from the network, or reinterview

Here’s the important part… walk away from it. I tried this entire exercise for hours to no avail. It kept hanging up on the interview stage. Finally went to sleep and woke up and my HomeAssistant acknowledged the new device. The integration isn’t perfect (laggy at times) but at the very least it’s available.

I did something similar except that instead of mounting the whole devices folder I just narrowed down to


z-wavejs is very flaky for me. even with the multi-color bulb which supposedly supported (the file is there).

What are you using to update the config? I had loaded ZWaveJS2MQTT through the HA add-on store.

We’re modifying the volume settings inside the docker-compose.yaml file. I’m not experienced with the HA add-on store but I seem to think that also uses docker but is less flexible for this sort of configuration.

If you find a way into terminal access, then you would want to import the that device profile. Hopefully things are resolved soon on the Pull-Request and you won’t need to take an alternate path. The conversation has moved into a different pull request 1676 from my last post with some recent activity a few hours ago.

Hey guys, just wanted to let you know that we have an offline conversation going between developers/inovelli and this product (along with LZW36 fan/light switch) has been/will be implemented in the coming days. So for those who don’t want to get into the weeds, the fix should be coming VERY soon.

but there is an outstanding issue:

So just give it a bit of time and it will all work great without the deep dive.

On that note - anyone who wants in on this convo and/or can help, feel free to let me know and I’ll add you to the convo.

1 Like

I wouldnt mind being part of the conversation. Not sure if I will end up being helpful, but I will help out any way I can

Not much left to the convo TBH. The LZW45 fixes have been merged into zwave_js, I’d expect it to fully work within the next few updates of the ZwaveJS/ZwaveJS2MQTT Addons.

1 Like