Blue 2-1 with HA - immediatly turn lights on but dim slowly when turned off


Could one point me in the right direction to enable:

  1. Turn lights on immediately (from HA automation)
  2. Dim lights to off in ~5 seconds (from HA automation)

I have tried multiple combinations of RamRateOnToOffRemote with other settings such as DimmingSpeedUpLocal, etc. without success.


Thanks in advance,

Ramp rate is what you are looking for:

Parameter 3 is ramp rate off to on remote - set to 0.
Parameter 7 is ramp rate on to off remote - set to 50 (for 5 seconds or 50 * 100 = 5000 milliseconds).

Confirm by reading back the parameter once set.


I can’t check till later but you can put a transition parameter into the automaton to set the time as well. I have lighting I transition over a long period of time doing this to gradually turn the lights on as the sun sets.

Yes, it seems that the HA transition parameters for the light must somehow trump or work with the Blue light switch ramp/dim settings. I will need to test this our. Sort of like 2 different feet on the gas or break pedal.

I assume it would work with the blue switches. It works with the red ones. It works with esphome lights which is where I use it every day.

Does not work with Z2M.
See this thread

Although it appears to work with ZHA as well as Hubitat. Likely an issue with the Z2M converter.

I am having the same issue here. Using ZHA and the remote params for dimming speed and ramp rates just work erratically or not at all.

For ZHA, in the ZHA settings, Global Options, “Default light transition time (seconds)” overrides the switch’s ramp rates for remote level changes. It’s kludgy, but if you set Default light transition time to 6553.5 seconds, it’ll use the switch’s settings.

1 Like