Blue Series issues - fails to config on-switch or in ZHA. Smart bulb mode not working - binding not working

Hi everyone,
It has been quite a frustrating evening to say the least and I’m unsure of where to go next. I recently got around to setting up my replacement blue 2-1 switch after I had the routing/connection issue but am having quite the challenge getting this new switch working.

Wiring: Multi-way with AUX (3 way)
Environment: Home assistant (HASS OS) 2023.1.2
Zibgee integration: ZHA
Zigbee radio type: ezsp with 20 working devices on it
Switch Firmware: 02.08

In this location previously was a red series dimmer that I wanted to move so my new blue series could control my hue lights directly so I popped out the red series and put the blue in. At first I could config the switch to dimmer on the device (orange flashing) but no other configs would work (down + 5x config for multi-way aux for example), including setting up smart bulb mode. I did get it to pair pretty easily and the settings actually changed correctly and the switch was mostly working (it could change brightness of the hue lights in smart light mode).

Next I tried to set up binding in ZHA so my hue lights could work with the switch without the hub.

At this point I try to reconfigure in ZHA but get an error so I:

  • Pull the air gap and let it reset
  • Restart home assistant
  • Factory reset (I think) the switch by holding up and config until the bar is red (about 30 seconds) trying to get back to square one.

However now I can’t get anything to work properly (except on/off mode as if it was controlling dumb lights) and have errors trying to set to config parameters on the device in Home Assistant (error message of “failed to call service TurnOn” for trying to turn on smart bulb mode).

Is there another trick to factory resetting that I’m missing? I’ve also tried to hold config only until it turned purple but that didn’t do much either.

Weirdly, the switch that had the reception issues (that this new one was replacing) has firmware 02.00 and I can see ControlLevel endpoint 1 and everything could theoretically work - but the reception issue with it means I can only set it up right next to my HA box.

I feel like I might be missing something glaringly obvious but have spent quite a bit of time on the forum here, r/inovelli, r/homeassistant, and good old google and can’t seem to find a way to get everything working

To factory reset you need to include the top paddle as well.

Start by factory resetting the switch. Press and hold the config button and then while holding the config press and hold the up paddle. Wait for the LED to turn to red, then release config, then the paddle. You’ll see the switch cycle through colors and start pulsing blue. That will get you back to factory fresh and the paddle will work to operate the lights.


I have done this already a couple times. I tried the air gap to restart the switch, then restarted home assistant to see if that would do anything and then did the factory reset holding up+config where it goes green, yellow, and then red, and released after it had been red for a couple seconds.

The just holding config was something I just tried to see if there was any other result I could get

The original issue if I’m reading it right was you want to set up binding from the switch to the Hue lights, is that correct? In that case, you would want to bind from EP2 of the switch to EP1 of the group/lights so that is working as intended. You’ll likely have a spinning circle when you hit bind that doesn’t complete, that’s fine though it should still apply.

The current issue is that you can’t control the switch at this point, is that also correct? Can you remove the switch from HA and then factory reset the switch again and rejoin it ‘fresh’? If that works (it should) then you should be back to square 1 and able to go through config settings again.

The original issue is correct - I got the spinning circle but it never seemed to apply, at least in a similar way to the youtube video from the previous threads showing binding from you all (but I’m tabling this right now).

Currently I have tried to remove from HA, factory reset, and re-add but it will not config correctly.

  • Also tried restart HA, rebooting the hardware im on (miniPC), and just turning off power to it and letting it start.
    This is via the UI through ZHA and on the switch with the config options from the card in the package (e.g. I can’t get it to accept up paddle + config 5x or turning on the setting in ZHA).

Understood, let’s focus on getting you working again. Generally speaking the recommendation would be to stick with configuring the switch through the hub (ZHA in this case) as it’s simpler and easier to make sure it works and the config ‘takes’ vs using the paddle commands, etc.

So for clarity, you can successfully remove the switch from HA, factory reset and then re-join it to HA? It shows up in HA with the right quirk (the VZM31SNv12 you had in the original screenshot)? If so, can you turn on/off the load from the hub as well? These should confirm the basic communication with the switch.

Does the switch also manually work? It turns load on/off, etc? Ideally button presses should show up in HA logs too?

Thanks for the help so far - this morning the switch started to come in under a different name/quirk and not all parameters were syncing (only about 10 were). Additionally a lot of zigbee devices were showing weird behavior that they weren’t showing yesterday so I’m going to troubleshoot my zigbee hub first. I’ve had a combo zigbee/zwave stick for a few years now and now have separate sticks on the way to see if it might be hardware first.

I just switched back to the red dimmer since this light is in my office and I’ll need it working. I’ll be sure to update the thread when the new devices get here and I rule out any zigbee hardware related issue

I’m having the same issue. My replacement switches that shipped with firmware version 2.08 do not list LevelControl with Endpoint 1 under bindings, only Endpoint 2. Under device info the quirk lists zhaquirks.inovelli.VZM31SN.InovelliVZM31SNv12

I have another switch still on version 2.07 that does show the correct endpoint. Its quirk is zhaquirks.inovelli.VZM31SN.InovelliVZM31SNv11.

Not having an issue with smart bulb mode. That is working correctly.

2.08 and that quirk are working as intended. Firmware changes were made to bring it into alignment with the Zigbee specification and works that way for ZHA and Z2M both now. You should be binding from Endpoint 2 of the switch > Endpoint 1 of either the group or bulb(s) depending on how you’re looking to control them. If you were adding the switch to a group, that would use Endpoint 1.

Thank you for the explanation.

@chack - So looks like it could have been a hardware issue elsewhere. I ended up moving to a new zigbee stick over the weekend and re-set up the network. The grouping and associations worked perfectly.

To anyone else coming across this thread:
When I couldn’t get the behavior to work properly I did a factory reset on the switch (hold paddle up + config button. The LED bar will go green, then yellow, then red, once it is red release) and continued to have odd behavior on the switch. At the time all other zigbee devices were working fine but over that evening (after I had removed the switch from the wall and “gave up”) more problems showed up within the zigbee network. I ordered a Sonoff Zigbee stick and a new USB 3.0 extension cable and that sorted it out. So if you have a similar issue check your hardware as well.

1 Like

Glad it’s working for you now! One note, if you’re going to use a USB 3.0 extension cable, you should plug it into a USB 2.0 port if you have one. USB 3.0 can cause interference so either using a 2.0 cable or a 3.0 cable on a 2.0 port will both help (ultimately the extension itself should help some as SSD’s, etc can also cause interference, but you may still have issues if it’s 3.0 on 3.0).

I’ll keep an eye on it. So far it has been lightning fast and the mesh is strong, but I probably have a few 2.0 cables laying around somewhere as well.

So according to this thread, How To's | Setup Zigbee Binding - Home Assistant (ZHA) is a bit outdated, as we want to bind to endpoint 2 for the switch. That is working for me and was my primary confusion.

It seems that home assistant will spin and spin, but the binding is in fact there.