Can anyone help me create an assocation between a red series dimmer and ilumin bulbs?

I have saw this post that walks through creating an association in smart things, but Im struggling how to do this in home assistant exactly.

I have all three devices (one switch and two bulbs) paired in home assistant and they work, but the z-wave control panel is a bit confusing when it comes to assocataions.

Thanks in advance!

@jtronicus @doublepedaldylan @EricM_Inovelli – can you guys help here when you have a free moment? I’ve been meaning to get a page setup as well in the Knowledge Base.

I no longer use the built-in version of zwave for my Home Assistant Setup, but I found a post with screenshots that can hopefully walk you through the process.

For my Red Series dimmers/Ilumin bulbs, I set up associations on groups 2, 3 and 4.

  • Group 2 gives you on/off control
  • Group 3 also gives you on/off control (it seems to work fine if you dont associate this group, but it doesnt seem to cause any issues either way)
  • Group 4 gives you dimming functionality

Dont forget to disable the relay on the switch (config button x8).


@jtronicus thanks for the reply. So would I set up all three devices (switch and two lights) on al three groups?

Just the two lights would need to be added to all 3 groups (the groups belong to the switch, so you cant group a switch with itself)

So I might be a bit confused. Do I initiate this from the light switch or the bulb? I also noticed theres atually 4 groups for the switch (the bulb only shows lifeline)

Groups work one way. Basically, you are setting up the switch so that the physical button presses control your lights directly via zwave. You only need to set up the groups on the switch (not the bulbs)

The Lifeline group is typically used to communicate status changes back to your hub. Only the Hub needs to be in the Lifeline group, and it is automatically set when you include devices you no changes should be needed for that group.

It should look like this:

|   +---Lifeline(Group 1)
|   |   +--Hub
|   +---Basic_Set (Group 2)
|   |   +---RGB Bulb 1
|   |   +---RGB Bulb 2
|   +---Switch_MultiLevel_Set (Group 3)
|   |   +---RGB Bulb 1
|   |   +---RGB Bulb 2
|   +---Switch_MultiLevel_Start/Stop (Group 4)
|   |   +---RGB Bulb 1
|   |   +---RGB Bulb 2
+---RGB Bulb 1
|   +---Lifeline(Group 1)
|   |   +--Hub
+---RGB Bulb 2
|   +---Lifeline(Group 1)
|   |   +--Hub

Keep in mind that once you set up your associations, you do not want to control the switch itself in Home Assistant. The Groups/Associations are for the physical buttons on the switch. If you try to control the switch itself in HA, you will end up cutting power to the bulbs.

You will probably also want to set up a light group in HA in order to control both RGB bulbs at the same time:

  - platform: group
    name: Kitchen Lights
      - light.rgb_bulb1
      - light.rgb_bulb1

Thanks for dumbing it down for me. So I went to the switch and then added it to Group 2 controlling Bulb 1 and it worked. But then when I try to add bulb 1 to another group…it doesnt seem to add it. Any ideas?

Edit: So I have the relay disabled and on/off is working perfectly now. But Im just struggling to add it to the other groups so I can get dimming to work

Edit 2: NVM. Got it working! Thank you so much! This works amazingly well.
I had to spam the add button a few times. Once both switches had it added to all three groups, they work great. Im so stoked

Seems like you got things figured out, but I did create a “How To” for those looking in the future:

Awesome. One question, I noticed once I disabled the relay the LED strip goes to (seemingly) max brightness and despite adjusting the setting, it doesnt seem to change. Is that normal?

Yes, that is normal. The LED indicator shows what brightness the dimmer switch is set to. In order for the smart bulbs to work, the dimmer needs to be set to 100% with the relay disabled. This means the LED is always on bright.

1 Like

Sorry if this is a bit OT, but this seems to be the right place to post.

If you setup association between LZW31-SN and iLumin bulbs, can you configure the dimming speed/ramp rate, etc?

From what I can tell, either the switch is not passing a “duration” to the bulb to tell it how fast to ramp up/down, or the bulb is ignoring the value. I have not been able to figure out how to get transition times working.

Since I prefer my lights to turn on instantly, I just used association group 2 (basic set) instead of group 3 (multi-level set).

Association Group Group Name Behavior
1 Lifeline Needs to point to your hub (should already be set)
2 Basic Set Will turn on/off bulbs instantly
3 Multi-level set Bulbs will transition on/off. Unable to configure transition time
4 Multi-level start/stop Needed in order to dim bulbs by holding the on/off buttons

You do not need to associate in both groups 2 and 3 (either one is fine)


Cool. That confirms what I’ve experienced.

The chart you posted above is interesting. It specifically mentions group 3 “unable to configure transition time,” so that answers my question. Where did that chart come from? Was trying to learn more about association and that helps.

Is there any issue with having 2,3, and 4 set?

I have two seperate dimmers, each paired to 2 ilumin bulbs. About 70% of the time, they work great and turn on/off both bulbs at the same time. The rest of the time, one of the bulbs wont turn on (or off) and often I have to turn the switch on and off (or vice versa) 2 or 3 times before both bulbs will activate. Any ideas about this?

That chart is just my own observations. From what I have researched, both the bulb and the switch support COMMAND_CLASS_SWITCH_MULTILEVEL version 2, which should mean it supports a transition time. I dont have any other brand zwave switches to test with though, so I havent been able to pinpoint the root cause.

I havent had any issues with 4 bulbs using association, but I do occasionally have slowness when controlling multiple bulbs simultaneously in Home Assistant, especially when changing the bulb color. I dont necessarily think it is a problem with the bulbs though. When looking at the OZW log file, I can see a lot of network traffic. I think Openzwave is sending extra commands to the bulbs and it is flooding the zwave network. These are my personal observations though, and nothing is confirmed.

1 Like

@jtronicus Cool. That’s helpful to know. Thanks!

@pizzapants i think you mean issues with setting group 2, 3, and 4 associations, not the quantity of bulbs right? If so, yes, that will still work, but you may lose dimming on/off because group 2 will instruct the associated devices to behave with binary on/off.

In my case, i’m using group 3 and 4 associations. The result is I can dim the bulbs and when I turn them on/off they ramp up/down respectively (However, the speed of dimming doesn’t seem to be configurable).

Yeah, I think I misread @pizzapants question. I am using group 2 and 4. I have full on/off and dimming functionality. My lights turn on and off instantly (without a fade in/out), but I can still dim the lights by holding the paddle buttons down. I cannot control how fast the lights dim up/down when holding the buttons down though.