Can't get Smart Bulb Mode to work between Inovelli dimmer & Inovellli smart bulb

So I’ve got my Z wave association set up between my Inovelli Dimmer & Inovelli Smart bulb, but no matter what I do I can’t get them to function in Smart Bulb mode. I can create a Smart Lighting association and it will function through the hub, but I want the switch to communicate directly with the bulb so it’s not dependent on a network connection. . I’ve confirmed they are both paired as secured and the steps appear to set up and take for the z wave association, but that never functions. Any pointers or direction would be greatly appreciated to resolve this as I’ll also be using this setup in my fixed recessed can lights where they also have a constant power supply. Thanks in advance for any help/assistance.

Can you let us know which hub you’re using?

Aeotec Smarthings V3

Make sure bulb and dimmer and joined with the same security level. The bulb supports S0 or none.

Can you take a snap of your parameter settings and toggle the smart bulb mode to off then back to setting 2? I want to make sure the bulb gets always on power.

The bulb always has power. It’s in a fixture that used to be a pull chain hence why I want to use smart bulb mode.

Ah. So the switch isn’t controlling the bulb socket load? What is it controlling?

Right, I want the switch talking directly to the bulb in real time via z wave association. I’m thinking it may be the secuity level. The show Ls but the dimmer says in it’s settings * networkSecurityLevel: ZWAVE_S2_AUTHENTICATED while the bulb says * networkSecurityLevel: ZWAVE_S0_LEGACY From the other response I’m assuming these need to match?

Hey @BenJF3 – first, I just want to let you know you aren’t crazy!

There seems to be an issue with SmartThings where they are essentially either blocking Associations now or there’s a bug in one of their latest updates. We are reaching out to their team.

We didn’t catch this bc all of our existing associations are working, it wasn’t until I saw this thread and tried myself with a brand new association that we discovered there’s something wrong.

I had this convo with @EricM_Inovelli last night:

It’s been a crazy ride with ST we fixed the S0/Non-Secure issue with SmartThings when they changed it up a few months ago… now they pull this lol.

Hang tight, we will get to the bottom of this.

Ahhh ok! I was getting frustrated beyond belief (not with you guys, but myself) thinking I was missing something here. I went with ST for one reason only - WAF lol I’m debating if I should have went with Hubitat now ugh

The S2 Auth vs S0 is definitely a problem in addition to any ST issues.

This is 100% not going to work. Get them either both off secure or match the switch to the bulb (S0_LEGACY). Not secure will be MUCH faster.

Ok, question is how to do that? I did the repairing multiple times but it ends up sitting with those protocols. Also, Eric chimed in that there is an issue in ST at play here as well. That said, I’d at least experiment with trying to align the security setting with some direction.

Lol, it’s ok. I figured the frustration was at an all time high – and with the WAF contributing to the cause, that only exacerbates it haha!

I hate finding out about these things through customers as I can’t imagine the frustration of following all the directions and it still not working and then you think it’s a you problem, when in fact, there’s nothing you could do, it’s something on the hub side. I love SmartThings, but man do they love to, “break” things every other update.

Yes, @BenJF3 – when we do confirm with ST what’s going on and they do fix it, I’ll go over the various security levels with you to make sure both the switch and bulb are on the right one (should be non-secure). I’ve tried this personally and ran into the same issue as Eric M noticed last night.

During the pairing of the switch, and it asks you to scan the QR code or something, exit out of the QR code scanning and it should default to non-secure.

On the bulb, when you are pairing the bulb, turn it on/off/on/off/on/off quickly and it should pair in non-secure mode. I will also take a quick video today to help illustrate it.

1 Like

IF you are on ST, you have no way to update the firmware so you are stuck with S0 solution.

As Eric said, when including the switch when it asks for the S2 qr code, just ignore it and exit or whatever, it should then default back to S0. Hopefully it doesn’t do S2_Failed or whatever.

ST is the reason I have smarthome stuff and Home Assistant is the reason I have a SMART home. Very different things.

1 Like

Same thing here

1 Like

@BenJF3 – our very own @EricM_Inovelli has been working on this all day and modified his device handler to work around ST’s update. It’s bringing back memories for me as 4.5 years ago this is exactly how I met him… ST broke something with our 2-Channel smart plug and he was just hanging out in the ST forums minding his own business and I put out an SOS to help and he volunteered to fix it. I sent him the product overnight and within 24hrs of me sending it out, he had it fixed and let ST know what happened on their end lol.

Can you overwrite your device handler with the new code and try the associations again?

In the meantime, Eric let ST know about this and is waiting to hear back. We’re hoping they can just fix it on their end as this is a workaround and may not be feasible for long-term setups, but it will work in the meantime.

3 Likes

When I attempt to overwrite the code or create a new devive handler for the switch I get the following error:

org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:
script_dth_metadata_bbce8830_906d_4c2f_b087_533222e32430: 1636: unexpected char: 0xA9 @ line 1636, column 1.
© 2021 GitHub, Inc.
^

1 error

@BenJF3 the code only has 1635 lines. Did you append by accident instead of overwrite?