Cause/Fix for Slow or non-responsive commands going through Hubitat with Red Dimmers and Fan+Light

So I’ve been having one issue that I keep posting but never seem to get any definitive answer to over at the Hubitat forum (and I think I’ve posted here before too) - which is that sometimes my switches that are only connected via a neutral and line, and are being used in a virtual 3 way, take like what seems 20-30 seconds to turn on, or else just never turn on at all. Likewise, I have the same issue with the config button on the Inovellis having the same issue (i.e. I push the config button - a “7 held” in the Hubitat apps) and nothing happens or it takes forever for the action to be completed. I don’t have any issues with switches that are controlling the actual lights directly.

What I’m totally unable to figure out, and which I’ve never gotten an answer to, is what is causing the problem? Are the switches not sending the proper command to the hub? Is the hub not receiving the command? Is the hub receiving the command, but failing to send it to the switch? Is the receiving switch not responding to a properly sent command?

Virtually all of my devices are Inovelli Red Dimmers with 5 of their fan+lights, a couple of Aeotec 7 Range Extenders and a couple of Aeotec 7 plugs. I am using a Hubitat C7 hub running (I am mentioning the other equipment just to give a complete view of what I have).

I tried a Z wave repair. That seemed to help for a very short bit. I tried turning off energy reporting (setting param 18. Active Power Reports to 0). That seemed to do nothing.

After doing the above the situation was as bad, if not worse than before, particularly with a couple of switches. Alexa would also say “ok” but then not do anything when I said to turn those lights on.

So I did an air-gap on those devices. That seemed to work for a day or two.

As they started misbehaving again I even did a controlled shutdown, and then pulled the plug from the wall (not the hub) waited 30 seconds and then powered up again. That didn’t seem to help at all either.

I did notice that once they do turn on, they seem to turn off rather instantly and then, for a while, will turn on virtually instantly. So it seems like the turn on command is either not being sent properly to the hub or the hub isn’t properly sending it to the switch that is physically connected to the light or the receiving switch isn’t properly reacting to the “on” command.

I usually see the LED go up to 100% when I push the switch, but the light is not coming on - or again - takes an insanely long time to come on. But, not always. Sometimes pushing the switch to turn on doesn’t even make the LED show it is on.

I am using Switch Bindings instead of an association as the red dimmer called the Wegitorium is controlling the light on an Inovelli Fan + Switch, which will not work via an association (like I could with 2 red dimmers). I’m also using Switch Bindings as it seems there are no real clear instructions on doing an association with Inovelli red dimmers as at first it was associate “groups” 2 and 4, now it seems to use 3 and 4, and it isn’t clear which dimmer should get param 12. Association Behavior set, and what to set it to. (And even if that would fix my (Stuart’s) closet, I would still have the problem of not being able to do an association with the red dimmer and fan+light). BTW, all of this had been working for a good couple of months. So I don’t know why it started to become so problematic.

I don’t know how to really read the logs but here are a few shots of what happened when I tried to turn the Wegitorium and Stuart’s Closet Near Right Side on. If more/other screen shots or setting info is needed, I will, of course, be happy to post those as well.