Consistency with Red Series Dimmers w/ Hubitat / Google Home

Hi everyone! I have 11 Red Series Around my house. Love the look and configurability. However, after 2 years of having these installed, I have to constantly reset, pull airgap, and google home + hubitat only works maybe 60% of the time.

I have 3 in my kitchen that are particularly finicky. None are 3 ways, and they control a pendant row, 2 sconces, and under cabinet lighting. All LED bulbs and when they work the dimming is fine as well. There’s also one in a half bath that just gets stuck on or off and I have to pull the breaker to reset it.

They just aren’t very responsive, they seem to freeze all the time, and hubitat / google home rarely are able to turn them on and off consistently. I don’t have any complicated automations set up or anything, and have configured them in a relatively minimum setup.

Has anyone else experienced this? Did I get a bad batch? I really want to stick with the brand, but at this point I just want my lights to work consistently.

Freezing should not be a regular occurrence. I have a couple (out of many) that have had to pull the air gap once or twice over the last several years, but that’s about it. Not sure what causes that, but since you have a responsiveness issue, I’d tackle that first as that might be where the freezing is coming from.

I’d start by checking logs to see if the hub actually sent the request to the switch when you have a failure. Just because you tell Google home to operate the switch doesn’t mean the hub passed the request on to the switch, or the hub even received the request. In other words, is Google Home working properly with Hubitat? What happens when you send commands via Hubitat instead of GH? Do those work 100%.

Then I’d look at your Zwave mesh. Have you tried a Zwave repair? Do you have dead nodes (or whatever Hubitat calls them).

What you are experiencing isn’t’ common, and AFAIK, there isn’t a “bad batch” of Gen 2s.

There are a number of Hubitat power users here that can help you tracing your issue if you have questions.

1 Like

Thank you for the prompt response. I’ve tried reading trough logs, but I’ve noticed GH → Hubitat always receives the message. However, even when controlling directly through hubitat, just going on → off multiple times in a row I can get the switch into a weird state. Will try repairing the mesh and see how that goes.

After repairing the mesh I have 4 failed nodes. I also noticed that half of my switches are associated with S0 security while some are not. Is this an issue?

I don’t think the mixed security matters for switches that you are not associating, but someone that uses Hubitat maybe able to further comment.

A lot of those look like they take an awful lot of hops to get back to your hub. Not sure if that is normal for Hubitat or not.

@harjms @mamber Hubitat . . .

So I got rid of my 1 ghost node, but it still looks like the ZWave routes are very long. I’m considering setting all of the security to none, since it sounds like S0 might be sending extra data. Even after removing the ghost node, and repairing the mesh I’ve still seen it get slow / unresponsive.

Probably couldn’t hurt.

I had similar experiences with Hubitat and Zwave, mostly with the Innovelli light bulbs, less so with the switches. But absolutely get rid of security, if you can. I finally had to get off Hubitat when my Zigbee network went so haywire that moving to a second Hubitat box failed to fix the issue, and support couldn’t help. When I migrated, I set up Z-wave using zwavejs2mqtt, but the bigger change was that nothing except for door locks has security of any kind enabled, and… Magic, rock solid.

S0 is chatty so only use it on devices which require it.

However, I’m in the camp that uses S2 for any device that supports it on both ST and HE (C7). I don’t care about the encryption features, but instead the full CRC checksumming that S2 offers on connections less than 100kbps. I have no issues with mesh stability and don’t notice any other side effects except firmware updates on a device take a lot longer under S2.


I’m on Hubitat and I have a bunch of Inovelli switches as well. About 8 Red series and some older ones as well as some GEs. With the exception of 1 switch, the Inovelli’s have been 100% reliable. The one switch that wasn’t, was connected to a bath fan (which is a no-no) and I had to routinely pull the breaker for that one. So for the one that you have to pull the breaker, what does that switch control?

As for security, my Red Series are generally “S2 unauthenticated” and I have one “none” for a zwave association with another device. A bunch of other zwave devices are “none” with 3 “S0”. I’d avoid S0 because I’ve heard of overhead (maybe I should change those 3). Unfortunately, to change the security, you need to unpair and pair the device and add it back to any automations.

As for the Route, it doesn’t look that bad. I have a bunch with as many hops and about the same speeds (40kbps and 100 kbps). Do you have problems with the “Kitchen Sconce Dimmer” (0B)? That one looks like it’s directly connected to your hub (01).

Have you tried moving your hub closer to those devices or have it in a very central location? You’ll need to do a zwave repair (not the repair for the one device).

Do you have any 100% reliable switches? If so, you could swap it out temporarily with the one of the “bad” ones and do a zwave repair. Then you could determine if it’s the switch or if it’s the location.

maybe try a “soft reset” on the hub?

Make sure the “z-wave” region matches your country on the “Z-wave details” page.

Google Home is not a reliable way to test. Use the web interface for testing reliably.

The only issue that I ever have now with Inovelli is an occasional (few seconds) sluggishness when double/triple/etc tapping with scenes to control devices. This I suppose is the fault of Hubitat and not the switch.