Dimming in Smart Bulb Mode

I’m trying to set up dimming at the switch in smart bulb mode in home assistant but the way I have it configured right now, holding up/down on the switch dims the bulbs in a step rather than continuously while it is being held. I have to release and hold the switch again to get to the next dim setting. Also, the status bar on the switch does animate smoothly while it is held but it is not indicative of the actual dimness of the bulbs being controlled.

If someone could help me out with this I would greatly appreciate it!

Are the bulbs zigbee too? If so, use binding rather than automations. Are you using z2m or zha?

I did a similar automation with a loop to decrease the brightness.

trigger: hold down
trigger down released
mode: restart

If triggered by: hold down
decrease brightness a little bit

The bulbs are zigbee too, when I try using binding, dimming still doesn’t work and I get some other weird artifacts such as some lights not turning on every time so I’m not sure if binding is fully supported by these bulbs. I’m using zha.

I tried setting this up and it works a little bit but doesn’t seem consistent. Would you be willing to send a picture of the setup that you have? I feel like I may have missed something in mine.

Which bulbs

They’re Sengled flood lights.
These ones.

I have some sengled A19 bulbs. They work ok but seem to struggle when you do several commands in quick succession.

I switched to using the config button to trigger a dim scene instead and liked that better. My bulbs were wifi, so I didn’t have binding as an option. Zigbee binding should in theory work way better.