Fan/Light Switch

I just received my pre-ordered Fan/Light switch red. I can’t seem to get it to work on my hunter pull-chain fan. Instructions are strangely simple to install but when I try to pair the wall switch remote with the fan module, I get the flashing green lights followed by a red light and I can’t control the light at all…nothing, not light no fan movement.

Can someone suggest some testing routines…I’m beginning to wonder if I got a bad switch. The stage of the light is 150 Watts…so I should not need the bypass.


The pairing is between the wall switch and your hub, not between the wall switch and the canopy module. Are you following the pairing instructions for your hub? What hub are you using? Also, if it’s Smartthings, which app?

Thanks for replying. Regarding the pairing, I am following the instructions to first pair the canopy module and the switch (RF pairing), that is where it is failing. Here is how it is wired annotated:


Regarding the pairing, I am following these instructions that came with the switch,

Specifically, these instructions are, STEP 3
“Press and hold Button D and press Button E 3x. If successful, the LED bar will blink Green.
You should now be able to control the fan speed and light brightness from the switch manually. Press Buttons B & E to turn the fan and light on and off, and hold up and down Buttons A & D to change the fan speed and light dim level.”

When I follow these instructions the flashing Green led lights finish with a final Red flash. According to Inovelli this means the wattage of the light is less than 25watts and therefore the light needs a bypass installed but this is not the case, my light is 150 watts (incandescent).

Did I get a bad canopy module or something? Note the voltages measured and that if I jump around the module, the fan lights come on…it appears the amperage out of the canopy module is restricted.

Ok. I understand. I’m not sure why you can’t re-pair the switch and canopy module, but they come paired from the factory and normally, you shouldn’t have to do that step. Was the switch not communicating with the canopy? i.e. switch installed but not working at all. Pretty much everyone that has an issue with the switch gets it working immediately but it has issues after a period of time.

Hi Bry,

You understand me correctly. Yes, the switch was not communicating with the canopy. I even changed the light dimmer up and down while measuring the Canopy Module blue wire voltage and it never changed.

Switch is installed and get nothing at all…not fan light and not movement from the fan motor.

My very best,

Hmmm. I’m wondering if it got un-paired while trying to pair it even though you probably didn’t need to. Now it won’t pair.

Hopefully someone with experience pairing the switch and canopy can respond. Not sure how many have had to do that. @tfberg has an issue where one of his switches is communicating with two fans and he has to re-pair, so perhaps he can comment.

Thanks Bry. I bought 5 switches so, maybe I will try one of the others I bought. I looked at @tfberg community topic and it looks like the Inovelli CEO responded to him and told him to do what I have already done in “Step 3”.

I am beginning to think I got bad switch(s). Thanks again Bry for responding!

1 Like

OK. I tried a new switch/canopy module and it worked perfectly. The problem was that I had a bad switch/canopy.

1 Like

I am having a similar problem with my pull chain and submitted a ticket but since it is the weekend I may find the answer quicker here. In my situation though I do not have a light installed on the fan so I simply capped the blue wire. Based on your comment

According to Inovelli this means the wattage of the light is less than 25watts and therefore the light needs a bypass installed

that might be where my problem is.

I have two switches, the first I had the same issues as you, no fan movement so I tried to pair the switch in the module, got the teal (green?) pulsing lights and then a red flash. I also could not pair the switch to my hubitat hub (blue pulsing lights and a red flash). So I swapped it out for the other switch I had and was able to pair it to hubitat but again not able to pair it to the fan module. I checked the second module with a voltage pen and can confirm that it is powered. I also took the module out and hooked the fan back up and it works as expected.

While it is possible I have two bad modules, does the light wire need to be connected? I had reached out to Inovelli prior to placing the order and Eric indicated:

…the module doesn’t require it to be hooked up to a light wire at the fan so capping it off shouldn’t have any negative effects.

So I do not think the light needs to be connected.

@Bcaswell90 I do not know if the light needs to be used for the fan switch to work. Sorry, I can’t give you an answer. I have not tried to do what you are doing.