Firmware for Target 1 fails after 0 went through (zwavejs2mqtt, 1.48, 1.41)


I have successfully updated a handful of Red Dimmers using zwavejs2mqtt to 1.48/1.41 already, but now I have one that refuses to update Target 1, after Target 0 has already been updated.

The error message I am getting is something like “this device doesn’t support target 1” or “firmware update already in progress” when I try a 2nd time.

I tried restarting the driver and re-interviewing the device, but that did not help.

Any ideas what steps to try next?


Agreed. It has to be a ZJS2M bug because I am having the same problem.

I updated 5 or 6 dimmer switches successfully before that one, though. It might have been an older version, though. Maybe I’ll try to roll back one version and try again.

Agreed, I’ve done 100+ firmware updates to both targets. I think its the software that is the issue, not the switch or firmware.

What Version ZWaveJSToMqtt? They just updated to ZWaveJS 8.0.5 so there could be a bug.


Not the same Vendor, but seem similar issue it seems. Also looks like the same version you are on.

Bug created:


Big fixed, should come over soon. Easy change.


Thanks for investigating & reporting!

I am on zwavejs2mqtt-addon 0.23.4 now, which should be ZwaveJS2Mqtt v5.4.5 according to the changelog, but I still can’t update target 1 on that one Red Dimmer. Could it be a hardware problem too? I remember having other problems with that one wall switch.

hmmm - strange. I was able to upgrade all 27 of my switches on an older version of zwavejs2mqtt on HA without issue.

Have you tried using the 'official updater to rule zwavejs in or out? Found here. If you have a windows laptop, its pretty simple to shut down HA, pull the USB stick, and use that on the windows machine to do the updates. You can skip all the exclusion/inclusion steps because your zwave usb has the device map already.

That might be a way to narrow in on hardware vs software problems.

Yep I opened it back up, he fixed it (again) and closed it again, but we will have to wait for the next rev for it to work. It was confirmed working by another contributor who actually built a new docker installation and tested with the actual switch though.

Should be soon ™.

1 Like

@jhein release was posted 5 hours ago if you have docker and want to build up your own temp installation outside of HA.

Probably a day or two away from frenck posting the HA add-on version.


@jhein update is posted.

1 Like

@kreene1987 worked like a charm this time. THANK YOU!