Flashing lights in 3-way Blue + Dumb

I was trying to wire up a Blue switch into a 3-way circuit yesterday and was experiencing a strange flashing in some permutations of the smart and dumb switch (forgot which specifically :worried:). I don’t think it’s a “flicker” where individual bulbs are kinda rapidly changing in brightness; this is the whole lighting circuit going mad. Some switch states it’s solidly on, some off, but others…:

ezgif.com-gif-maker (1)
(mp4 version)

The switch was configured to be an on-off switch in a multi-way (toggle) setup with the ‘pre-setup’ button presses, and the wiring is as follows

I tried swapping the load and traveler lines (though it shouldn’t change anything, they’re equal to the dumb switch…) and retightening all the wires into the Blue switch, but no change, still the flashing.

You may need to get the hamster to maintain around 3600 rpm on the wheel to prevent flicker.

I hate to ask, but did you set the parameters via a hub vs local configuration? I feel there’s been higher amount of misconfiguration due to paddle configs vs hub config.

I’m in a similar situation. Sometimes when I turn on the lights, I hear 3 relay clicks, and the lights goes on-off-on very quickly. But it only flash once - which is different from your symptom.
It doesn’t always happen. And only happens sometimes when my dumb mechanical switch is in “down” position.
I’ll add a video later today

I set the “3-way dumb” behavior both thru local ‘config button’(when I first received the switch) and thru homeassistant-ZHA UI (recently). I’m using on-off mode. I have neutral wire (at least I believe so - hopefully I dont have a wiring error)

Configured with the config & paddle buttons. Hadn’t even tried to connect it to a hub yet. The colors it flashed me (red for on/off & violet for multi-dumb?) were what I expected. @xiaoqiao mentions configuring it both ways, should I try to connect to my Hubitat and configure that way?

It’s probably right. do you have a bigger neutral bundle in the box? From the video, I see large RED bundle which looks like line, but I don’t see as large neutral bundle (normally I would see about the same amount of wires in a wirenut).

Edit: I would definitely recommend adding it to the hub and configuring the parameters that way. When I installed 12 on Saturday, I didn’t even bother configuring locally. I waited to restore power, add the switch to the hub, configure said switch and continue to the next switch.

1 Like

You can try but in my case it didn’t solve my problem :sweat_smile:

Yes. I’m with @harjms . Setting the parameters via the hub is more reliable, IMO.

1 Like

@Alphahelix QQ: do you hear relay clicking sound when the light is flashing?

Sharing this issue with the engineers. Let us know if you have any additional info about the problem.

1 Like

No relay clicking with the quick flashing. Sometimes there’ll be a click with a button press.

Without touching the other switches (found the same problem on a 4-way, I uninstalled the 3-way because of the flashing), just pushing on/off on the Blue, it can go from off to flashing to on and back and such.

Witness meeee Flashing Inovelli Blue in multiway - YouTube

@EricM_Inovelli more details:

Hubitat reports:

Current States

  • auxType : Dumb
  • energy : 0.0
  • held : 1
  • lastButton : Release ►
  • level : 100
  • numberOfBindings : 0
  • numberOfButtons : 14
  • power : 69.2
  • pushed : 14
  • smartBulb : Disabled
  • switch : on
  • switchMode : On/Off

State Variables

  • parameter2value : 127
  • parameter21value : 1
  • parameter5value : 127
  • lastCommandTime : 2022-Nov-01 11:26:09 AM
  • parameter8value : 127
  • powerSource : Neutral
  • parameter258value : 1
  • manufacturer : Inovelli
  • driverDate : 2022-08-14
  • parameter22value : 1
  • model : VZM31-SN
  • fwVersion : 2.00
  • parameter3value : 25
  • parameter52value : 0
  • parameter6value : 127
  • lastEventCluster : ON_OFF_CLUSTER
  • fwDate : 2020805
  • lastCommand : On
  • parameter51value : 0
  • parameter23level : 100
  • parameter15value : 101
  • parameter7value : 127
  • parameter23value : 0
  • parameter4value : 127
  • lastEventValue :
  • powerOnState : Previous
  • lastEventTime : 2022-Nov-01 11:26:09 AM
  • parameter1value : 25
  • lastEventAttribute :

Just wanted to quickly say that we’ve received a firmware file (literally 30 min ago) that should address this issue. Eric M’s testing this right now (as he was able to replicate it) so hopefully (fingers crossed) it will fix this.

1 Like

Any ETA on the firmware? Days, weeks? Need a beta tester?

I believe @EricM_Inovelli uploaded it to Hubitat’s server so I’m not sure how quickly they will deploy it. They’re usually pretty good and get it up in a day or so.

While we’ve tested and confirmed the fix, this firmware hasn’t been widely tested, so I want to let anyone know who’s reading this that if you experience any side-effects of the new firmware, please let us know. Also, if you don’t have this issue, there’s no need to download the firmware.

Edit: If you have Home Assistant, shoot me a PM or reach out via tickets and we will work with you on the fix. There’s unfortunately no manual way to push this firmware (if we upload to the server, it will automatically start downloading on your switch and we don’t want that right now with beta firmware).

Was this pushed out to Hubitat yet?

I believe so. There should be a button on the device page that says, “Update Firmware” or something like that. Click on it twice and it should automatically start.

Let me know if you have any issues!

1 Like

I’m still a Hubitat noob, but I think I’ve updated the software to 2.05 and still getting flashing. Is the fix beyond that version?

I get the flickering as well on 2.05 using a dumb switch. Taken it out for now. will wait on more updates or just use it for a different switch in the house. Or i might just get the aux addon switch.

What version is this supposed to be fixed in? 2.05? 2.08? 2.11? other? I’m now at 2.08 and still get blinking, though it seems to be slower than it used to be. Not 100% sure.

  • powerSource : Neutral
  • manufacturer : Inovelli
  • driverDate : 2022-11-05
  • model : VZM31-SN
  • fwVersion : 2.08
  • fwDate : 20221110
  • lastUpdateFw : 1668529397133

  1. Aux Switch Type
    Set the Aux switch type.
    3-Way Dumb Switch

(though it is in a 4-way, but I don’t think the switch can tell the difference?)

2.05 was the initial fix for the bulb flashing. If yours is still flashing, you may want to share bulb brand and model number so it could potentially be tested. Have you tried different bulbs?

1 Like

The flashing is slower and sometimes there’s a delay before it starts now. I’ll check out the light model number when I get my ladder back :stuck_out_tongue: