How do I prevent the switch status (on / off) from impacting the LED bar with local control on?

I have a number of Red Series Dimmers throughout my house. I use them to control lights (some regular, some smart), do all kinds of things with Rule Machine and for notifications. I love the dimmers and have done some cool stuff with them.

One fun trick I found was to use the config button on these dimmers as a sort of “alt” or modifier button that gives me the ability to add even more activations to the switch using conditions in Rule Machine. For instance, normally two taps up turns on all the lights on the same floor as the switch, but if I press the config button, a virtual switch called music control is toggled. While that virtual switch is on, two taps up skips the current song on the nearest Sonos. Normally holding up increases brightness, but when music control is toggled, it increases volume. Pretty neat! The LED bar on the switch changes to chase blue when music control is on and stays green when it is off so you know what it will do.

Anyway, the notifications are pretty important to me too as I use them to tell me that status of my window and door contact sensors and HSM:

  • Normal status (all contact sensors closed, HSM disarmed) is solid green.
  • Minor alert (one or more contact sensors open, HSM disarmed) is fast blink yellow.
  • Major alert (HSM intrusion detected) is fast blink red.
  • HSM armed is chase red.
  • These notifications are all set to always-on—the notifications don’t change until Rule Machine tells them otherwise.

This works exactly as I intend on dimmers that have local control disabled because they operate smart bulbs. The LED bars default to green (they are set to green and 100% on or off in device preferences) and Rule Machine activates the notifications as above. The state of the dimmer switch is irrelevant and that’s how I like it. Turn on or off the switch turns the smart bulb on or off but the current notification is uninterrupted.

But it doesn’t work quite right on dimmers that still have local control enabled because they operate dumb bulbs. The LED bars default to green (again, set to green and 100% whether on or off) and the notifications are activated by Rule Machine… but turning the dimmer switch on or off interrupts the notifications and turns the LED bar green. So even if Rule Machine has turned on minor alert (one or more contact sensors open), the LED bar turns to green as soon as the switch is toggled.

Is there anything I can with preferences or even with Rule Machine to “disconnect” the switch status from the LED bar so it doesn’t reset my notifications or to override that behaviour?

Thanks in advance for any advice!

1 Like

what an incredible use of these switches. I absolutely love what you did here.

That’s a really great use of scenes… Alternates!!! Love it!!!

Okay so to your question So are you saying that on the dimmers that control regular bulbs (non-smart), interacting with the switch turns off the notifications to that dimmer? What rev of firmware are you running on these dimmers? If it’s 1.35 you may want to update the FW (both targets at this point).

An alternative to notifications would be just setting the “regular” LED color. You’d sort of be trading one issue for another since the size/height of the LED bar light corresponds to the brightness/level of your lights, but you wouldn’t have to deal with interrupting a notification LED when you adjust the dimmer (though as hinted at above, that is addressed with newer firmware — it will go back after however many seconds). You also wouldn’t get effects, just a solid color, but maybe that would be good enough for some things. Maybe that’s what you’re already doing with the regular vs. music control…I can’t quite tell. If not, something to consider! (If so, then ignore me; it sounds like what you’re doing already is probably good and the firmware might address this.)

Also, like everyone above, I freaking love the idea of using the config button to temporarily adjust the behavior of the dimmer! (I was fixated on the idea of just making the config button itself do something, but this doubles the possibilities instead of just adding one!)

Thanks everyone! These switches are amazing and are really the centerpiece of my home automation setup. I sort of lucked out figuring out that the config button could be an alt button—glad that everyone likes the idea!

So I’m using the notification effects (mostly fast blink for alerts and the Cylon-style “chase” effect for HSM and music control) and would love to keep those so I would prefer to continue using the notifications rather than directly setting the LED strip via the child device—but it’s an option if I can’t figure out my ideal scenario.

Looking at the firmware history, it appears that 1.41 introduced the enhancement you’re all referring to:

Notifications no longer turning off when user adjusts the level or performs various other actions on the switch.

I’ve updated to 1.45 using the Z-wave update community app for Hubitat, which is greatly convenient but does not appear yet to support the Holtek chip as a target for the .bin file. I’m going to test the switches now to see how the behave while turning on / off and dimming during notifications—but if anyone can answer the following questions, I’d appreciate it:

  • Will I get the benefit of the above mentioned enhancement made in 1.41 if I haven’t updated the Holtek chip?
  • Is there a device preference I need to change to leverage the enhancement? I have the most recent driver installed in Hubitat.

Thanks again—I can see there is a great community built here around a great product.

Yes, you will. I don’t know if anyone has determined what the .bin file does for this update. I have updated all mine to 1.41 (.otz file only) for the issue you have described.

I personally have been tempted to update to 1.45 which adds the ability to set the LED color to white. However, with that FW update, the .bin file would be required. I’ll probably do that as soon as work calms down a bit.

Nope! Nothing to change. You’ll just see the LED reflect any switch changes, briefly, and then the Notification goes right back to what it was.

Good news! Thanks to your suggestions, I updated the firmware and was able to achieve the behaviour I wanted using the device preferences. The relevant preference is LED Strip Timeout. With LED intensity set to anything above zero, the LED strips will display the default colour (Normal status in my setup) and revert to that colour whenever the switch is adjusted—unless the LED Strip Timeout preference is set. That preference defines how long the strip will default upon adjustment—from not at all (Stay Off) to a number seconds (up to 10). I’ve set it to Stay Off and now the LED strips always respect the current notifications and never change in response to switch use. Perfect!