Internal Relay default state

Hey all!

I’ve got a LZW30-SN in my media room with Lifx smart bulbs. I’ve got it set with the internal relay off so that a single-tap on or off tells OpenHAB to turn the smart bulbs on or off. Works great.

Right up until we have a power outage. Any time the power flickers for so much as an instant the switch resets itself and re-enables the internal relay, forcing me to physically go to the switch and do the 8-tap, up-tap, 8-tap dance before the lights will turn back on.

Needless to say, this does not meet the wife/houseguest acceptance factor. Especially in the power-outage season. :slight_smile:

I have had these switches for a while, so I’m not sure if this is something that is fixed with a firmware update perhaps? I definitely want to add more switches, as most of the lights in my house are smart bulbs, however a sub-second power flicker causing me to have to go through the entire now-dark house re-enabling switches isn’t the outcome I’m looking for.

Any thoughts on this? Solutions people have found?

This might be a bit of a workaround, but can you trap the power fluctuation events that cause the switch to cycle? If you can, then you should be able to create Disable Local Control child devices and reset all your switches immediately after an event.

Confirm parameter 1 is set to 0 or 1

It might be set to 2 somehow.

Isn’t that for the physical state? I’m thinking any re-enabling of the relay is hosing his scene controller.

I read his problem as the switch powers off (de-energizes the load) his smart bulbs when an outage occurs. Parameter 1 should set the state to “on” but leave local control disabled if set properly.

OpenHAB reports that it’s state is 0.

But I’m thinking that’s for the power state assuming the relay is on, which for some reason it’s defaulting to not?

That is correct.

During a power outage, the switch disables the load, leaving the smart bulbs without power when the house power returns.

To solve this I have to 8-tap the config button, then turn the switch on with an up-tap (causing the lights to come back on), and then 8-tapping the config button again to switch back to local control disabled.

I’d recommend changing it to another value and back and/or checking at the switch (refer to manual).

On my dimmers (I don’t have any switches) when I set the corresponding parameter and the power goes out, when power returns the dimmer goes back to the state it was (level 56 for example) when power was lost. This is on both dimmers that have local control enabled AND disabled. Should be independent.

edit: I have some set to come back on at 99, some back on last state, and some back to level 0 or “off”. All work as expected based on the parameter.

I misunderstood but got it now. I think @kreene1987 is correct. I’d set parameter 1 to “1” because you always want the switch to return to a powered on state. I don’t have any switches with smart bulbs, but just tried it with regular ones and it’s working as advertised.

In the interim, you don’t have to re-enable at the switch. You ought to be able to turn the switch back on via Zwave or however you do it with HAB. I’m presuming that you don’t have remote control disabled. This will save you from having to go through the local control re–enable/disable thing in the interim.

Turning back on via ZWave will also allow you to do something similar to what I first suggested should you not be able to get the core issue resolved.

1 Like

I’ll try jiggling that parameter to see if I can get the switch to default to powered on. If I can get the relay to default into an “on” state when the house power returns then the home automation scripts should take care of the rest!

I’ll report back with results.


After changing the parameter to make sure it’s at 1 I popped the breaker for the room and turned it back on, simulating a power outage.

After the breaker was back on:

  1. The smart bulbs were powered-off, not on wifi.
  2. The switch itself does absolutely nothing. (seems that it’s sending commands to openHAB, which is unable to turn the lights on or off as they are hard powered-off)
  3. 8-tapping the config button and then pressing the up-paddle turns the lights back on (by enabling the internal relay and restoring power to the bulbs)
  4. 8-tapping the config button again puts the switch back into local control disabled, but with the relay in the on position, allowing OpenHAB to control the lights once more.

So it would appear that parameter 1 doesn’t help here. I suspect that it simply controls the on/off state of the relay when the relay is enabled. However since the power-outage leaves the relay stuck in the off state, this doesn’t do anything at all in my case. That’s my assumption anyway.

Is it possible my switch is just defective, or too old or something? If other people aren’t seeing the power failure while in local-control-disabled cause the relay to stick in the powered-down state I’m even more curious.

If this is how it’s behaving then it is likely a driver error or hardware failure. The feature is SUPPOSED to be independent of the local control setting. On my dimmer with local control disabled (again more of a scene controller than anything) it powers back on to 99 every time, sending power to the bulbs. I have the bulbs set to off, but I know they are on as they are responsive and sending logs.

Have you updated firmware on the switch at all? Version? If on latest firmware (not sure for switches) this might be a firmware bug. I’ve not run into anyone else with this issue.

Do you have a second switch that could be tested or exhibits the same behavior?

I have not updated the firmware of the bulb. OpenHAB shows the zwave properties of the item and indicates that zwave_version is “1.9”. I see that the website has 1.19 (beta) as the downloadable firmware, so I may be 10 versions out of date? However I don’t see a changelog for firmware versions, so I’m not certain.
I’ll try and get set up to do a firmware update on the switch.

Zwave_version and firmware version should be different items.

Unfortunately OpenHAB is one I haven’t touched, so I can’t help much, but might be worth a second look to see if you are already on the latest.

Unfortunately I’m not seeing any other version information in the properties.

I also cannot update the firmware per the instructions provided by Inovelli as it appears that Silicon Labs no longer offers Z-Wave PC Controller 5.

I tested with local control disabled, so yours isn’t performing as expected. After you turn the breaker back on, before you touch anything, does your hub report the switch as off or on?

You can get the Silicon Labs PC Controller here. You’ll need to log in with an account.

Unfortunately all I get with that link, even after logging in, is “Please download either a Controller SDK or Embedded SDK before downloading Z-Wave tools. Contact support if any queries.”
I’ve downloaded their 700 Series Z-Wave Controller SDK (Simplicity Studio) to check. It does not appear to contain the PC Controller software, nor does having downloaded it allow me to download the PC Controller software via the link.

I think I get the PC Controller download link because I’ve logged in before. Take a look at this post:

Fantastic information about getting the PC Controller, thank you! Official docs need to be updated with that information, whoever we need to tell about that. :slight_smile:

Long story short, I’ve got it fixed and working as expected, a power outage now has the lights returned to a powered on state!
Something in the process of updating the device, having to remove and re-add it to the network after the update, and having to set it up again in OpenHAB with it’s new node ID managed to get it working!

Thanks for all the help, really appreciate it!


Awesome, can you select the “most” appropriate solution and mark as the solution so that this thread can show as “answered”?

Thanks and glad you got it working!!!