Is inovelli support usually this bad?

I recently installed a blue 2-1 switch and after a day, it fails to turn off. Two days ago, I followed the recommendations from the chatbot and gave it my e-mail. I haven’t heard anything since. I believe the switch is defective and would like to try another but haven’t heard anything. I can’t find any other way to try to get a replacement. It seems sort of shady that there’s no other way to initiate a return. Has anyone tried a CC chargeback claim?

1 Like

Have you tried a factory reset?

It’s not bad at all, actually. Ever, for the most part.

Inovelli is a company of like 4, maybe 5, employees. So occasionally your support request may not get attended to the same day, particularly, for example, if someone is out sick. Ask most here about there opinion of the company as a whole.

Plus, the proper approach when a switch doesn’t work would be to ask for some assistance here before simply trying to return it. There are a ton of people here willing to help. In fact, you got an almost immediate response with a suggestion.

So while there may be occasional chargebacks, most here wouldn’t. They know to seek help before giving up immediately. That’s just the way it works.

My opinion: First post here shouldn’t lead with “shady” and “chargeback”.

TLDR: You’re barking up the wrong tree . . .


It fails to turn off when you’re manually trying to turn it off, or when using a home automation solution like HA, Hubitat, or SmartThings?

1 Like

It fails to respond to anything physical or from the hubitat. I tried factory reset but no response either. The Led bar is dim blue and doesn’t change and the lights stay on. I do have neutral and ground and it’s just a simple one-way switch. The only way I can turn off is to pull the airgap.


@harjms , Yes. It’s unresponsive when I try. the lights stay on and the blue LED stays dimly lit and never changes.

I wonder if you have the local protection mode activated.

Hey @rentvent – sorry for the lack of response, I don’t see any open tickets, so I’m wondering if there’s something wrong with the way the bot is handling the inquiries.

Can you shoot me a PM so I can work with you? Or if you want to start the chat again, I’ll look for your message.

@rentvent – this is what is likely happening.

Can you try the following?

To disable Local Protection Mode (Parameter 256) on your Blue Series 2-1 Switch, hold down on the bottom part of the paddle (off) while simultaneously tapping the configuration button ten (10) times (do not let go of the paddle when finished tapping the config button). Wait for the LED Bar to flash solid red (and then let go of the paddle) indicating the switch has disabled Local Protection Mode.

Wow, ok thanks for posting that. Based on the other replies from Inovelli, you’re in good hands!

It would have to both local and remote, since it’s not responding to Hubitat, no?

Yes assuming the switch was included into the zigbee network with no issues. If it’s not failed, then perhaps there was an issue upon inclusion and just needs a good reset. It very well could be failed, but trying to look at all options.

Any chance of being installed incorrectly? Did you replace a 3-way switch (i.e. two switches control a single light, think of a hallway, with a switch on either side), or is it just a single switch in a room to control a light?

Did you ever get it to include in Zigbee, and then it stopped working, or you just installed it and nothing else happened? Sounds like either a faulty switch, or installed incorrectly, i.e. installed in a 3-way and kept the existing switch on the other end and didnt add the proper extention switch on the other end, this would keep power feeding to the light both ways and likely damage the switch.

@Eric_Inovelli reached out to me directly yesterday and we did some troubleshooting and believe that the switch probably has a bad relay. Local protection was on, but after disabling it, the lights still won’t turn off. Even after factory reset “off” still doesn’t work. This is a simple one-way application including neutral and ground in a plastic box. Hubitat never lost connectivity. A replacement switch is on the way.

I didn’t know that Inovelli had recently redone their support system and apparently it never created a ticket for my request or the follow up requests. I think there’s still some bugs to be ironed out before removing all other contact info on the main website.


Glad you got an answer to your post title, and that it was “No.” :smiley:


For what it’s worth, I had a similar experience within the last week or so. Incidentally, it was actually a similar issue with the switch (I had local protection turned on), but when I tried to contact support, I got the solution from the bot, it didn’t answer my question, so I chose to talk to a human. The prompts from the bot led me to believe that I was being handed off to email support, and that I should close the window and keep an eye on my email. When I tried again a couple days later, I realized I needed to keep the chat window open, and I’d be connected with someone there.