Issues with Inovelli Switches and Bulbs Losing Connection with Home Assistant zwave-js

I switched my home assistant zwave setup to use the new zwave js integration a few months ago. Since then, I’ve had persistent issues with inovelli switches and bulbs “graying out”. I’m unable to turn them on or off. If I click into the device within home assistant, the zwave info status shows “Device Ready: No”.

If I run a Re-Interview Device, the issue is resolved, but I have to do this a couple times a week. There seems to be no rhyme or reason when the devices seem to lose their connection. This doesn’t seem to happen with any other zwave devices on my network, just inovelli (which I have a lot of). Home assistant is fully up to date.

Has anyone else experienced this problem or have any insight into what might be causing this?

I do not, but I have had excellent luck discussing with the dev’s on discord. Highly recommend you get on the zwave channel over on the HA discord and ask the same question.

Mine haven’t gone to “Device Ready: No” status since I last restarted in checking my logs.

I’ll give that a shot. Thanks for the tip.

1 Like

I had this happen yesterday with 1 bulb. Then twice today with the same bulb and 1 other. Today I tried restarting the zwavejs2mqtt add-on and my bulbs were magically available again. May be a bug in the add-on.

I had a bunch more devices do this same thing today. The same bulb that’s now done it multiple days in a row. Plus 2 Inovelli red dimmers, 3 minoston outdoor plugs, 1 minoston indoor plug and 2 GE switches. Coincidentally all of these devices with the exception of the bulb are part of 1 automation. I triggered the automation which turns everything on then starts a 5 minute timer to turn it off. Everything turned on, but every device went unavailable before they turned off. I don’t think this is an inovelli issue. I didn’t copy the log, but when I checked it earlier it was something along the lines of sent command 3 times, marked device as dead.

@curtis what are you using for a controller?

That’s good info. Is it possible for a z-wave network to get “overloaded?” I dont know enough about how it works. I would think if there are a lot of commands fired off at once they would just queue up. It seems odd that it would cause commands to be missed. But, again, I don’t know the protocol. I have noticed occasional lagging when I turn lights on or off at times, particularly since I’ve switched to zwave-js, though I haven’t correlated that to the devices becoming unavailable. I’m using a nortek z-wave and zigbee usb stick (HUSBZB-1). I agree with you, I don’t think it’s necessarily an inovelli problem either, because I never had any issues at all prior to zwave-js. (Though it does seem to only happen with inovelli devices for me. I have a lot of leviton devices as well and they have been fine.) I just can’t seem to recreate this issue with any set of circumstances. As of right now, it just appears to happen randomly.

Did you heal the network? If a global heal fails to get them all then you may need to go through and do each device individually. I believe my network got better after doing this, about 30 devices give or take. There were some zwaveJS restart issues with devices not available and devices just becoming unavailable while it was running before I did it. I’m not using it for much automation yet though.

So last night I decided I was going the extreme route and starting over with my zwave network. With 30ish devices, this was no small task. I had several nodes on my network that were hanging around from a while ago that I could never get rid of in home assistant. Every time I would try to remove them, I would get an error. I am using the HUSBZB USB controller. I thought I could just change the keys in the zwave-js config that would assign the USB stick to a new zwave network. Apparently it doesn’t work that way. The node information is all stored on the USB stick so if you want to start over, you have to remove those nodes one way or another. If you aren’t getting errors removing nodes, you could do this from Home Assistant one device at a time for failed nodes or using exclusion mode for active nodes. This was not an option for me.

I found a method to reset the USB stick using Silicon Labs Simplicity Studio 5 software using a windows pc. (You need a free account with them to download)
( I can post instructions if anyone is in the same boat as me. But in short, for the HUSBZB stick, you need to apply the CP210 drivers to the device (also from Silicon Labs). Then I followed these instructions to get to the zwave control. Once you get that installed, there is an option to reset the device which wipes out all nodes.

I’ve added nearly all of my zwave devices back in, and the network seems to be responding faster and, so far, no devices have dropped into the dreaded “presumed dead” state. I’ll update in a couple days if all continues to work.

1 Like

The zwaveJS server doesn’t have the user interface like zwaveJS2MQTT, correct? In the zwaveJS2MQTT interface there are tool to deal with a dead node. I wonder if that would have helped you get rid of those nodes.

It’s not nearly as feature rich as zwavejsmqtt, but there is an option to deal with dead nodes in zwave-js. I did try zwavejsmqtt last week and wasn’t able to remove the nodes from there either.

Almost 4 weeks later after completely resetting my zwave stick and I can report that everything has been rock solid. Not a single device has dropped and the responsiveness of my zwave network has been much faster. I think it’s safe to say that I had some lingering issues with old nodes on my zwave network.

1 Like