LED Strip in zwavejs2mqtt

@jtronicus have you added inovelli light strip to Zwavejs2mqtt?

Yes, I just added it the other day. Im on zwavejs2mqtt version 1.2.2. Here are my observations right now:

  • Strip does not show up in HA (shows as unavailable). This worked in earlier versions of zwavejs, so I dont think this is a problem with the LED strip. As a workaround, I am controlling the strip in HA by configuring it as an MQTT light.
  • Partial config parameters are not showing up properly for me in the zwave2mqtt dashboard. Not sure if it is a config file issue or something else.
  • I am currently unable to set LED strip colors or white temperature with HA over mqtt. Home Assistant expects to set the RGB value as a single command, and the way it is set up in zwavejs2mqtt would require 5 commands to properly set the color. (A fix is coming for this in the near future though. Right now, I am just using the LED strip for on/off/brightness.

No visble in HA for me either.

I can set strip colors via MQTT (node red).

I can set whites but get an odd timeout where once I change it, I cant change again for 5-10 seconds.

What parameter are you changing in MQTT to turn it on/off?

zwavejs/nodeID_48/switch_multilevel/endpoint_0/targetValue/set to turn on and off. In HA, I have a light component set up like this:

  - platform: mqtt
    name: LED Strip
    command_topic: "zwavejs/nodeID_48/switch_multilevel/endpoint_0/targetValue/set"
    brightness_command_topic: "zwavejs/nodeID_48/switch_multilevel/endpoint_0/targetValue/set"
    brightness_value_template: "{{ (value_json.value) | round(0) }}"
    brightness_state_topic: "zwavejs/nodeID_48/switch_multilevel/endpoint_0/currentValue"
    brightness_scale: 99
    payload_on: 255
    payload_off: 0
    state_topic: "zwavejs/nodeID_48/switch_multilevel/endpoint_0/currentValue"
    state_value_template: "{{ 0 if value_json.value == 0 else 255 }}"
    on_command_type: "brightness"