Load level indicator Timeout

Loving my blue series so far. A couple QUESTIONS which may or may not be operator error… Thanks in advance.

Yesterday my dimmer was displaying load level without timeout. Today, load level disappears after about 4 seconds. However parameter 17 is set to “display load level with no timeout”. To trouble shoot, I’ve disabled all other related routines in case there is a conflict but visual load level continues to disappear on the dimmer after about 4 seconds.

Also side question, parameters 60ish to 90ish do not appear in smartthings but are in the instructions. Should they be missing?


Which Hub are you using?

With Hubitat, in the same situation, I would try a Configure → All


If that doesn’t work, I would reset the switch, discover it again (it will return to its initial slot), and do an “Initialize” and then “Refresh”.

I’m using smartthings. I don’t think there is a configure all option. Unfortunately resetting and re-adding devices means they get removed from routines, so sort of a pain. But I’ll give it a shot. Thanks

Missing menu items can mean the improper driver. Which one are you using?

If you are going to remove the switch, before doing so, add a virtual switch to your routine. Then delete the switch. The “extra” switch in the Routine will keep it from getting deleted.

Ok. I reset the dimmer using the air gap and the same issue reappeared. I have determined that the issue seems to be triggered by a specific routine.

I have a routine that turns on specific led notification if a door is open. I have a second routine that turns off the led notification when all doors are closed. The routines seem to work as intended, however when the second routine turns off the led notification, the dimmer does not resume showing the load level for its light. If you adjust the light manually the load level is visible for a moment but then dissapears, despite having parameter 17 turned on indefinitely.

So it seems like any routine that turns notifications off breaks the function for the dimmer to display it’s load level indifinetetely… Wondering if I have stumbled accross a bug? @Bry

Great tip about the virtual switch. Thanks! I am using driver version below. I think it is up to date?

I’m not certain about the date. Are you using the Inovelli Edge Driver or a default driver that ST loaded?

I am using the Inovelli edge drivers from the smartthings Inovelli channel.


@sdbigio Can you post a screenshot of the routine that kills the LED bar?

This turns notification on :

This turns it off:

At which point the load level does not reappear.

1 Like

I’m seeing the same thing.

@EricM_Inovelli - can you check this out on your end to see if it’s something firmware related or driver related (or both)?

I think I know what is happening. The “Off” effect is an effect that has all of the LEDs off. If you double tap the config button I am guessing it will clear that effect and return the LED functionality to normal. I’ll update the driver to map “Off” to “Clear” the LED since that is what is trying to be accomplished.

Edit: I pushed an update for this and tested it. I am not sure how to force an update to your hub but it will eventually update on its own.


TY. Looks like it pushed on its own. Problem solved.

Any thoughts on the missing parameters, 60-90?

Thanks for pointing that out. These parameters have not been finalized yet and actually weren’t supposed to be included in this firmware release. I’ve updated the manual.