LZW30-SN 3-way config with dumb switch not turning on (or off)

Hello guys! I am having a weird issue that seems to be tied to my particular red series on/off switch. TLDR: watch video below

Background: I have 6 red series dimmers and two on/off switches. Dimmers have all worked fine (except some potlight flickering that required a switch swap from another location). For the on/off, one worked great, while the other exhibited the issue found in the video below.

Basically, depending on the order I turn my dumb switch and inovelli switch on an off, I can either

  1. have everything work properly (if i turn off the light from the same switch i turned it on from)
  2. ability to turn on and off from dumb switch, but unable to turn off from inovelli
  3. ability to turn on and off from inovelling, but unable to turn off from dumb switch

I had a previous switch (same model) at this location that was working, and I confirmed this switch has same behavour on another circuit.

Unlisted video showing the behaviour: