LZW30-SN Turns on by itself / doens't work properly with three way wiring (but fine as single switch)

Hello friends. I’ve spent the entire weekend trying to get my dumb 3-way switch to work with the LZW30-SN. I’m fairly certain it’s wired correctly.

It’s for a big hanging light in my foyer (6 led’s) - so it’d be a pain to pull down the fixture and check the wiring there… but here’s what I know… The house is from the 60’s, so not the most modern wiring…

Box 1 (left)

  • Hot line comes in from a three way wire. Neutral is tied into a neutral bundle with some other wires.
  • The left switch is single pole and controls power to the top of an outlet on the other side of the room (for floor lamps I suppose)
  • The middle 2-wire circled in green take power from that first 3 way. I assume this wire goes to the bottom outlet - but not sure. Doesn’t seem relevant, but kept it in for completeness.
  • The right switch is the LZW30-SN. The old dumb switch had the line coming from the other switch - just like this one, so I left that. And the old dumb switch i replaced had the black and red of the bundle on the right as the transfer / travellers - so I kept that as is.

Box 2 - to the right of light. Here’s what I know:

  • The white wire is energized when the red transfer wire on the inovelli is sending power.
  • The black wire is energized when the black load wire is energized on the inovelli.
  • The red wire is attached to common, and I assume headed to the light to complete the circuit.

The behaviour when wired like this is:

The light will turn on and off mostly ok from both switches. However, when I power it off - it’s only off for a few seconds (Sometimes a second, sometimes maybe 10 seconds) but the invoelli always audibly clicks and light switches back on by itself. So the inovelli is providing the power to energize the light.

If I tun the inovelli off, it will just turn back on after a few seconds. If I turn the dumb switch off, the inovelli will just turn things back on after a few seconds.

The inovelli seems confused at times by the dumb switch and doesn’t always indicate (via the led) that the light is on, or off, and when the light is on, but the led indicates off - I need to push the inovelli to off, and then the light comes back on on it’s own.

Working as 2-way:
The inovelli switch will work absolutely fine and as expected as a simple 2-way wired like this:

As a single swtich, it’s works beautifully. As a three way, it just always essentially keeps turning itself back on.

The confusing part is that it absolutely seems to be working as it will turn on and off (thus actually energizing or cutting power as requested) it just doesn’t stay there.

Any thoughts? Anything else I can check/should check or try?

I had kind of the same issues when installing my first LZW31-SN in a 3 way configuration.
I spent some time removing everything and triple checking wire configuration.

Then I realized: the switch has to be configured to work in 3 way.
Once I changed the configuration it worked just fine.
I don’t know if it is the same for the LZW30 but did you check if you need to configure the switch first?


Yeah, unfortunately, I probably read way too much on the topic to the point where I’m more confused then when I started. My switch doesn’t have that setting - not that I can see.

There is a mysterious “parameter 13” that comes up from time to time in forums and posts - as maybe addressing the forcing of a 3-way setting - which I do have, but it’s called “load type” and my options are “auto detect” and “manually set for special load type”. I’ve tried both, and it seems to make it worse.

Once I set manual, there doesn’t appear to be any instructions on what to do with the manual setting - or what the manual setting does. This is probably the best I could find:

So I haven’t tried the new parameter (It’s only available on firmware 1.17+). The file used to name it special load T8 or something like that, but I think the name was changed to identify it as manual load.

I had a couple switches that did not work with the auto load define and ended up using AUX switches to fix my issue.

You’re not confused . . . the switches don’t have a setting to pick 2-way, 3-way, etc. Only the dimmers do. As @harjms alluded to, the switch is supposed to auto-detect.

See if you can find the Load Type setting and switch it from default to T8 (or vice versa if it’s not set). “Load Type” is what it’s called in SmartThings but I don’t know what it’s called in HA.

Yeah, that’s parameter 13 I was mentioning. It says “load type” and the only two options are “auto detect” and “Manually set for special load type”… There doesn’t seem to be a difference in behaviour regardless of whether it’s set to auto or manual. Unless i need to reboot the switch somehow? I just pull the air gap - figuring that would kind of reset it…

This is my next step if I can’t get this sorted. I haven’t really looked into it yet, but have seen it as a solution a couple times.

I did replace the dumb switch (since it was a couple decades old) as I’ve heard that can help to - but no dice.

Bear in mind that you are going to have to re-wire at the fixture if you go with an Aux. Just mentioning because you mentioned the difficulty in getting to it.

EDIT: I also wonder if the load can be causing the issue. What is the load? Can you at least get at the fixture to change the bulbs easily? If they are LED, temporarily swap for incandescent.

1 Like

Hey Bry - I’ve seen this mentioned a few times. I’m hoping you can help explain this to me - as I never really found a good explanation. How does the load affect things? Maybe if I can better understand this part, I can troubleshoot better. it’s currently 5 led’s, each pulling 6w. This is confirmed by the data from the lzw30-sn which says it’s using just over 30watts when on.

Changing the bulbs is a pain, and it’s about 3/4 of the way to pulling down the whole fixture - so if I go that route, I’ll probably go 100% of the way just to get things sorted.

I wish I could, lol. At the moment, it seems to be voodoo science.

The best I can tell you is that for whatever reason, some bulbs work better than others with the Inovellis. Switches and dimmers are primarily built around two components, MOSFETs and TRIACs. Some bulbs seem to do better with one or the other.

My sense is that TRIACs do better with LEDs generally; however, MOSFETs are used to incorporate features into switches that TRIACs don’t allow. (The Inovelli dimmers are MOSFET and I THINK the switches are too.) There are some other factors that can complicate things for dimmers, but in your case we’ll stick with the switch.

I’m sure there is a more complex technical reason regarding bulb compatibility, but that’s above my pay grade. The best I can tell you is that in a few cases here, users have solved multi-way issues by changing bulbs. So it’s something that sometimes gets recommended as it’s usually easy to try. In your case, maybe not so much. But that has to be easier than dropping the fixture to re-wire for an Aux. :thinking:

I assumed the switches used relays since you hear the click when you turn it on and off. Would you hear the click with a MOSFET?

There are relays in both the switches and dimmers. With the dimmer, the relay is used when paired with a dumb switch. So you’ll hear the click with a dumb switch but not with an Aux. Not 100% sure on the switches. Might just be the MCU.

Interesting. I have a black series and red series and they both click as single switches - and the red series clicks as a 3 way. (haven’t used the back as a 3 way.

You should hear clicking when mated with a dumb switch, at least on the dimmer. If you are mated with an Aux, you won’t hear the clicking. But relay or no relay, my point was that some LED bulbs just work better than others. The quick test is to swap out for incandescents, which always work.

My dimmers in a 3-way configuration are all virtual 3-ways via association. I guess since it doesn’t sense the other switch it doesn’t activate the relay.

I spent 1/2 a day trying to figure out why my aux switch and then dumb 3-way switch were both having issues with the LZW30. With the aux switch I was experiencing the aux turning on the LZW30, but not off. With the dumb 3-way I was experiencing the LZW30 turning back on after physically turning it off (at the LZW30). Same issue through the hub (off resulted in the LZW30 turning back on within a second). I upgraded to firmware to 2.20. No improvement. I set parameter 13 (Load Type) to Special Load (T8). No improvement.

Then… I decided after reading numerous threads of people experiencing the same issue and responses that the LZW30 is supposed to auto-detect a 3-way circuit, that I would try replacing one of the 3 LED bulbs on the circuit with an incandescent. Bingo! the 3-way circuit worked. Problem identified… the LZW30 needs a load greater than what the LED bulbs were creating in order for the LZW30 3-way auto-detect to work. Since I’m not going to live with a mix of LED and incandescent bulbs, I’ve installed a load resistor (similar to what is needed for some older dimmers after swapping to LED bulbs). I use the Aeotec version, but there are others out there. Google “Aeotec bypass for nano dimmer”.

The resistor connects “across (or in parallel)” with the light (or outlet - if that is what you’re controlling) itself, thus creating constant resistance on the load (which is what an incandescent bulb would do). You can wire the resistor at the LZW30 itself by connecting one of the resistor’s leads to the Neutral connector, and the other resistor lead to the Load connector (along with the wires needed for the circuit - as seen in the Inovelli documentation).

I’d like to see a firmware update which forces the 3-way config (doing away with auto-detect). I’m not really enjoying dropping $15 on a load resistor to solve the problem.

Hope this helps others. Cheers!