LZW31-SN Installation Help - LED bar not lighting up

First time trying to install this switch. I am trying to install this into a switch that runs a wall outlet and has no neutral (2 wires and a ground). After installation, the LED bar does not light up at all. When I take the wires in/out the LED lights up red for just a second (like it is a bad connection). The LED light also lights up when I disengage then engage the air-gap switch. Any suggestions would be appreciated.


Do the lights the switch is powering turn on and off properly? Are you using the Aeotec bypass? How many lights does the switch control? What is the wattage of each bulb and also the model #? Have you been able to pair the switch to a smart hub, if so which one? It sounds like you’re setup in a single pole situation. Sorry lots of questions, some more info is needed.

I had issues with switchs behaving weirdly in a non-neutral single pole situation and I found that certain bulbs were less picky but ultimately needed to install the bypass on all the non neutral switches.

I am trying to install this to power a wall outlet. So, no lights. I want to turn off local control, to keep the outlet on all the time and tie the switch to other inovelli smart bulbs in the room. Not a standard setup, but hope it makes sense.

That is a unique one. Full disclosure I’m not an electrician or electrical engineer so take what I say with a grain of salt. I know the non neutral setup requires a 25w load to make dimmer function properly or you will need the bypass, that was where I was having issues. Have you tried plugging in enough stuff into the outlet to provide that?

Thanks @flipontheradio, that helped to a degree. I plugged in a vacuum and turned it on (although it did not actually turn on until I “clicked” on in the device settings). Plugging the vacuum in and turniing the vacuum switch to the on position allowed the switch to light up and be able to be found by my hubitat hub. Even after I disable local control (there seem to be 2 different settings for this), the vacuum does not turn on.

So, I was able to set up and test as long as I have the vacuum plugged in and vacuum switch in the on position. This somewhat makes sense as the switch would need a closed circuit to work. I may try a bypass on the outlet and see if that helps make this work.


Please do not use the dimmer to control the outlet. The dimmer isn’t designed for it. The on/off would be the better option, but still not recommended to run a large motor like a vacuum. Some of those Kirby’s can pull some Amps.

Agreeing with harjms. Please check the max ratings for your switch and ensure you’re not attaching a load that will exceed them. I thought I recall seeing that 600w max if all six tabs (3 on each side of the front of the dimmer) are intact. 110v so I think that means no more than 5.45 amps.

FWIW I have the same dimmer that you do and mine is connected to some outlets above my kitchen cabinets that have LED accent lights plugged into the outlets. I also don’t have a neutral at the dimmer installation point and have installed the bypass onto one of the outlets.

The dimmer powers on and works properly in this config.

Thanks everyone! I was seting this up to just test the switch out prior to moving into a new build we are in the process of. I plan to use this the same way you have it setup @geekdaddy. Ended up plugging in a stand light for now.