LZW31-SN not giving a good experience with Smart Light (Philips Hue)

I’ve got a lot of Philips Hue light, and I wanted a dimmer switch that allow me to disable the relay so the light always remain power (Unless Hub is not responding, then it could fallback to a dummy on/off switch).

The problem is when you set the light in Smart Light mode, the On/Off still cut the power to the light.

If I set Disable Local Control, then I lose the dimmer switch functionality, so that not good.

Note I got these dimmer so I don’t have to bypass my actual house wiring, because I do take the Philips Hue light with me on film project from time to time, and I put back simple LED light, so with having the wirering remain the same, I can just run a script to update all my light to disable the Smart Light mode which then make it a normal dimmer for normal light.

The dimmer function does work correctly, it does send the value over Z-Wave which I can relay to the Hue Hub. I would wish that that the dimmer send Z-Wave level update WHILE we are actually dimming the light, which could provide a realtime update of the light level while we are changing the level on the switch and not just when we let go of the toggle.

Any idea if this can be done before it too late for me to to return them ? Thanks


Smart bulb mode does nothing but ensure no actual dimming occurs at the switch level, because that’s a quick way to damage a smart bulb. I have several LZW30-SNs that do nothing but control Hue bulbs through scene controls with local control disabled. You’ll need to change the brightness level over time based on the up and down buttons being held or switched. I use advanced button controller in Hubitat.

I just started to try the ABC, and it felt interesting, but this app require the light device to support capability.changeLevel which the Hue light integration doesn’t. The Hue light only support switchLevel only.

Also, the Inovelli LZW-31-SN switch send a Pushed 8 when you long press Up and a Pushed 6 when you release it (held for the down button). I don’t see how that could be integrated using ABC.

Also, I don’t think we can send the led notification to show the light level (progress type indication) like when the dimmer is enabled. So I would end up with different switch with a different user experience which suck !

Adding my voice to this as well (in addition to other post) that smart bulb mode should keep the switch voltage to the load even when off. It becomes a scene controller only and not a physical switch in any way.



Maybe I’m misunderstanding, but that is what disable local control is for. The two functions are separate so that you can have the switch put out full output yet still work like a switch. That’s important for those that need switch-like functionality in a non-neutral config.

If you just want it to be a scene controller only and not work as a physical switch, then disable local control.

My problem with disabling local control is the led bar locks at 100%. If you could associate a bulb and dimmer and keep the voltage at 100% even when off then the led bar would always work.

When you disable local control, you are saying that I don’t want the switch to PHYSICALLY control anything. So it makes sense the LED bar won’t move as the switch isn’t controlling anything. It’s just a scene controller. If you want the LED to work, then use Smart Bulb Mode and associations.

I don’t use associations, but I believe @Chris and/or @kelchm have the associations and LED dimmer working and syncing for a 3-way. @Chris describes what he did here:

That works for syncing led bars across dimmers. Not with a smart bulb like the illumin.

@Chris specifically says he got it working with smart bulbs, so he’ll have to comment.

I’ll clarify the behavior in seeing. With a single dimmer and a illum associated. With local control disabled and smart bulb enabled the dimmer is locked at 100% always. With local control enabled and smart bulb enabled, power is cut when you reach 0% dim of off

I don’t have Illumin light. I have Hue light which require the hubitat to do the translation. Right now, I got the On/Off/Dimmer feature working just fine with a few rules (except maybe providing visual progress of the dimming). The issue I’m left with is the power get cut to the light at the switch level. I don’t understand why you would want to cut the power with a smart bulb in the first place.

You enable smart bulb then disable local relay. Smart bulbs never turn off.

1 Like

You’re right, you don’t. But the dimmers are used in multiple scenarios. It’s not always about smart bulbs. Read my post about 6 up from yours where I responded to @kreene1987. I explained the difference in the two functions there.

@Bry can you provide a scenario where you enable smart bulb mode and would cut power when the dimmer is off? That’s my hold up with the current behavior.

1 Like

There is no disable local relay, only local control, which then I lose local control ! That is not the same thing as disabling the relay ! I want the switch to continue it normal operation, but only disable the relay/dimmer function ! Smart Bulb mode does disable the dimmer control of the relay, it just doesn’t disable the relay. I don’t have Z-Wave light, but if I had, I feel like this would suck, since other device would keep setting a potentiel device to relay with and it would disappear everytime you put the switch to off, which would suck ! So you would have to disable local control, and setup on the hub a way for the light to talk to the switch…

If for some reason it desired to cut power to a smart bulb (which I don’t think it is (unless the z-wave hub is not responding)), then another configuration option should exist to disable local relay… Like it is written in the Features / Specifications page. Which the 8 button press is actually disabling local control, which disabling local relay is just a side effect and not the main purposes.

I don’t understand why you guys are trying to justify all this to be normal… It a simple bug, or bad product descriptions at the very least. And as a bug, it super easy to fix !

1 Like

@EricM_Inovelli @Moc description above exactly describes what I’ve been trying to say in our PM thread

1 Like

Weird my Ilumin bulbs works with local control disabled.

1 Like

Yes. I have a non-neutral where I want a light switch. I don’t want a dimmer, but I can’t use a switch because they don’t work with non-neutrals. So I install a dimmer and set it to Smart Bulb Mode. I now have the functional equivalent of a light switch using a dimmer. I can turn the light on and off from the switch.

You’re expecting two functions with one setting, but there is a reason not to implement it that way, at least as I see it.

@Moc I’ve raised the exact same concerns as you (using this dimmer to control a Zigbee bulb) , this product is sold with confusing marketing. The people answering in this thread are just confusing the issue with anecdotal stories about other kinds of bulbs (Z-wave, etc) and are not being helpful. I’ve seen it time and time again on these forums.

For everyone else: bottom-line, people want a dimmer that can constant power the local load but still send Z-wave dimming commands to the controller. That way the smart-bulb can be controlled in real-time without resorting to events and loop timing. Getting the local dimming LED bar to reflect Z-wave dim level would be the icing on the cake.

It’s really that simple.


Disable Local Control is really “disabling the relay”. (@Eric_Inovelli . . sorry for the quotes). Disabling the relay on a dimmer is really just a throwback to how it was previously described.

There is no relay in a dimmer. So even if you wanted to disable the relay, you can’t because there isn’t one in there. Disable the Relay, Disable Local Control or call it what you want. You are simply saying I don’t want the dimmer to physically cut the power.

Well, if you actually had a bulb and could try it you would see that it would work just fine. There are many here that have it working just as it should. In fact @harjms just commented that his was working as expected.