Lzw31-sn scenes stopped working after firmware upgrade

Running on Hubitat, and everything has been peachy … I just upgraded the switches from 1.47 to 1.52, and everything seemed fine, so I finished upgrading the rest. Then I realized that all of the scene control has stopped working, and as soon as you touch a paddle, the lights just come on.

I tried the settings in the drivers to adjust the button press delay, and enable/disable the physical on/off delay among other things … but they either aren’t getting applied in the switch, or just don’t work.

Am I missing something? It’s like my Red’s have turned into Black’s …

Its a known “bug” with that firmware. It automatically sets the delay between button presses to 100ms instead of the default 700ms. Configure delay back to something longer and your scene control should work again.

I did … I set it back 700ms, but it had no impact.

When looking at the state variables on the device page does parameter50value equal 7 and parameter51value equal 1?

Yes they do.

Have you tried cycling parameter 51 to yes (disabled) and then back to no (enabled)? If that doesn’t work you might have to rope in an inovelli tech.

I had tried setting it explicitly to disabled (vs. “no selection”) and then back to no selection several times; I don’t recall if I had set it to enabled in any of my tinkering. I did just try setting it to enabled, waiting a minute until I was sure that param51 reflected the change, and then switching it back; that appears to have solved it.



Glad I could help!

Make sure you mark as solution IF it ends up working for a day or two!

Well … being honest here, as soon as I got it working; I tried to flag it as the solution - but for the life of me, I can’t find an obvious way to do that :thinking:

Since you are the OP, you should have a Solution button at the bottom of the post you want to mark.

That’s what I was looking for … and then I searched for other options …

Any other ideas?

This is typical. After every firmware update, I have to change all my parameters to some other value and back.

None, lol. Different browser, maybe? Not that big of a deal. At least you gave it a shot!

I can confirm this is an issue when upgrading to 1.55. After the upgrade, some dimmers would not register anything other than single taps until I toggled Parameter 50 and 51. Seems like 50 has to be at least 300ms to receive double tap, in my experience. I also have to disable SBM on non-smart bulb dimmers.

I’ve noticed that too. I have not been able to get the Inovelli to register a double-tap below 300ms even though I can consistently double-click under 200 (gamers click at 125 or less)…