LZW36 Creates fan & light automatically

I added one of these before and it did NOT automatically make child objects for fan and light. I had to create them. This time when I add it it created them by itself and I can’t rename them or do anything. I’ve tried selecting different drivers but there is no way to delete the child entries or change them or do anything. Any suggestions as to why it’s doing this and how to fix it?

Did you change the parent device to use inovelli LZW36 driver from GitHub?

I just left the two auto created child entries alone and only work with the 2 child entries from the inovelli driver.

Yes. I manually added the device driver code. I’m just frustrated that it did that for one and not the other. It just crowds up my device list and is useless. No way to change that? Why did only one do that?

Make sure the driver is correct and click Configure then you should be able to delete the old child devices, you may just have to go into the child device and if remove isn’t available there go to the gear in the upper right and go to the bottom of that screen and there should be a remove option.

Just posting on here to share that I have the same issue: a total of 4 child devices. Two child devices were created when the device was added (Fan and Light, non-removable). Two additional child devices were added after changing the parent device to the Inovelli supplied driver (same name as device, removable).

Removing the device and re-adding does not fix the issue.

*Edit: seems like a Hubitat issue more than an Inovelli one.

I might be able to add something to the driver to delete the Hubitat created devices. In my opinion they should let you delete them from the interface though if you want to change drivers.


I’ve made the change to the LZW36 driver. After you update it just hit “Save Preferences” or “Configure” and it should delete the unwanted devices. If it doesn’t work there might be an app that is using the child device so double check that.

This is not working for me. I checked the “In Use By” section of the Device Details, and the child devices are not in use.

I have fixed this in my own hub and I have added a pull request with my patch:


Thanks, dumb mistake on my part. I’ll merge the request.


Thanks! It worked great!

1 Like

You guys are amazing, great work.


Such amazement I find in this company. I have this same issue, find it on the forum with a pull request, and the CTO immediately admits his mistake and pledges to merge the PR. I have never seen this in a company.


Welcome to Inovelli :slight_smile:


Thanks for taking the time to get this squared away @EricM_Inovelli and @datavortex. We appreciate it.