image not found img not found

LZW36 Fan/Light Parent/Child Device Issues

I installed five LZW36 combined fan and dimmer switches over the weekend. Mostly things went well but I did run into an issue that, for one switch, I am still contending with. Help is appreciated. I am using Samsung SmartThings for the moment (but probably not for long).

To lay the groundwork here, I have both device handlers installed. I have the 2020-05-18 version of the “Inovelli Fan + Light LZW36” handler and the 2018 version of the “Switch Level Child Device” handler.

My issue revolves around the devices I get when I add the switches to my SmartThings-managed Z-Wave network. 2 of the 5 switches worked exactly right the first time - I got the parent device for the fan and the light, and the 2 child devices, one for the fan and one for the light. For 2 of the switches, I had to go through multiple add/exclude cycles to get the right devices. Sometimes I would get the parent device and the light device (no fan-only child). One time I got only the parent (no light-only, no fan-only). And one time, oddly, I got four devices (one working parent, one identical but not-working parent, and two working children. I just hid the non-working parent and kept it).

But my last switch is my problem child. It has been through three add/exclude cycles so far and every time the results are the same - I get only the parent device and the light-only child. No fan device. The parent and the light-only child work as expected. This switch should have excellent connectivity, it shares a 2-gang box with an Inovelli LZW31-SN dimmer switch that works well. The LZW31-SN has zero hops to the hub. Besides the add/exclude cycles, I have also tried Z-Wave network repair utility but no change there.

Is there any way to add the child fan-only device that’s missing? If not, any other ideas? Thanks!

I would do a factory reset and re-pair to your hub. I have had to do that with a few of my devices.

Thanks, Sky. To the best of my knowledge, a Z-Wave exclusion is the same as a factory reset. I have done 3 pair/exclusion cycles so far with this switch. While this tactic did in fact work on 2 of the 5 other switches I had this problem with, this one is more stubborn, and I keep not getting the fan-only device upon add.

I thought the same thing, it is not the same. @Eric_Inovelli ay be able to explain better than I can. I have had to do a fuLl factory reset by pressing and holding the program/inclusion button for 20 seconds until led turns red. Then re-include.

Thanks again, Sky. In-between your posts I decided to give it one more try and it would seem the fourth time is a charm. I did not do the full factory reset. For whatever reason, with an identical process of “exclude -> z-wave repair -> pair”, this time around I got the correct 3 devices. I followed an identical process earlier on the day with the same z-wave network members with the broken results above. I did not change any hardware or upgrade anything.

BUT the fan-only device populated in the IDE as type “placeholder” and not, like my other switches, as a “Switch Level Child Device”. And, while controlling the fan from the app works, I still get an error message falsely indicating that the command failed (“A network or server error occurred. Try again later.”)

I changed the type to “Switch Level Child Device” in the IDE, but the false negative network error messages persist.

Try to enable local control right at the switch. Press and hold A while tapping B eight times. do the same for the fan pressing and holding D and tapping E eight times. You will get a green led flash of three times. This is what I had to do on mine to get it to function correctly. Read through this post also may help.https://community.inovelli.com/t/lzw36-issues-local-control-stops-working-after-adding-switch/3873/2

Thanks but local control has always worked. The local control works whether or not the switch is included in the SmartThings z-wave network. I suspect the bug you’re referencing was limited to Hubitat.

Yeah, most likely thanks, glad its going for you now.

1 Like