LZW42 Adjusting Transition Time

I have LZW42 bulbs that are by default transitioning in what I counted to be 3 seconds. Is there a way to make this transition time 0, so that it will instantly turn on/off?

I am using Home Assistant 2021.9.3 with OS 6.1. Firmware on the bulbs are v2.31. I am using Z-Wave JS to MQTT with MQTT disabled.

I see some transition parameters below in zwave2mqtt UI panel, but I don’t think I am using it right. Under “Send Options”, I do not know how to confirm the value as there is no arrow to send the message like on all other parameters. For [14-38-0-duration], it is already at 0…

In my automation where I have an action to turn on the light bulb, I tried adding a “transition: 0” line, but got the error; “Message malformed: extra keys not allowed @ data[‘transition’]”

type: turn_on
device_id: 1522f2b5f3b6ddd153186c978f35fd02
entity_id: light.mudroom_light_1
domain: light
brightness_pct: 25
transition: 0

Please help, the WAF is at stake :cry:

I’d suggest troubleshooting in Developer Tools → Services. From there you can try a couple service calls to see what works and doesn’t.

I don’t typically use the device function in service calls, so my yaml looks a little different, but this should work.

service: light.turn_on
data:
  transition: 0
target:
  entity_id: light.bedroom

If your code is exactly as you pasted it, you may have some formatting issues. When you post code there is a “preformatted text” option that you should use.
Let me know if you get it working!

1 Like

There is no way to change the default ramp rate that I am aware of.

Would love to see improved firmware allowing us to change as a parameter as well!

2 Likes

Can you do a zero ramp rate via association?

I tested associating bulbs to a red dimmer. The dimmer ramp rate had no effect on the bulb ramp rate.

The slow ramp rate of the bulbs caused me to forget trying to use them.

1 Like

I have always used the simple action type Device that I forgot about Call Service. I can now instantly turn on/off my bulb. Thanks!

My first code is exactly as I pasted it. It looks like that’s just how the Device structure works. Using Call Service, it now looks like yours:

service: light.turn_on
target:
  device_id:
    - 1522f2b5f3b6ddd153186c978f35fd02
    - d9bec9d212a6cb6589f75bbac563c5ae
data:
  transition: 0
  brightness_pct: 25

I do hope that one day there is a way to change the transition time directly from the bulb parameters.

Awesome! Glad to hear that worked for you.

I agree, it would be nice to be able to change defaults, but for the time being I’ve built in transition times for anything specific. Some things I have set to instant, but lots of times I just use 1 second for a smooth, but not lengthy on/off effect.