LZW42 does not remember previous state after power outage

I have three brand new LZW42 bulbs, connected to Home Assistant and paired to an USB Z-Wave controller via Z-Wave JS. They came already on firmware 2.31 that as far as I can see is still in beta, but whatever - they are working perfectly. However it seems like they do not remember the last state after a power outage.

I have verified in Home Assistant that the setting “State after Power Loss (2)” is set to “(0) Previous state” for all three devices, but after cutting back and restoring power, they turn back on. Also, after they turn on, HA still sees them as off, so I have no way except visual confirmation to know that they are actually on.

Am I missing something? I thought this was the major feature differentiating those bulbs from the cheaper ones. Maybe it’s an error within HA?

Thanks in advance!

1 Like

I just saw the same behavior on my three LZW42s running firmware 2.31. We had a power flicker overnight and I awoke to find the lights on even though they were off before and they’re set to resume the previous state. HA did see mine come on, though.


Maybe I’ll try downgrading the firmware next week to see what happens.

Interesting, let me check it out in HA.

I’ve had 11 of them running in ST for almost 2yrs now and they’ve all remembered the same state and thank goodness bc if the wind blows the wrong way, my neighborhood loses power!

Edit: to add, I’ve upgraded the firmware when the time came and still have no issues.

1 Like

I am not sure why Z-Wave JS has that info for that configuration parameter. The options should be:

0 - On
1 - Previous State

Edit: So you should set the value to “1” to have it work as you desire.

1 Like

Hello @EricM_Inovelli, thanks for the information, I’ll be trying that as soon as I get off work!
I may be mistaken, but I think Z-Wave JS uses the JSON published at node-zwave-js/lzw42.json at master · zwave-js/node-zwave-js · GitHub, which in turn is derived from the XML at https://products.z-wavealliance.org/products/3613?selectedFrequencyId=2 , which contains the following snippet:

          <Description>Remembers Last State</Description>
          <Description>Bulb turns ON after power outage</Description>
          <Description>Bulb turns OFF after power outage</Description>

Thanks for the help!

1 Like

LOL… That would explain it.

The setting of 1 seems to work for me.

I’m going to make these fixes and submit a pull request to zwavejs. @EricM_Inovelli , is this a firmware generation thing, or does 0 == “On” and 1 == “Previous State” for all firmware versions? Also, is there a setting for “Off”?

1 Like

Sorry for the delay, I too can confirm that the “1” value persists the last power state. Thanks for the help!

@krisk, the pull request should be enough as far as HA/Z-Wave JS are concerned, but I still think that the proper future-proof fix should be applied to the main Z-Wave device database. Maybe that’s something @EricM_Inovelli can do?

Thank you for submitting the pull request.

This was a mistake by the manufacturer during their part in the certification process and we were never able to get it fixed in the device DB. I believe that we had it fixed in all of our drivers / device handlers / documentation / etc. for some time. I can see if I can hear back from some one over at the alliance about it.

Since we’re on it - I can’t confirm as I don’t have an actual device but I think there is the same issue on the product description page for LZW41 (see https://products.z-wavealliance.org/products/3614, both in the config params and the linked device manual PDF, and the Z-WaveJS descriptor that I cannot link directly as I’m a new user, while OpenSmartHouse Z-Wave Device Database reports the same 0-1 params as LZW42).

Thanks everyone for the help!

1 Like

@EricM_Inovelli , here is my draft pull request:

Would you mind looking it over for accuracy? I found a few things that appeared to be wrong based on the manuals you publish.


Looks good to me. Thanks for submitting that!

1 Like

No problem.