LZW45 cant set parameter 30 past 65365 yet docs say setting up to 197375

Home Assistant “blue”
OZW 1.6
Strip is included correctly, comes in at LZW45 light strip.

Per LZW45 doc, parameter 30 can be set between 0 -197375. Paper doc that came with strip though says 0-32768

I am trying to use @nathanfiscus toolbox. Unfortunately I cant get it to send anything to my light (maybe this is because of parameter 30 as well). When I look at what values it says its sending for the following program, it says to set parameter 30 to 65791 (over the 65535 range)


When I try to enter in those 4 parameters listed in a node red flow, parameters 22,23,24 are sent fine. I get an API error on parameter 30 with a debug error saying out of range

I’ve also tried just setting parameter 30 through developer tools > services and I get the same error.

The XML for parameter 30 is incorrect, the max needs to be set to 197375. I’ve open a pulled request with the Inovelli openzwave repo.


I copied over the revised LZW45.XML. Restarted my entire device. Copied back of the LZW45.XML back to my computer just to confirm the newer version was copied over, and it was. See parameter 30 settings below. But I still get API error saying I cant set 30 any higher than 65535. No I need to remove and then re-include the light strip?

OpenZwave caches the configuration file when you add the device to your network. That cache file is zwcfg_****.xml. I think you can refresh the node from the device page in HA and it should refresh the cache as well. If not you have two options. You can edit the zwcfg file on your host, or you can remove and re add the device.

Was able to edit that file except for 1.6 its called ozwcache somethin… instead of zwcfg_****.xml