LZW45 Drivers - Z Wave-JS addition through Pull Request

Yep I sure did. I do it through Node Red and a LOT of automations, so I’m waiting a bit for a FINAL solution before I go changing everything to a interim solution. I am avoiding MQTT not because it doesn’t work, but because it’s another step that causes a slight delay. Speed is king here.

Thanks for pointing that out though!

Yah I’ve only tested out JS on a VM. Im not touching my main rig yet. And really, aside from an occasional hang up a few weeks ago, OZW 1.6 has run good for me so I dont really need to switch to JS. But I kinda want to just because its new lol

1 Like

It looks like LZW45 is on the list for the Z Wave JS group to do. I dont know if that changes anything on the Inovelli side or not?


image

1 Like

Yup, I looked at the codebase and it looks like @pedro is working on the config files for the LSW45 right now.

I also opened a ticket to see if we can get the new parameters added to the config files. The main developer over there said they were focusing on getting everyone’s standard zwavealliance configs into the config files first and then will do firmware specific updates after that.

So far, the config parameters they have are pretty complete for Inovelli but missing some of the newer, beta firmware, changes that are not ‘officially’ in the zwave certified standard.

@EricM_Inovelli It may be helpful to provide a guide on which parameters are which in each firmware version in one place. This may help the devs get things like parameter 50, 51, and 52 for red series dimmers included just for the right firmware versions into the config files.

The project is moving fast though! I moved to zwavejs2mqtt over the weekend and it has been pretty good so far. I chose the mqtt version for the admin interface which works well.

1 Like

image

Ha! My mistake good sir!

1 Like

Just to confirm, they are going to have firmware specific versions of the config files and a method in place that assigns the correct config file based on the firmware version? What happens if the user updates the firmware after the device is included into the network? Does the system check the firmware version and then re-assign a config file if necessary?

Hey Eric -

As I understand it, yes, the config files have the ability to be firmware specific. What I am not sure about is if the zwave devices update the hub when they get upgraded to show the new firmware versions and subsequently show the new config parameters. I would assume they do, and if not now, maybe in a future release. @petro - seeing as you are working on the config files, do you have any idea?

Here is the documentation on how they call out firmware versions.

There is also a RFC to enhance the documentation so that multiple firmware versions can sit in one config file.

Also - FYI, zwave js has the ability for OTA updates so that will be a nice addition to home assistant.

Yes, as a matter of fact, there is a PR that adds all the params for the LZW31(-SN) and even only shows the correct params for the beta firmware if you are on that.

Ill what happens when you update, but I think the device might need to be reinterview. That should happen on next restart. If it does need a reinterview, I can submit it as an issue saying arguing an interview should always happen after a firmware update. Seems logical for any zwave device to me.

They added the ability to update Target 1 in a recent PR, so I’ll test it so as soon as that gets pushed out in a build.

Hopefully in the near future, adding an invoelli device to HA will be as simple as adding the device to the network, no more of that ozw 1.4 config file stuff.

I tried this yesterday and it didn’t like the .bin file for some reason. I don’t have time to dig further right now.

Yeah it is checking to see if it is a valid zwave firmware. And its not, as its for the other MCU. Fixed in dev but not in a release yet.

1 Like

I saw that post about 5 times and finally saw what you did wrong. Even though he had circled it. lol

On the topic of LZW45 drivers, how can I tell in GitHub when they have been added? Im pretty new to GitHub and its very confusing to me. I just tried to add my LZW45 to my virtual machine running Z Wave JS and it didnt include correctly.

There are the hex numbers for the “commits” and then eventually they’ll decide to release a new version and there’s effectively a cutoff. The cutoff happened about 21 hours ago with commit 8f22052 (Commits · zwave-js/node-zwave-js · GitHub) that released version 6.3.0 and the LZW45 drivers were included below it.

That being said that’s to the main Node Zwave JS code, which is the “core” of everything. Depending on how you’ve added ZWaveJS to Home Assistant you’ll see it at a slightly different time. I have it set up through the official zwavejs2mqtt addon, which is almost 100% a duplicate of the zwavejs2mqtt in the main page, but it has to go backwards… so the official zwaveJS2mqtt has to be updated… and then the official addon has to be updated. But honestly those both should happen within about 24 hours.

Can you explain that to me clearer cause I’m running js2mqtt as well on my virtual test machine. But because of that, I don’t run the official Z-Wave JS add-on. You appear to be saying I need to update both JS2MQTT add-on AND the Z Wave JS add-on; or maybe I am reading that wrong.

You’ll only ever need to update one thing. Do you have zwavejs2mqtt installed manually via a docker outside of Home Assistant or under the “Supervisor” tab in Home Assistant?

Under supervisor tab in my home assistant “blue” device.

Ok. You’ll just have to wait until an update appears on zwavejs2mqtt under that tab. The next update should incorporate the changes for the LZW45 drivers as well as the additional parameters for the LZW31-SN and LZW31-BSD configuration.

I’m also eagerly awaiting the changes too as I currently have one Red Dimmer switch in air-gap mode until I can change some parameters. Don’t ask…

Looks like it just got released (the mqtt version) so you should be able to install!

There’s a bug (caused by me) with the current config file. Custom strip effect intensity for the 4th effect is incorrectly bitmasked so when you change the 4th intensity or the 3rd intensity, they both change. There’s a PR for this and you can follow it. I basically forgot a zero :man_facepalming:

EDIT: It got merged while I was sleeping. Expect the update in a week or so.

I have the new ZWave-JS version installed in my HA addon as well as the new configuration files are loaded. From the Supervisor Addon everything looks great for the LED strip, however the actual Home Assistant integration of the lights doesn’t seem to be working.

I think I might’ve seen someone else have this issue and potentially had a solution, but I don’t remember where it is. Is there something I can do to HA entity to control the light normally (as in an on-off button, color choosing, and the brightness bar)?