LZW45 (light strip) drivers for home assistant?

I’m on 1.6 and I just tried again downloading the xml direct from the open-zwave github and manually placing it into the open-zwave\config\inovelli folder, re-including the RGB strip, restarting HA, and parameters are still not available to adjust.


@isewise 1.6 doesnt use those config folders. the config folders are somewhere on the host system that you apparently can only access with keyboard/monitor directly connected to the hardware thats running HassOS.

But the xml has been put in the ozw 1.6 repo. I restarted my ozw 1.6 add on, thinking maybe it would pull the new xml in. Re-added the strip but stills comes back as unknown.

Looks like the new xml is still not officially in the repo, so the HA add-on wont pick it up yet.

If you go here, http://openzwave.com/device-database, and down down to inovelli, LZW45 is not listed yet…

@nappyjim Not to be rude, but I’m pretty sure the “open-zwave” folder is used by Open-Zwave.

I’ve manually edited files by using the Samba share addon to enable scene control and other features working directly with files on HA.

From another post you mention you’re using the new blue hardware, I’m using a raspberry pi 4 running a different install than what you’re using.

Additionally, ozw isn’t going to get its config files from the openzwave.com website, its going to get them from the github page. As @EricM_Inovelli mentioned he updated it yesterday as you can see on the github history:

Yeah, I got the website from the openzwave github that the xml was updated in…

For those with 1.4
I setup a test HassOS instance and used the 1.4 Z-Wave integration to add the device. It is detected as Multilevel Tunable Color Light, but it seems the Home Assistant is unable to detect the type to create the correct entity. I stopped the integration and then edited the zwcfg_****.xml to change the type to Multilevel Power Switch and specific to 1. Then I restarted the zwave integration and the light entity was created.

So this:
<Node id="7" name="" location="" basic="4" generic="17" specific="2" roletype="5" devicetype="1536" nodetype="0" type="Multilevel Tunable Color Light" listening="true" frequentListening="false" beaming="true" routing="true" max_baud_rate="40000" version="4" query_stage="Complete">

became this:

<Node id="7" name="" location="" basic="4" generic="17" specific="1" roletype="5" devicetype="1536" nodetype="0" type="Multilevel Power Switch" listening="true" frequentListening="false" beaming="true" routing="true" max_baud_rate="40000" version="4" query_stage="Complete">


In your own screenshot it says: “Our device database is mainly based on community contributions…”

A device doesn’t need to be listed on that database for functionality with HA.

Why do you think in Inovelli’s own installation instructions they list out commands to download XML files from github?

It does appear that the new 1.6 OZW Daemon does check in with the device database on start up and will pull missing configuration files. If you check the logs of the integration you will see it attempting to pull missing records from http://download.db.openzwave.com/. So theoretically once it shows up in the device database on openzwave.com, it should be pulled into your config directory after a restart. If you don’t want to wait, you can locate your core_zwave data directory on the host machine and pull it manually as the Inovelli Support page (listed above) describes. The location of the core_zwave data will depend on your installation method (This can’t be done through either SSH addon, and isn’t support by Home Assistant so use caution.).


Supervised Install:

Commands to automatically pull the XML and update the manufacturer_specific.xml if you trust my bash:

1 Like

@nathanfiscus thanks for the confirmation. Ill keep checking the database to see when the LZW45 is listed there and then restart my ozw 1.6 add-on.

Anyone know how long it takes the device database at openzwave to be updated?? Tried again tonight, still unknown device

I think you need to unpair and repair your device for it to pull the correct information. I don’t think it updates otherwise. I got mine set up but I followed the work around instructions before the device was added.

@harmfulmushroom thats when I been doing. Removing the device, restarting ozw 1.6 addon, and then adding the device again.

This worked for me, thanks! For others on 1.4, if it wasn’t clear find the proper <Node> block in your zwcfg_****.xml file to make the suggested edits. I searched my file for “LZW45” to find that block easily.

Result is an adjustable color and brightness light entity along with the other sensor and zwave entities I had prior.

Then I customized the light entity and set supported_features to 177 like @nathanfiscus suggested. Now I have color temp working as well!

Haven’t tried anything more advanced yet with the light, as color and white temp was my primary use case (TV bias light).

1 Like

Confirming that this worked for me as well with legacy zwave (1.4)

1 Like

@nathanfiscus so I plugged keyboard into my HA blue device. I was able to CD to the inovelli config folder. When I tried your sudo curl command from the other thread, I’m getting a /bin/ash: sudo : not found. Or trying the command with sudo, i get curl not found

You can install curl using one of these two commands:

sudo yum install curl
--- or ---
sudo apt-get install curl

yum not found
apt-get not found

im locked out of everything!! lol

You are already logged in as root. The sudo can be removed.

@nathanfiscus curl is not found either! lol. Its like im in some minimal root account that doesnt have access to too many commands

From someone in HA forums:

The Blue device runs HA OS, which is a minimal OS that only has what it needs to run HA and doesn’t include the ability to run to sudo or curl.

One way may work for you is to install the SSH add-on in the HA store, and use something like WinSCP to edit the files via SSH.

So im in a catch 22 here, i cant get access to root system in SSH and I cant do the commands I need in root. I dont get why the openzwave database takes so long to update?!?!?