LZW45 (light strip) drivers for home assistant?

Just got my strip and added ti to zwave, came up as following. Toggling does not even turn it on/off.

Installation guide

1 Like

There’s a typo in the guide, see my post here. Even following guide as is though, the device will add with proper name, no Unknown stuff. I’m just having a problem now not getting any light entities under the device.

1 Like

I can control the light however, I can’t set parameters.

You can tell from the OpenZWave menu that the strip is not being configured correctly and all the parameters that allow for animations aren’t being applied. See screenshot:
image

Under another Inovelli product, LZW-31 (Red Dimmer), the config values (parameters) are extensive.

Unfortunately that guide is for OZW 1.4, I’m on 1.6 (beta). @nathanfiscus is trying to help me edit the drivers in this thread, but not luck as of morning of 1/12.

I was running 1.4 during the beta, and never got proper functionality. HA developers over in their discord channel claimed getting it to work wasn’t going to happen because of bugs in 1.4 that will not be resolved. There was discussion wondering if that was true considering the bulb that uses color class and still works.

Any update on getting the RGB strips to work with HA and 1.6 OZW?

1 Like

Check the link I posted 2 replies up. I have same issue. Nathan’s been trying to help me get access to config files in ozw 1.6, but no luck yet. May have to wait for @EricM_Inovelli to update ozw 1.6 repo with the new xml

The config file has been added to the official open-zwave repo.

open-zwave/lzw45.xml at master · OpenZWave/open-zwave (github.com)

@doublepedaldylan I know we discussed this in our private Git repo. I’m guessing there are no workarounds that have been discovered for 1.4? What is the process of upgrading to 1.6?

FYI, I fixed this yesterday. The config file is in the official open-zwave repo as well.

1 Like

Ok so now how do I get my config folder on OZW 1.6 updated to include this? lol

Looking for the same! Ozw 1.6 on home assistant

I’m on 1.6 and I just tried again downloading the xml direct from the open-zwave github and manually placing it into the open-zwave\config\inovelli folder, re-including the RGB strip, restarting HA, and parameters are still not available to adjust.

image

@isewise 1.6 doesnt use those config folders. the config folders are somewhere on the host system that you apparently can only access with keyboard/monitor directly connected to the hardware thats running HassOS.

But the xml has been put in the ozw 1.6 repo. I restarted my ozw 1.6 add on, thinking maybe it would pull the new xml in. Re-added the strip but stills comes back as unknown.

Looks like the new xml is still not officially in the repo, so the HA add-on wont pick it up yet.

If you go here, http://openzwave.com/device-database, and down down to inovelli, LZW45 is not listed yet…
image

@nappyjim Not to be rude, but I’m pretty sure the “open-zwave” folder is used by Open-Zwave.

I’ve manually edited files by using the Samba share addon to enable scene control and other features working directly with files on HA.

From another post you mention you’re using the new blue hardware, I’m using a raspberry pi 4 running a different install than what you’re using.

Additionally, ozw isn’t going to get its config files from the openzwave.com website, its going to get them from the github page. As @EricM_Inovelli mentioned he updated it yesterday as you can see on the github history:
image

Yeah, I got the website from the openzwave github that the xml was updated in…

For those with 1.4
I setup a test HassOS instance and used the 1.4 Z-Wave integration to add the device. It is detected as Multilevel Tunable Color Light, but it seems the Home Assistant is unable to detect the type to create the correct entity. I stopped the integration and then edited the zwcfg_****.xml to change the type to Multilevel Power Switch and specific to 1. Then I restarted the zwave integration and the light entity was created.

So this:
<Node id="7" name="" location="" basic="4" generic="17" specific="2" roletype="5" devicetype="1536" nodetype="0" type="Multilevel Tunable Color Light" listening="true" frequentListening="false" beaming="true" routing="true" max_baud_rate="40000" version="4" query_stage="Complete">

became this:

<Node id="7" name="" location="" basic="4" generic="17" specific="1" roletype="5" devicetype="1536" nodetype="0" type="Multilevel Power Switch" listening="true" frequentListening="false" beaming="true" routing="true" max_baud_rate="40000" version="4" query_stage="Complete">

2 Likes

In your own screenshot it says: “Our device database is mainly based on community contributions…”

A device doesn’t need to be listed on that database for functionality with HA.

Why do you think in Inovelli’s own installation instructions they list out commands to download XML files from github?

It does appear that the new 1.6 OZW Daemon does check in with the device database on start up and will pull missing configuration files. If you check the logs of the integration you will see it attempting to pull missing records from http://download.db.openzwave.com/. So theoretically once it shows up in the device database on openzwave.com, it should be pulled into your config directory after a restart. If you don’t want to wait, you can locate your core_zwave data directory on the host machine and pull it manually as the Inovelli Support page (listed above) describes. The location of the core_zwave data will depend on your installation method (This can’t be done through either SSH addon, and isn’t support by Home Assistant so use caution.).

HassOS:
/mnt/data/supervisor/addons/data/core_zwave/ozw/config

Supervised Install:
/usr/share/hassio/addons/data/core_zwave/ozw/config

Commands to automatically pull the XML and update the manufacturer_specific.xml if you trust my bash: