Multiple Illumin lights "popcorn" effect on Hubitat

I am new to Inovelli, Z Wave, and Hubitat, so sorry for that.

I’ve got 3 new Illumin bulbs all installed in one fixture. I got them setup as devices with my Hubitat hub and the custom Inovelli driver no problem. I have full control over them. All good. Since they are in a single fixture, I want them to function in sync. The Inovelli site / documentation all suggests this is possible through Z Wave association and tested on ST and HE.

I have tried a number of different approaches including what I assume is the intended approach of creating a “Group” using the “Groups and Scenes” app in Hubitat. Added all 3 bulbs to that group and nothing else. I don’t have a smart switch in place to control this fixture and was just playing with using Alexa. So I exposed this fixture group through Alexa and added it to a dashboard as well. With both Alexa and the dashboard buttons, when I action the group it affects each light one at a time and always in the same sequence although the exact timing varies.

As I said, I tried a number of approaches which I can go into if helpful, but I assume there is just some specific black magic I’m unaware of and after a couple of hours of googling and forum diving, I’ve got nothing that works. Since this is apparently a supported and tested scenario, I’m hoping somebody out there (or at Inovelli!) can help educate me on this. And assuming there is an answer, perhaps Inovelli can get that put somewhere on their site / instructions so that others don’t have the same struggle.


Z-Wave association allows a switch to send commands directly to the bulbs, which mostly eliminates “popcorning” because the transmission is fast.

Inovelli has a tool that you can use to create association groups easily without having to manually set deviceIDs into groups:

However, you don’t have a switch controlling these-- just a Hubitat group virtual switch. There is no good way to avoid popcorning when controlling the bulbs through the group like this. Zigbee bulbs have groupcasting support, but Z-Wave doesn’t support this.

You might try a Z-Wave repair through Hubitat, which will ensure each bulb has a connection with minimal hops to the hub. If you set up the bulbs one by one, they might have picked their neighbor bulb as the best path to the hub, which could exacerbate the popcorning-- the repair should help the bulbs all take the same path.

FWIW I have three bulbs in a fixture like you describe and after a Z-Wave repair they turn on essentially simultaneously (but not perfect).

Sadly, the re-pairing did not change their behavior.

Just to be sure, you did a network repair in the Hubitat dashboard-- not disconnecting the bulbs and pairing them again, right?

As I’m so new to this, I appreciate you checking. I did exclude and then re-included them. But then I also subsequently did the network repair. No change to behavior in either case. Since I’m just playing with things, my hub is new and I only have one dimmer switch and only 2 other bulbs beyond what we’re already talking about. So very little going on yet.

I got home and retested my bulbs. Turning them on from the hub, I would say there’s around 100ms between each bulb lighting. From the switch (relay disabled, direct association) it’s indistinguishable.

If your bulbs take considerably longer there could still be something afoot.

This is what I’m seeing … Video of On / Off delay

Nice, the double phone! :stuck_out_tongue:

OK that’s definitely abnormal. Can you post screenshots of the Group-2.1 device that holds the bulbs, as well as one of the bulb’s config pages?

Group details …

Middle bulb details …

Unfortunately that looks exactly like mine. I see that you have on/off optimization turned off (but I assume you were playing with it), that’s the only difference I see compared to my group of 3 bulbs.

Here’s the log when I issue a turnoff command from the hub dashboard. You can see that the turnoff gap is around 15ms from bulb 1 to bulb 3. Maybe you’ll find a hint in your logs?

I just found this thread through a link on another thread.
I’ve got 4 Illumin bulbs in a ceiling fan that are being controlled through a red series dimmer on Smartthings using zwave association.

When I hit the switch there is a little bit of a popcorn effect, but it is nowhere near what you have in the video. And unless I’m looking right up at the bulbs while I’m turning them on it’s not really noticeable in an every day use setting.

From what I’m understanding from your posts, you created a lighting group to turn your bulbs on. This is NOT z-wave association. If you are turning a lighting group on from the switch (likely using some sort of rule), the hub would be processing the command and then sending the signal off to the bulbs. This is likely the reason for the drastic popcorn effect you’re seeing.

If, instead of trying to control the lighting group with the switch, you associate all 4 bulbs directly to the switch using the z-wave association tool. This way the hub isn’t doing any processing at all. The popcorn effect will still be there, but we’re talking miliseconds not full seconds like you have now. Use the tool posted by @seth, scrap your lighting group and setup true z-wave association. Then when you want to control it from the dashboard, control the switch not the group.

On a side note, when I put the 4 bulbs into one fixture, I get some buzzing coming from the bulbs. But each bulb in a single light fixture is whisper quiet. Have you noticed the same in a 3-light fixture?

I’ve gotten my “popcorn” effect to a minimum by just maintaining a healthy z-wave mesh… Removed all non-plus z-wave devices, plenty of mains powered repeaters, and every time I add or move a device I do a z-wave repair… Since hubitat doesn’t support z-wave multicast you will never be able to get rid of it entirely, as the commands for each bulb have to queue up…

The issue, in my current setup, is that I’m trying to use these bulbs in a fixture NOT on an Inovelli (or other) z wave switch. Standard switch with 3 Illumin bulbs. From what everyone says, seems like it’d be fine with a red series switch and z wave association. I’m just using the hubitat app on android or Alexa to turn them on and off … And that’s where I’m getting the popcorn.

I can try it with a red series dimmer to confirm. If true, then this configuration is just at the mercy of guitar to one day support multicast. Could Inovelli do anything on their side to solve this in some creative way independently of the specific hub?

Ahhh sorry, I misunderstood that part. Then yes, in your case you’re at the mercy of the hub. The hub will always send the on signal 1 at a time to the bulbs. Although that video does still seem slow for local execution with hubitat.

I’d say get yourself a red series dimmer and setup zwave association and be done with it.