Need a little help - Red series dimmer appears "dead"

I just installed my 6th Inovelli switch. I absolutely love these.

However, on this switch (red series dimmer), when I got all wires connected (line / load / neutral / ground) there is no lights, nothing. The switch does not show up when trying to find it with Z-wave, and the lights don’t turn on.

I’ve checked the power across the line / neutral, and I get 120V AC, so I know power is getting to the switch.

I’ve tried holding the config button down for over a minute - nothing; tried pulling the air gap and then config - nothing; pulled the switch out and reinstalled - nothing.

Anyone have ideas?

Welcome to the community :slight_smile:

Assuming literally no sign of life at all, i.e. the LED doesn’t even light. The only two possibilities I can think of is dimmer dead or the dimmer is not getting power (even though you measured 120V).

I’m not recommending this to you necessarily but I would (actually have).

I cut an old extension in half. Connected the plug end to the Line and neutral of the dimmer. I find a firm tug on the wires to test the connection is a good idea.

Put some tape around the exposed screws then plugged it in.

I have one I’ve not installed yet so I reset the dimmer by holding in the config button for 20 seconds. At about 5 sec the LED turned yellow, shortly later another color and at 20 seconds turned red.
Now my switch should be the same as yours (factory reset)

I unplug the plug it in again and the leds cycle: Red, Green, Blue then dim blue.

If there is no response from your switch then you should contact Inovelli support.

Along with JohnRobs excellent suggestion, If you have another switch that has not been installed yet, Or a known good dimmer from another location Swap the suspect one out with one of these. As JohnRob points out, remember to give a tug on the wires to check the physical connections. If the new one works, I’d be reaching out to Inovelli support about the suspect dimmer.

Wow, fast responses. Thank you both.

I’ve swapped this switch out for the previous (Lutron) known good one, and the switch works just fine (the old Lutron). I’ve tried the “extension cord” method and still get nothing (no light no nothing), so I’ll reach back to Inovelli…

Thanks again

Hey @DRH - sorry about the dead switch, let’s get it swapped out!

I just answered a ton of tickets a bit ago, so I may have already answered yours, but if not, feel free to write in and I’ll grab it:

Again, sorry for the frustration and thanks for the continued support!

1 Like

Eric, thank you.

I did fill out a trouble ticket. I’ll check emails for next steps…