Notifications turn switch on

I have to be missing something obvious here…

Red Series 2-1 switch. Smart Things.

The on/off toggle controls the lights above the switch. I used the LED light bar for color notifications based on other smart device statuses.

I’m finding that if the lights are off, and the device gets a notification, it displays the proper LED color, but it ALSO turns the lights on as if I pushed the up toggle.

I definitely do not want the lights turning on every time a notification is received. I HAVE to be missing something super simple here.

I don’t have SmartThings, but that sounds like this might be your fix? Double check the notification routine and make sure you deselect the Turn On option?


When you add an adjustment to the notification, you must first uncheck the option to activate the light, which is checked by default. Then adjust the notification as required. This way, the light will remain in its current state and only the notification will adjust.

You are turning on the notification with a routine, right? As @m_harton is suggesting, in the THEN section of the Routine, press the TURN ON selection to deselect it.

@chack Thanks. I could not find my own post on my phone lol.

1 Like

Oh my…i feel sooooooo dumb here. I looked at this numerous times and didn’t catch that.