NZW37 - Inovelli incompatible with latest SmartThings App?

Has anyone found success importing full function for NZW37 (Two Channel Plug) into the new SmartThings app? In my situation, the device is visible in the app, but I cannot control it (On / Off) and at the top of the screen for the device, a symbol of a cloud with a slash is visible. I assume this is meant to symbolize a problem connecting to the cloud, but cannot find any details on its meaning.

If you’ve made the “mandatory” migration to the new app and have found a method to keep functionality, please let me know.

I am running the Samsung SmartThings Hub, version 2. The old app still works fine with this device, so I am confident there are no issues with the plug. It is simply the new app that has created the problem.

I have the same problem within the new SmartThings App. However, I can control the separate channels using voice control (Alexa), Smarttiles, or Automations. Since I seldom use the SmartThings App to turn on/off devices, this isn’t a show stopper for me; However, it should be fixed (I’m not sure if this is a Samsung or Inovelli issue)

Before I migrated to the new SmartThings app, I basically excluded all devices, deleted all device, except my NZW37s, because they were using a DH. Then I uninstalled my SmartThings Classic, installed SmartThings and added all my devices again. All worked like a charm, including my NZW37s.

All the sudden I am now I having issues with my NZW37 not turning on/off via new SmartThings app. I had to finally exclude/delete the NZW37 device from my IDE and try a clean install.

Now I can not remember the hoops to manually install. I still have the DH installed in my IDE.

As for Inovelli providing support for NZW37, the discontinued items are out of warranty, and they are not legally obligated to provide support, so always inquire with your nice voice.

If anyone here is good at providing long drawn out instructions on ways to do a clean reinstall for use with the new SmartThings app that we can all use, we look forward to reading and following it.

Maybe Eric, as a developer, can provide more insight on the background of what is probably happening to cause the issues, so that all end users can understand it from his prospective.

Its my understanding that IDE Groovy is going away soon. So we all better try and get all of our toys NOT dependant on DHs.

I know this is not the answer you’re looking for, but I seriously think you should get rid of SmartThings.

Samsung killed something that was working fine for you and now you have to rebuild your HA system from scratch because Samsung said ‘jump’. I think that’s a crappy way to run things.

I would recommend HomeSeer- it is 100% local, 0% cloud. So there is never any delay- scenes execute instantly. No cloud also means no forced upgrade / migration. If your old version is working well, you can keep using it forever.

Another nice thing about HomeSeer- no device handlers needed. For a switch like Inovelli it shows up as a main device with several sub-devices (central scene control, multilevel light switch, KWh power usage, current power usage, etc). Same with any other z-wave device- whatever capabilities the device has are exposed as sub-devices, so no drivers or device handlers are needed.

I can’t speak for Hubitat or Universal Devices ISY, but I’ve heard good things about both of them. Also cloud free.

Good news is we still support them, I promise. We answer Gen 1 questions all the time both here and via tickets. But I do like the advice to use your nice voice :rofl: – we can be fragile sometimes!

@EricM_Inovelli can probably provide some details as to why this isn’t working. It honestly seems to be hit or miss as it works for some but not others. Even with the Fan/Light module which is also a multi-channel device, there are some instances where ST will just freeze up the child devices. I know Eric’s working hard with the ST engineers on a lot of this.

In the ST Community, there seems to be some sort of hack to get this to work – we’re investigating, but it looks promising!

Yeah, I found a method, I’m moving to Hubitat. I, like you, am on a V2 hub, and with the last round of annoucements I foresee a “mandatory migration” to V3 or higher in the not to distant future. The coming shutdown of the IDE also has me concerned. Truth be told, I’d probably still be happy with Smartthings if I hadn’t tripped over Inovelli while searching for Non-neutral dimmers. Now that I have them, there is available to me features I never new I “needed”, but that Smartthings is starting to have issues with.



This has been mentioned in a few other threads. I’ll try to create a KB article about it, but the basic process is:

  1. Update the device handler.
  2. Delete the previous child devices. (can be done in the IDE or sometimes in the new app)
  3. Create new child devices by going into the parent device and editing a preference.

Device handler:

Thanks for suggesting HomeSeer. I will look into it.

I saw on their page:

I noticed that inovelli is not listed as one of the compatible products/brands.
Does that mean jumping hoops to get it to work?

No hoops at all, it (and all other Z-Wave devices) Just Work without any hoop jumping or additional software. That’s a big reason why I like HomeSeer over most others- rather than present the Red dimmer as one device with capabilities that needs a driver, it presents them as a root device with child devices that are based on the various Z-Wave classes the switch supports. Thus, a Z-Wave device never ever needs any sort of additional drivers or support code.

Here’s what that looks like:

Those devices can then be used in events or controlled. For example, here’s an event I have so pressing the config button turns the light on very dim as a night light (for walking around without losing night vision):

This can also be used to do other stuff.
For example, there’s a hallway light right outside the first floor bedroom, it’s very bright, and will wake up anyone inside if the door is even slightly ajar. But that light is very useful for walking around at night.
So I wanted to make it so if someone was asleep (time is after sunset, AND the sleep sound noise generator is on) it’ll adjust the hallway light to come on to 5% by default instead of 100%. That takes two events, both of which set Parameter 9 on the hallway switch, one to turn it down to 5, the other to turn it back to 99:

The reason the bottom one has two conditionals is because in HomeSeer the first IF is always the event trigger. So the first IF triggers processing, the THEN actions happen if the other conditions (if any) are true. Thus I need two- one for if I turn on the sleep sound after sunset, one for if the sleep sound is already on at sunset.

After successfully using my NXW37 in the same place in the house with no changes to the HA toys and hubs, all the sudden it seems it doesn’t want to play nice.

I believe ST app update may have caused issues. All the sudden the ST app states, “waiting for status” and would not turn on/off the NZW37 with the ST app. I only had a 5v USB adapter for a indoor wifi cam connected to this NZW37, so I know I did not over-work the device.

Attempting to do a clean re-install of my NZW37 on the new ST app. I still have the DH installed on my IDE.

I am at the ST app, press config screen

I tried the on/off button on the NXW37, and it will not config the device. I am stuck. Can I manually get it installed?

Feel free to copy and paste every last last detail for instructions. I would rather have too much information. Others will be able to benefit from the instructions. I probably won’t be the last asking for help. If there already is a webpage, I missed it.