On USB power and showing 1% battery

My Inovelli 4-in-1 sensor is powered with a USB connector.
It has the latest firmware and Smartthings driver.
I keep getting warnings in Smartthings that the 4-in-1 sensor has 1% battery remaining.
Smartthings shows the battery at 1%.
I looked at the history and for up to 3 days and the battery was never polled.
The system is set to poll the temperature, humidity, illuminance and battery every 2 hours.
I tried pressing the button on the back 3 times to “wake” up the sensor and nothing changes.
Is there a setting that I need to change? I would like to stop getting the warning messages.

@EricM_Inovelli – have you ever seen this before?

I have two LZW60s on USB power. The one running firmware 2.4 reports 100% battery, but the one I upgraded to 2.5 reports 0% since the upgrade.

My LZW60 also reports 0% when powered via USB with 2.5 I remember this being discussed the firmware came out. I just ignore it since I know it’s USB powered.

1 Like

I believe this is a consequence of the USB routing that was added in 2.5. I don’t remember why, but it seems that the device reports 0% battery when in that mode.

If using our device handler you could probably comment out the “capability battery” line of the code to stop the device from recognizing the low battery.


Yes, this issue showed up when I updated to firmware 2.5.
I commented out the “capability battery” as suggested.
Will see if this works.
The warnings has been coming about every 3-4th day.

1 Like

When I use RCR123 in the sensor, it always reports low battery. Seems that over ~3.5 volts drives the battery reporting crazy.

Just an update. Commenting out the code has worked. I have not had a warning message since.