Problem controlling Ceiling Fan Light with Red Dimmer via Hubitat Rule Machine

@skarden on the Z-Wave Details page, what does that device look like? You could be seeing the signs of a strained mesh. Here’s an example of a switch that is incredibly responsive, and another that is not so much due to the number of hops.

According to the the screenshots below both the fan/light and the red dimmer seem extremely similar to the one you describe as “incredibly responsive” as like yours, both of mine are S2 Authenticated, have only one hop and are going at 100 kbps. (BTW, my fan/light is the one that is literally taking a day for the firmware update). However, I do notice that your fast one has one route change while mine have 39 and 47. I’m not sure what that number means though. I have 20 red dimmers installed, 5 fan/lights and 5 black series switches. I never added more than 20 devices in a day and let them sit a few days between installs. I also waited about a day to do any automation - with one exception - which now I’m wondering may be an issue - When I did the last exclude/re-include for the red dimmer I set up the new rules right away. I’m wondering if that could be a/the problem. Once the firmware update is done (probably tomorrow) I’ll re-exclude the red dimmer, let it sit overnight and then apply the rules again.

Here is a screen shot of the Red dimmer that I am trying to use to control the Fan’s light:

I had tried Rule Machine, but thinking that might be the issue, I deleted those rules and created new rules with the Button Controller. Here is a summary screen shot of the rules:

I don’t know if it is safe to go into the Fan/Light device while the firmware is being update, but here is a screen shot of the parameters for the red dimmer:

Which might be easier to look at like this:

One last thing: I would be as happy, if not happier, to do an association between the red dimmer and the fan’s child light device instead, as that should be even faster, but I can’t get that to work. I believe they both have to be Inovelli drivers, but the fan’s child comes in as a generic dimmer. I’ve asked elsewhere what Inovelli driver to use for the child device but haven’t gotten a response. Also, someone suggested there could be a security mismatch, but both the fan/light and red dimmer are S2. I don’t know if the child device has its own security level or not.

Also I haven’t gotten a response at to what group(s) to do the association on as I understand the Fan/Light might have different #'s.


Route changes are just the number of times the routing table has been changed for that device. My guest hall light switch is literally the closest switch physically to my hub, so I don’t understand why it struggles so much to connect, but that’s probably not an Inovelli issue. It’s crazy that your firmware update is showing that long. I’ve only updated via a USB stick, and my longest update was probably 20 minutes. 100kbps is a good sign though. I still need to try out the new update driver to see what all of the fuss is about, but I’m not sure I have anything left to update.

Z-Wave associations shouldn’t have much to do with drivers beyond initial setup as it’s routing commands without going through the hub. I personally do not like the built-in button controller, but use Advanced Button Controller on all of my switches. I would still be curious to see what your logs show if you turn logging on for all three items (switches and button controller).

If I had an LZW36, I’m sure I could help you untangle how the child devices are intended to be used with association, but I don’t.

Thanks. Strange to me too. This is also the switch that is closest to the the hub. It is in the same room. It is now at 30% and 7 hours 53 minutes.

At this time we can’t do an association with a red dimmer other than one that will control the fan and light at the same time. The best we could do is to association one lzw36 to another lzw36.

The first dimmer I updated using this method went as expected yesterday, but the red dimmer I tried today was running about the same speed you are describing despite being a solid direct connect to the hub. I gave up and aborted. There is something really funky going on. I’m going to try to firmware update using my Z-Stick later this week to see if it’s a mesh problem or a software problem.

I finally got it done using the Z-Wave Firmware Updater. BTW, I was told it requires the device to have no security. So this is what I did:

  1. Go to 3 vertical dots in upper right of Hubitat screen for Settings

  2. Once in Settings shut down the hub.
    a. I was expecting the lights to go off on the hub, or to get a message it had shut down. But, nooooo. :slight_smile:
    b. Instead, look for the light on the hub to turn red

  3. Unplug the hub

  4. Power down the modem

  5. Unplug the router

  6. Plug the modem back in and wait for it to get online

  7. Plug in the router

  8. Plug in the hub and wait a few minutes for everything to get back up

  9. If you have any Security at all on the device you’ll need to exclude it, then re-include it with no security:
    a. On the Hubitat screen go to Devices
    b. Discover Devices
    c. Click Z-Wave
    d. Go to your device and put it in exclude mode with button holding the correct button and doing the paddle clicks per what that device requires
    e. Go back to your Hub’s screen and click Start Z-Wave Exclusion
    f. Once excluded, go back to the device and put it in Include mode
    g. Go back to your screen and click Start Z-Wave Inclusion
    h. Once the Security screen pops up uncheck everything and say OK
    i. If need be put in the DSK and then name the device as you wish.

  10. If you haven’t already, install the Z-Wave Firmware Updater. Per these instructions:

    If you have already you can skip to Step 7 of the linked in instructions.

Couple of Notes:

  1. Have the link to the file copied so you can paste in the URL in Step 9 of the linked instructions.
  2. Once it was done (this only took about 12-13 minutes) it said it was flashing the switch. So I waited, and waited, and waited 20 minutes for that to finish. I found out it was finished and that never goes away.
  3. Of course, as the instructions tell you, you then switch the Type/Driver back to the “real” driver.

Hope this helps,


The driver that @bcopeland created and you linked to doesn’t play nice with security, but the switch I updated yesterday is S2 authenticated as is the one I tried today. The Hubitat app he built for the C7 is definitely more compatible (it works at all with security), but I will try rebooting the modem to see if that fixes my current issue.

I had a 2nd Fan/Light that didn’t have security turned on and it updated just fine. However, I just went to exclude a 3rd Fan/Light to remove it’s security and for some crazy reason it won’t exclude. I did the range test and it turned green almost instantly. There are just a couple of walls between the hub and the switch, the blue lights flash when I hold button A and tap button B 3 times quickly, so I don’t know what’s up with that.

It is taking a rather circuitous route though:

BTW, any idea why a device will some times use it’s Node #, like 3C instead of its # (here would be 60)?

I used the Z-Wave Firmware Updater with a gbl URL. Does that mean I have the version that works with security? If not, I’d like to try @bcopeland’s one that does work with security so if I don’t have it already, can you give me a link to that, please?


It’s the built in app you access via that menu.

I was on 2.2.4 and that was the Device Firmware Update (“DFU”) app I could never get to work. Even after I got past the 26 hour non-update and it ran in about 20 minutes it kept telling me that the image didn’t match the target. (See below). That’s when I gave up on it and went with the Z-Wave Firmware Updater. I’m on 2.2.6 now, but I don’t think anything has changed in the DFU.


Did you send the OTZ file to Target 0? I just rebooted the hub and started the firmware update immediately. It’s working much better than it did last time.

I was using the gbl

Ah. Forgot we were talking about the LZW36 in this thread. I don’t think you have to worry about targets on those.

All I know is that when I first tried to use it I kept getting errors and couldn’t even get to the page where you actually run it. I had to remove it and re-add it. Once I did that it ran but always gave me the error posted above about it not matching the target.

Have you now been able to get it to work to do an association between a 2nd Gen Red Dimmer and the light of a Fan+Light?

Is that anywhere on your “to do” list?

Unfortunately this won’t be possible with association. There is not enough storage space on the Z-Wave chip to add multi-channel association.

If you have a local processing hub, you could use scene control and have a pretty good experience. On a cloud platform it probably wouldn’t work very well.

I am using a Hubitat C7 that is in the same room as the Fan+Light switch and the other switch is literally on the other side of the wall as Fan+Light switch in the hallway. The one in the hallway is connected to just the line, neutral and ground.

While it usually works via a Hubitat rule, for some reason from time-to-time I get huge delays from a few seconds to 30-40 seconds or sometimes forever, before the light turns on or off. That happens periodically with every switch that isn’t physically connected to a load, and even for the ones that are I get that same non-responsive behavior for all of my Config/Favorite buttons as they have to go through the hub. It seems to be worse late at night, but it can, and does, happen anytime of the day or night.

Often after the Favorite/Config button doesn’t work I find just turning it on and off from the main paddle (when connected directly to the load) gets the Favorite/Config button to work. I have no idea why this is, other than a guess that somehow it was “sleeping”. But this doesn’t seem to make sense as I have a neutral wire connected to every switch and therefore they should be always on. My other guess is that perhaps the hub was working on the routing, but I have no idea how to tell if that was the case or anyway to schedule when that happens. Still 30-40 second delay, or even, at times, no response, seems way more than should be accountable for that.

I’ve posted several threads here and on the Hubitat site asking why this happens and how to prevent it, but I literally get no response from anyone. I don’t know if it is an issue with your switches, the Hubitat hub or, if this is home automation’s dirty secret, that it just isn’t that reliable.

Yeah the delay sounds like something is up. Thinking back, the only time I have seen delays of that length have been when a device is associated to another and the second device is having issues or has been removed from the network. So the device will try to send a command and will eventually time out. This can cause a long delay. I’m not sure if that is what is going on or not. Also, if the hub is getting a lot of load at the time, that could be it. You might want to check the logs during the delay and see what is happening.