Red Series Dimmer - No Neutral Wire and Bypass

I have an LED light fixture I’m trying to get to work with the Inovelli Red Series dimmer. My home has no neutral wire.
The fixture has the following specs:
Voltage: 85-265 Volts
Power: 36 Watts

Despite being over the 25 Watt requirement, the fixture would flicker like crazy and then power off, power on and flicker again. The dimmer would also refuse to pair or function, with the LED flashing red, blue, and green. I assumed I would need a bypass, and I purchased one from Lutron (LUT-MLC). I installed it at the back of the fixture, using wire nuts. One end is connected to the hot wire (black, confirmed hot with a tester) from the junction box in the ceiling, and that is wired to the black wire on the fixture. All three are connected under a wire nut. The other end of the bypass is connected to the white wire from the fixture and the junction box. The instructions for the bypass , and the other is connected to the white wire. My fixture has a green wire, labeled as neutral. Per the bypass instructions, I’m to include this with the white wires.

After powering the circuit back on, I was able to pair the dimmer with my Hubitat, and I can power the fixture on with no flickering. However, when I set the dimmer to off, the fixture intermittently flickers.

What am I doing wrong? I went with Inovelli red, which is honestly overkill for this. I don’t want to do anything but power the led fixture on and off with an integration to my smart home, but I went with it because I can’t find any “no neutral required” switches on the market. I was disappointed to find I still needed to install a bypass, but did so. However, it still doesn’t solve the problem.

Am I wiring something incorrectly, or is the bypass just not the right kind?

I haven’t used the Lutron version of a bypass, but would think it’d work as well as the Aeotec brand.

Make sure your dimmer is configured for non-neutral and one way (or three if it’s a 3 way). Also I’d adjust the minimum dim level to 35 or so and see if that helps.

In addition to what @harjms said, I would double-check your instructions for the bypass. This may not solve your problem, but it will remove a safety issue. In most cases, the green is a ground and NOT a neutral. The ground and neutral should NEVER be wired together in a light fixture. To do so removes the safety feature the ground is designed for. If you are not familiar with electrical wiring, it may be best to consult with an electrician.

I believe the Lutron bypass is a LUT-MLC. Directions follow. They don’t say anything about connecting a ground. If your instructions are different, please post them.

image

https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=&ved=2ahUKEwiTpqb8uc30AhVzj4kEHdsYDMIQFnoECAMQAQ&url=https%3A%2F%2Fwww.casetawireless.com%2FDocuments%2FLUT-MLC.pdf&usg=AOvVaw1_ZGKnvm75dkINlYBvT77d

I’ve noted your comment, and not hooked up the green wire in the fixture, which was labeled on the fixture as “neutral”. Note that it was never used before, but I assumed it was per the instructions of the bypass.
My bypass instructions are overall the same as what you provided. I think the issue here is the use of the term “neutral”. Even the instructions you provide show the white wire (1) as “Neutral”, even though this home has no neutral wiring. It’s some of the confusion.

I can’t find anything in Hubitat that controls the configuration for non-neutral and/or one/three way lighting. It’s a one-way light, btw.

I did try setting the minimum dim level, but it didn’t resolve the issue. This did get me to try the dim levels.

Any level over 66 results in the light turning off and then turning back on again. Changing it to anything between 1 and 66 resulted in no visible change. The fixture is still on. Setting it to 0 or off and the light does turn off, but then flashes on and off, one every 2 seconds.

I understand. @harjms can help you with the Hubitat settings.

Just so you are aware terminology-wise. You have a hot (black) and neutral (white) at the light fixture. If you didn’t the light would not work. But because presumably there is only a 2-wire conductor (possibly with a bare ground) run to the switch, that is where you don’t have a neutral. So the term non-neutral applies to the switch box and in your case, at least as you’ve described it, requires a non-neutral capable smart switch.

BTW, what type of load are you switching? i.e. is it a removable bulb and if so, what type? Or is it a bulb that is permanently connected to the fixture?

Any level over 66 results in the light turning off and then turning back on again.

I experienced these exact same problems when running a LZW31-SN made in 2019 with no neutral, and they are specifically mentioned in some of the firmware changelogs as fixed issues. What firmware version are you on? What is the date code printed on the front of your switch? (should be a month and year of manufacture)

You should definitely try updating to the latest firmware. You may need to temporarily put the switch somewhere else that does have a neutral wire so that you can include it and update the firmware.

Also, one clarification: All homes have neutral wires, even ones wired in the late 19th century. Electric devices won’t work without a neutral wire; it’s the second “prong” on a 2-prong outlet. What’s relevant for installing smart switches is whether there’s a neutral wire in the switch box. In newer homes, it’s required by code to always have a neutral in the switch box specifically to support future smart lighting upgrades. In older homes, it’s sometimes there, and sometimes not, depending on the exact wiring configuration of that particular box. With an older home, you probably have a neutral in some of your switches and not in others.

Built in hubitat drivers don’t always expose all the configuration parameters. Install the inovelli-written driver and then change the device type in hubitat to use the new user driver rather than the system one, and you’ll see the config parameters we’re talking about.

The fixture will have two or three wires. If there are only two, they are hot and neutral. If there are three, they are hot, neutral and ground. If the ground is not connected, the light will still work, but be less safe. If the neutral is not connected, it won’t work at all.

The general convention for coloring is that white wires are usually used for neutral, green or bare/uninsulated wires can only be used for ground, and any other color (black and red are most common) is hot. If you have a green wire that was previously unused and is labeled neutral, that’s almost certainly a ground wire with a confusing/mistranslated label, and which should not be connected to anything but a ground wire or grounded metal electrical box. It’s better to leave it unconnected than to connect it to the neutral.

I’ve installed the Inovelli drivers and re-paired the switch with them. Here’s what I see for firmware version:

  • firmware : 1.57
  • firmware0 : 1.57
  • firmware1 : 1.45

I’m a bit confused by seeing three different versions, but they are for the otz and bin, and does that mean they are the most recent?

At this point, I’ve practically given up and obtained another light fixture, but felt the firmware might be one final thing to check. If a firmware update won’t solve the issue, I think that’s my last resort.

Looks like you have the latest Production version of firmware.

I will clarify, by “give up”, I’m giving up on the fixture. Put in a simpler bulb fixture and used a standard bulb with the switch. Works great that way!

3 Likes

Did you ensure you see the parameters specified by using the inovelli driver? My guess is the default neutral mode hasn’t been changed to non-neutral so it isn’t working as intended.

Check your driver that you are using the INOVELLI written one, not the Hubitat version. Then go into configuration options and change parameter 21 to No Neutral. Here is an example in my home assistant settings:

image