Red series dimmer - turns on, goes full brightness then turns off

Newly installed red dimmer. I just replaced my black non dimmer. The neutral and line are in this box.
I’ve set config:
12 clicks to 1
13 clicks to 1 (but I have tried 2 also)

The dummy switch works and turns off and on. The dimmer side works and turns off and on but it will turn off after full brightness.


Has anyone seen anything like this? Is it a wiring or config issue? I’m at a loss.

Max brightness value, maybe.

Tagging @harjms

1 Like

Agree with @Bry. Either limit your maximum brightness to 80% within the controller or try upgrading your switch to latest firmware 1.47.

1 Like

I sent the maximum dim level to half way and it works.

I’m only running one led light bulb off the 3 way switch but I guess that will do. I might upgrade the firmware at a later date, it’s a pain with the usb in my Unraid r720 server.

Thank you very much for your help.

If you set the configuration to max level of 80%, it’ll adjust the switch parameters so if anyone does raise it to “100%”, it’ll actually only be 80%. It was fixed in the latest firmware or at least most report its fixed. Either way glad to see it’s working (limited).

1 Like

Thank you for your help.

I just have a quick follow up question.
When configuring max dim level from the switch configuration settings how many clicks equal what percent?

Is it 1 click = 10%? I’ve been looking through the instructions and I can’t seem to find that info.

So I do this via Hubitat device settings. I’m not too sure how to do it via config button.

@rob.van -Looks like you press up 80 times per the configuration sheet.

Edit. Number starts at 55 since that’s the minimum max level.

By far hub is easier.

1 Like

you were right, I just decided to update the firmware.

This solved the issue in the video.