Red Series with SmartThings stopped working - IDE not accessible

I have several red series switches, that have been working ok for about a year via SmartThings hub.
I’m using smart lighting automations in Smarthings to trigger scenes.

After returning from New Year’s holidays, all of the switches stopped working.
They are still accessible via smartthings, you can turn on/off the switch itself, but none of the smart lighting action works.

I tried to check device settings via smartthings IDE and could not find ide itself.

However this article is quite worrying:

It specifies that on Dec 31st all smartapps created via IDE stopped execution (I suppose including device handlers)

May be I’m missing something, but:

I’m stuck unable to change a single setting for the switch or re-configure it from factory reset

So for the last 1 - 2 years, Samsung has been advising that they are deprecating the Groovy language and Device Handlers in favor or the Lua language and Edge drivers. Despite the initial time announcements about the end of 2022, this migration is still taking place, so I’m not quite sure why your things stopped working. I don’t mean this in a bad way, but if you just became aware of that End of Groovy article, you’ve got some catching up to do in terms of education, but it’s nothing you can’t recover from.

The plan is for Samsung to automatically migrate your switches from Device Handlers to Edge drivers. They have slowing been converting other devices, but Inovelli’s, AFAIK, have yet to be automatically converted.

The symptoms you are describing are a bit puzzling:

1 - Nothing about this migration process should prohibit your switches from working at present. I have manually converted some of mine to Edge, but I have plenty still running on Device Handlers.

2 - Nothing in the Samsung enviroment will prohibit you from factory resetting your switches. Perhaps you are saying that you have factory reset your switches but you can’t re-add them to SmartThings? If that is the case, using the SmartThings hub utilities (from the app) run a general exclusion and then exclude them that way. Sometimes Zwave devices need to be excluded from the hub before they can be re-added. Post back if you need more detail.

At this point, if you have factory reset your switches, you should probably load the Edge drivers before you re-add the switches. Add the drivers via this link: SmartThings. Add a little smartness to your things.

And read about them in this thread: SmartThings Edge Drivers: LZW30-SN, LZW30, LZW31-SN, LZW31, LZW36, LZW41, LZW42, LZW45, LZW60, VZM31-SN

You will still be able to use SmartLighting if you wish. SmartThings is designing a new version to replace the Groovy one you are presently using. The one will still work, btw, but you might as well load the new one, or use Routines instead. I have things running under the old SmartLighting still, so I’m not sure why yours are not. But it could be part of the migration process taking place in stages. I have found that the new SmartLighting is still a bit buggy, and things that don’t run properly in it work perfectly coded the same in Routines.

If you want to load the new SmartLighting, go to the Automations tab, click + to create a new Routine, then select Discover at the bottom. Find and select the new SmartLighting app. The icon for the new version is a yellow light bulb.

If you haven’t factory reset your switches but SmartLighting just doesn’t work, then just load the new SmartLighting as I just described, or use Routines instead. My preference is to use Routines until they work the kinks out of the new version of SmartLighting.

Post back if you have more questions. We’ll get you going!


THIS is why I love this community. Dang.

1 Like

Thank you.
After adding edge drivers and resetting the switches (removing from smarthings and re-adding), I was able to make them work again.

Just adding edge drivers was not enough, as switch settings page looked old, like with device handler.

I suspect that samsung started to wind down gradually those groovy based device handlers, as basically all devices stopped working at the same time (give or take, as I was on vacation).

I was able to find IDE link
it was showing last actions for the switch, like double up, or double down, but routines were not executed at all.

Glad you got them going.

Get used to working without the IDE, as it will be going away in the near(?) future. It’s no longer 100% accurate at present due to the changeover. There are still a couple things in the IDE that Samsung hasn’t replicated to the app (like the hops), so you may not be able to leave it 100% as of yet.

There are also 3rd party tools like Todd Austin’s API browser that now provide some of that functionality.

Why would the Edge driver not pull through for a Red on/switch? The driver was selected in the enrolled channel, the switch was excluded and then added as a device but the “driver” option in the three dot menu does not show up? Any suggestion? I opened a ticket but have not heard.

I am not sure, TBH. I usually do several operations which may be redundant. Try these and see if it helps.

  1. Delete the device from SmartThings via the app.
  2. Go into the IDE and make sure that the device is gone there as well. If it’s still in the IDE, delete it there as well.
  3. Exclude the device doing a general exclude. You can either do this via the IDE or the app. Make sure that you get a confirmation of one device excluded.
  4. Factory reset the switch by doing a long press of the config, about 40 seconds until the LED turns red.
  5. Add the switch back using Scan Nearby. I don’t add my switches with S2.

If you are uncertain how to perform any of these, post back and I’ll provide details.

1 Like

Both a ticket to Samsung and a call to Customer Service resulted in them saying the Smartthing Z-wave switch driver is the default Edge driver. When telling how the GE/Jasco also pulled the Smartthings default driver but was allowed in the app to select other driver and pick the Jasco preferred, that worked. The Inovelli switch driver does not show when useing that select other driver even though it is on the hub list of included Edge drivers. At this time, Customer Service has escalated the ticket.

I’m in the same boat as IvanF. All of my routines/smartlighting have stopped working on my red series dimmers. I really don’t want to factory reset them because they are set up in 4-way configurations that took forever to create associations for. I especially don’t want to reset them if I’ll have to reset them again when the Groovy backend is implemented. Maybe I’ll just wait for things to settle down on the Smartthings side before heading down this long road.

I was able to fix it without factory reset. I had to remove it from smarthings and re-add it. It automatically resolved with those edge drivers.
However, I had to recreate all routings from scratch. Didn’t use smartlights now, just went with standard routines.

Well that’s good to know. I think I’ll still need to set up all of the associations in the 4-ways after removing from smartthings. If anyone can confirm that the associations are hub independent (meaning switch to switch) then maybe I’ll give it a go.

I think if you exclude the switch using zwave exclusion, by default the switches will reset per zwave spec; so you’ll lose you associations. It’s been a good minute since I used the reds though so I may be off.

You will lose associations when the switches are excluded from smartthings.

Ok i need some help!!! I updated my wifi went to a mesh network and combined my wifi. Now my Red switches won’t work with smart things because i can’t pair them with the new app. Does anyone have any instruction on what to do? I didn’t reset my switches but i did reset my hub. I had a bunch of routines run in alexa with controlling the lights and would really like to get that function back.

Any help would be greatly appreciated.

Try running a general exclusion on the hub and exclude the red switches first. Then re-add them.

Switches cannot be added to a new hub before they are excluded. I am thinking that is sort of the case because you reset your existing hub. Not sure, but it’s worth a shot.

Put the hub in the exclusion mode and press the config 3x on the switch.

You should be able to pair them in the new app. While the app appears to not have updated the inclusion instructions under the brand section, basically all you have to do is click, “Scan” and that will put your hub in inclusion mode.

Make sure you have the device driver installed if you don’t already (Instructions here)

Here are the steps (including @Bry’s suggestion to exclude):

  • Click on your Hub in the ST App
  • Click on the three dots at the top right and select, “Settings”
  • Click on, “Z-Wave Utilities” and then, “Z-Wave Exclusion”
  • Once Exclusion is running, click the configuration button on your switch 3x
  • If successful, it should blink green or red (I can’t remember off hand) and your app will say, “A device was removed”
  • Then go back to the devices page and click the “+” at the top right and select, “Add Device”
  • In the, “Scan for nearby devices”, click on, “Scan” – this should put your hub in inclusion (pairing) mode
  • Click on the configuration button on your switch 3x and the switch should start pulsing blue – if successful, it should blink green and if unsuccessful it will blink red
  • Your switch should show up as, “Inovelli Dimmer Red Series” or “Inovelli Switch Red Series” (depending on the model) if you have the Edge Driver installed

Keep us posted if that works or doesn’t!

1 Like

Thank you guys so much!!! I got them to pair after i excluded them and it all is back to normal!!!

1 Like