Red Switch won't turn off, but it tries

I have a Red Switch that is in a 3-way with a dumb switch at the other end. It controls my outdoor garage lights. So I have Smartthings setup to turn the lights on in the evening, and then off in the morning. For the past 2 days I’ve noticed that they have been on in the morning.

So I tried turning it off manually at the switch. As soon as I tap off, it turns right back on.
I tried in the ST app… same thing.

It wasn’t until I pulled the airgap switch, waited a couple sec, reset and then I was able to get the light to turn off and stay off.

I attached a picture of the history from ST.
You can see where ST tried to turn it off with a routine, and turned back on. And then when I was pushing the button

So is it working properly now?

1 Like

No. After I reset it, the same thing happened the next morning.

Not a ST user so just a guess here, but have you set the switch as a dumb 3way?

So it worked okay for a while, but then the next morning it reverted to having an issue?

Take a look at your routines tab and see if there are other routines controlling the switch. Are you using any third party software like SharpTools? How about voice assistants like Alexa?