Relay Setting Changes on Power Loss

I have a red series dimmer switch that I installed to provide local control of a Phillips Hue Colored LED. I am using neutral and have a single pole application (very simple). I forced the relay to always be on by pressing the configuration button on the switch 8 times per the instructions. I get three red LED flashes which indicates all is good. Finally I had to use the Hubitat interface to turn the switch on (pressing the on button in Hubitat from the device control panel). I have set up an app in Hubitat to turn the Phillips hue LED on when the Inovelli dimmer switch is tapped up and to turn the Phillips hue LED off when the dimmer switch is tapped down. This all works fine. I can also tell Google to turn the LED on or off or set the color or level and this all works fine because the Inovelli dimmer switch always powers the LED.
But then chaos happened. I lost power due to the weather and when I powered back up, the switch did not retain the relay setting. I had to reset the dimmer by pressing the config button eight times. And then I had to turn the switch back on using the Hubitat device interface. I also learned that the relay setting is also lost if the configuration button in Habitat device interface is pressed. I purchased six Inovelli red dimmer switches thinking that I could use them to provide local switch control for the various Philips hue lights I have. But I don’t want to have to go through resetting up six switches every time we have a power glitch. This would be a pain for me and impossible for my wife if I’m gone for a few days.
So I am now considering bypassing the switch all together and just wiring the line and load together. Then I’ll use the dimmer switch as a button controller that looks like a switch.
If I do this, will it work if there is no load connected to the dimmer switch? Any comments or suggestions about this or other approaches? I’m a little disappointed … :frowning:

I believe this is a firmware bug that will be fixed at some point. If the relay is disabled and power is lost, the switch defaults to off when power is restored.

When the relay is disabled via config x8, you can still control the switch through zwave. Until the firmware update is released, you may be able to do one of the following:

  • Bypass the load and wire the bulb to be permanently on. I have read other posts that suggests this works, but I havent tested it myself.
  • Set up some sort of timed automation that sends the ON command to the switch every 10 minutes or so. This would ensure the switch eventually gets turned back on after a power outage. Sending the ON command to a switch that is already on doesnt seem to cause any issues, but if you send the commands too frequently, you may saturate the zwave network
  • Set up some sort of automation that detects if your smart bulb becomes unavailable and then sends an ON command to the switch. This has a less chance of causing zwave bandwidth issues, but is probably not as reliable as option 2.

Good workaround suggestions… Hardwiring load to line came to mind however mine is a 3-way switch so that actually become a bit more of a headache.

I hadn’t considered the sending an ON command every X minutes, that’s a pretty good idea as well.

I’ve wired the load wire to the line wire and hooked up a switch leaving the load terminal empty. I then used zwave association to control a set of smart bulbs. I can confirm this does work.

That sounds like the cleanest approach. Unfortunately my lights are all Zigbee Sylvania SMART+ RGBW lights. I’m using Hubitat to relay the commands to them. It’s about a ~0.3s delay.

The issue I have with this solution is if I decide to switch back to a normal bulb, I have to rewire the switch (I’m using Red Dimmers because of the package deal). And in few years, when I move, I don’t want to have to go around and rewire all of the switches where I am using smart bulbs. And besides, the switch is advertised to be able to continually power smart bulbs … but it does not work :(. I have updated the driver and this has not resolved the issue. Wondering if I have to delete the switch and then re-add it or something?

Both of these situations are correct. For switching back to normal bulbs, you need to move 1 wire. When selling the house I’d suspect you’d want to bring your smarthome stuff with you since it doesn’t really add resale value to the house.

Also, from what I’ve read and somebody please correct me if I’m wrong, disabling the relay at the switch doesn’t disable the relay when controlled by a zwave command. So an off command via zwave will still cut power to your lights.

As mentioned above, it’s a firmware bug so new drivers won’t fix it.

This is extremely frustrating, and without this feature, I’d argue “the control of smartbulbs” is incomplete. The workaround of periodically turning the switch back on means all my bulbs will come back on as well.

I really hate to return 15 switches, but when the firmware fix has no eta and may not happen at all, I’m not sure I have an alternative.