Set default dim level by time of day

I followed the how-to included, and could not get this to work “reliably”. Every time I hit a switch after a time change the switch would go to the last dim level the switch was on. Turn off the switch and turn it on again and it would go to the expected dim level. I checked the logs, and everything looked correct. What I figured out (though Hubitat) is that the routine is working exactly as it was told. The problem is that the child set local level is being updated when the parent switch is turned on. What needs to happen is the child device needs to already be set before the parent is turned on. What you need is some event to happen when the time changes. So say at 6:00 pm you have your hub change mode from day to evening. Now you just need an automation that sets the desired default dim level wen the mode changes to evening. You could use a virtual switch instead of mode.

There are two different “Default Level” child devices you can create:

  • Local
  • Z-Wave

If you are using the local child device, the default level only takes effect when physically turning on the switch. The Z-Wave child only works when turning on the switch remotely. Keeping in mind the child device must be “on” for the default level to take effect. If the child device is “off” the defaults will not be used.

If you are still having problems can you take some screenshots of how you have things configured?

I understand that perfectly well. I was commenting specifically on the how to that was given. When your time frame changes, and you push the switch the first time, your light turns on to whatever level the child was previously set to and then the new level is set at the child. So if your child is set to 100% and the time changes and the it is supposed to go to 25%, what happens is you press the switch the light lights to 100% and the child sets to 25%. The next time the light is activated at the switch it will light to 25% because that is what the child is currently set to. To prevent the first press from possibly blinding you in the middle of the night is set the child to the desired level before the switch is pressed. I use mode changes simply because they are already occurring at the times I want. You could easily say turn on and set light (default local level) to 25% when time is 10 pm also turn off at 6:30 am this will now let the default level in the physical switch take back over.

Could you post some screenshots of how you have things configured in Hubitat? Also what is the bulb you are controlling in this case?

I haven’t had any issues turning on dumb bulbs, they all start at 0% and ramp to the default level as configured. Smart bulbs on the other hand are a different animal entirely.

I am not having any problems since I moved away from having the physical switch be the trigger for setting the child device. I now just have a rule that says turn on and set a level of XX of child device at TIME1. Turn off child device at TIME2. It now works every time. In the How To:

Under, “Select Trigger”, select, “Switch”

Click on, “Which switch?” and select, “Master Bedroom”

Where it says, “Turn on & set level when” – leave it to, “Turned On”

This section turned on my light at the last default level, and then turned on the child device and sets it’s level. Using the physical switch to set the child was the problem. By changing the trigger to an event that happen at a specific time, I no longer have the issue of the light ramping up before the child device is set. There is just no reason to have the physical switch be the trigger. I was posting this, because I had an issue by using the How To. I figured out a way that completely solved my problem, and was passing the info on in case others are having the same issue.

That’s what I was thinking was causing your problem. The default level can (and should) be set using an event other than the switch. In my case I use modes as the trigger event, and just vary the child device level as desired. Turning off the child simply reverts to the default state (remember last level). Depending on how you control things there may not be a need to turn it off.

Ah, that makes a lot more sense. I’m glad you managed to resolve the problem. Given that article is specific to SmartThings, that could be a limitation of that system. Perhaps @Eric_Inovelli can add a Hubitat version - or create dual device guides that simply note the differences between Hubitat/SmartThings.

At a minimum thank you for pointing out the issue so it can get fixed for others that may follow :slight_smile: