SmartThings Edge Drivers: LZW30-SN, LZW30, LZW31-SN, LZW31, LZW36, LZW41, LZW42, LZW45, LZW60, VZM31-SN, VZM35-SN, VZW31-SN, VZM36, NZW30, NZW31

Updated lzw36 to edge today and can’t seem to disable local control for just the light button. I see local control setting under “main” but it controls both the light+fan and I only want to disable the light button.

Also I’m having a problem with the fan LED. It will change appropriately to my actions / any setting changes but will always turn off after a second. Video:

I was able to create virtual switches to be able to control the child devices for voice assistants thanks to this thread but definitely is a pain in the ass not having a seperate fan / light in devices

Did this get messed up in the latest smartthings update? If I deselect “turn on” it takes away al other switch parameters. So currently I can’t set a notification without potentially changing the state of the switch, unless I am doing something wrong. (Using IOS)

Not for me, although I am on Android, and there have traditionally been differences between the performance of the two OSs. Tested this morning. I can set a Routine to trigger on something and set a notification without turning a Red dimmer on or off. When I de-select ON, I can still turn on the Notification Effect to set the parameters.

Tried the same with a Blue and that is working for me too.

IOS, maybe?

@EricM_Inovelli i am seeing the same behavior as @PJones. When you deselect “on” the options all disappear. But this would be a ST issue, right? Any contacts you have over there to notify them?

Thanks for posting the pictures showing that, I was going to try to post a video but got side tracked. Are you using an iphone as well?

Yes, I’m also using an iPhone. Must me a ST software issue just not sure how best to address it!

Seems to be iPhone App only, as Android is still working OK.

Not sure if either or you guys are running SharpTools, but you can set notifications with the Rule Engine there as an interim fix.

1 Like

Thanks @Bry. I am running SharpTools. I actually don’t have an immediate need but was more validating @PJones bit SharpTools is a good idea for a workaround if needed in the meantime!

1 Like

Was a driver for nzw37 ever released?

1 Like

Yeah, it looks like the recent iOS update is causing an issue with the ability to use custom capabilities without turning the switch on or off. I am reaching out to their support. Not sure if @jody can help in this regard.

There should be a zwave-switch driver from ST that supports the nzw37.

1 Like

Thanks! Found it!

1 Like

Does this mean there is still no way to change over to the edge driver without excluding and re-adding the red dimmer switches? Is there any type of ETA on when the switch to the native driver would happen automatically by Smartthings?

AFAIK, excluding and re-adding is the only way.

Samsung has stated that these would be accomplished Q1 2023, but this date has been slipped. So my opinion is it will happen sooner or later, maybe . . .

To me, it’s not that big of a deal to remove and re-add. You can preserve routines but inserting another device as a placeholder. Other than that, it’s about a minute or two to remove and re-add, and then a bit of time tweaking some code.

I got a response last night and they are aware of the issue and are looking into it. I will post back when I receive an update.


I am pressing Samsung because I deleted, reset, and added the on/off switch device but the Inovelli Red series Edge driver did not come with the add even though it is on the hub list of Edge drivers. The add device pulls the Smartthing generic Z-wave switch driver by default. I go back and delete the generic from my hub list and no matter how many times I go through this delete/reset/add process, the generic comes back on the hub list. When you choose Select other drivers, there are none listed. I even deleted the old Inovelli driver from the IDE so all was clean. Waiting on Samsung.

It may well be on the Samsung side, but out of curiousity, let’s check this:

Log into the channel, click on the available drivers button and screenshot the Red Switch and Red Dimmer entries.

It should look like this:


Bryan, here is what I took from your channel, and is on my hub list of drivers.

Yep, that looks correct. Are you sure it’s a Red and not a Black?

@rcjny0829 If it came in a black box then it is a Black series not a Red. I would load the black switch edge driver. Exclude and factory reset the switch and add it again.