SmartThings Edge Drivers: LZW30-SN, LZW30, LZW31-SN, LZW31, LZW36, LZW41, LZW42, LZW45, LZW60, VZM31-SN, VZM35-SN, VZW31-SN, VZM36, NZW30, NZW31

That is weird, I wonder how that ended up getting changed. So this was a routine that had multiple switches in it and the duration was set to 0? So when you added the switch back to it the notifications did not work?

I don’t know it was set to zero. I failed to look at what the Notification duration was set to before I asked for it to be changed. The value that I used was 24 hours. So I am guessing a little on this as to what the orginial value is. What I can say is that untill I changed the value for Notification duration, Notifications were not being displayed on the Red Dimmer switch.
I tried routines that had multiple switches and one that sent a notificaiton to just one of the switches with the same effect of not seeing the notification. What I did observe is that when I sent 1 switch or multipule a Notification the Notification type would get changed, because I could view it from the device screen. I do not know how to see Notification color or duration.
Yes, when I added back the each Red Dimmer switch back after the full Smartthings reset, none of them would display a Notificaiton. Afterwards, I also tried excluding and re-adding the switch to the same effect. I even thought maybe it was the firmware (started with 1.47). So I also excluded each Red Dimmer switch, updated the firmware to 1.57, added it back - to the same result.

Was the update that was pushed for the light/fan driver, or a different product?

I’m still having the same issue. Driver version reads 2022-10-04.

Can you let me know the symptoms of what is happening? I’ll look into the light/fan driver right now.

Hey! Looking for some help.
I have several Inovelli Red series Dimmers
I can’t get them to see the edge drivers. I have installed the edge drivers from here -

https://bestow-regional.api.smartthings.com/invite/qyMZ8Pwq1Zlm

Removed my devices using ZWave exclusion and then re-added them.

I have also unenrolled my hub from the drivers, deleted the drivers and re-enrolled.

I can’t seem to get the devices to see the edge driver.

Any ideas welcome. I would love to utilize the features I had before edge.

Thanks!

Not sure where to ask this, so here we go.
I just upgraded all my switch and red series dimmers to the edge drivers.
Worked like a charm.
Now I’m trying to set up the notifications I had before.
Example, I want the LED bar on a red series Dimmer to be on and yellow when the light in the attic is on (a black series switch) and turn off when the light is off. I simply can’t figure out what to use in SmartThings. A routine or Smart Lighting?
How do I configure the notifications?

Another example is to have the light bar flash red when the front door is unlocked then when it’s locked have it flash green for 3 seconds and turn off. I used to have this notification on three different red series dimmers

I couldn’t find any description on how to configure notifications.
Any help would be appreciated

That is the proper link to enroll. After you did that, did you click on the “Available Drivers” button and then install the specific drivers you need?

image


image

Use routines.

For the attic light, you’ll need two.

If Black Attic Switch: ON, THEN
Control Devices, Inovelli you want the notification on, deselect the On or Off at the top, then set the notification preferences. Effect, Color, Level and Duration. You must set all 4 for the notification to work.

For the off rule, IF Black Attic Switch OFF, THEN
Control Devices, Inovelli you want the notification on, deselect teh On or Off at the top, then set the Notification Effect to OFF.

If you can’t get the other one after getting this one going, post back.

1 Like

Thanks for the quick help! My mistake was to not set all of the parameters.

2 Likes

Yes, I have added the correct driver as well. I have done this with other non-Inovelli devices and have no issues, which is why this is confusing to me.

Several things to check/try, as this is a bit perplexing.

1 - When you open the device page in the ST app and select the 3-dot menu, confirm that you DO NOT see the “Driver” menu.

2 - Are you sure you have the Red series and not the Black series? Strange as this sounds, it has happened where a user did not realize which series they had and consequently had the wrong driver installed.

3 - Try this series of steps. I know it’s redundant, but this is what I go through:

  • Delete the device in the app

  • Look in the IDE and make sure that the device is gone from there too. If it’s not, delete it there.

  • Using either the IDE or the app, do a general exclusion via the hub utilities and exclude the switch you just removed. Start the exclusion utility and 3x press the config button. SmarThings should confirm that a device was deleted

  • Factory reset the switch using a long press on the config button until it turns red.

  • Re-add the switch to SmartThings

  • Open the device’s page in the app and make sure that you are seeing the Driver menu

I was 99% sure I had all Red series. So much so I knew I had all the boxes still from when I purchased in 2019. Dug them out and found that I evidently had 1 black series and 6 red series. The first one I was trying to switch over evidently was the Black Series. :man_facepalming:t3: sorry for the User Error moment. Thank you for helping me troubleshoot.

2 Likes

Hi all. First off thanks for the vibrant community here. I love my inovelli reds and looking forward to when my back ordered blues show up.

This weekend I finally upgraded all of my Reds to the edge drivers talked about in this thread. In general, everything is working great except notification automations. The issue is that I can only set notifications IF I change the state of the switch (turn it off or on) which I don’t want to do. I simply want to change the notification state and only the notification state. Reading the posts above, the correct approach seems to be simply “unchecking” on or off in the automation (smart things gen 3) but if I do that then it causes the rest of the options to disappear meaning I can no longer set the notification. How am I being stupid here?


You can de-select the on/off by simply pressing it. That way you don’t have to include an on or off in the notification. Totally confusing . . fooled me for a while too!

Thats what I am saying isnt working. You cannot simply de-select the on/off. If you press it, it removes all other configuration as per the screenshots above.

I then found the posts above from @EricM_Inovelli talking about the same issue where the problem seems to be an issue in the iPhone Smartthings app. Out of curiosity Eric, has Smartthings mentioned anything about resolving the bug yet?

Got it. The iPhone issue slipped my mind, as I’m on an Android.

@EricM_Inovelli had a tempory workaround in mind, so maybe he will implement it if it doesn’t look like ST will get it fixed. In the interim, you may or may not be able to use a precondition depending on what you’re trying to accomplish. See @PJones comment above.

1 Like

I am going to paste a previous post I made about this issue below of a work around that I believe should work, but I have not tested. Mainly because I just set all of mine up and then had my son come over with his android phone and edit out the on/off problem, (which he gives me no end of crap about needing his android to fix it). This idea would take extra automations until they fix the issue with the iphone app though.

Previous Post:

You could probably work around it in smarthings but it would take extra automations to do it.

The particular one I discovered it on (my dining room light) I use the notification to tell me both doors are locked and the garage door is closed. I guess I could add “if dining room light is on” as a pre condition, and both locks are locked and garage door is closed, change the notification to green and turn the light on. Which would not change the state of the light because it was on, then you could copy the routine with a precondition of “if dining room light is off” and all the above conditions are met, make the notification green and turn the light off, again not changing the state of the light because it was already off.

But honestly my workaround right now is, create the automations and then call my son and have him log into my account and deselect that option on his android phone.

2 Likes

Yup, this is a great suggestion and I dont see why it wouldnt work. I like your main workaround too of ‘just use an android device’ even better.
:slight_smile:
I found one other workaround that I am currently using, but may not be as elegant as your suggestions, where I just disable ‘remote operation’ for the switch in question. No remote operation == the switch stays in the same state as it currently is. Of course that has the HUGE drawback of then not being able to use remote automations on that switch, but in my particular case, its ok, especially as a short term fix. And it has the extra benefit of only requiring a single addition on a single routine to actually implement.

1 Like

Cannot pair my LZW30-SN switch, I have 3 Red series switches, all were running the old DTH’s, about a month ago I excluded one and re-paired it under the Edge driver.

Another one on the DTH became unresponsive so I decided to exclude it and re-pair it but it won’t pair with my smarttings hub.
I have a Z-wave stick and was able to add it to Home Assistant so i don’t think it’s the switch.

I have excluded it from both and Smartthings and HA, factory reset it, tried pairing by scanning for nearby devices and the QR code and nothing seems to work.

Has anyone else had this issue lately? I’m thinking about excluding another z-wave device and trying to pair it to see if it is a Samsung issue.

Double-check to make sure it’s really a Red. i.e. a LZW30-SN vs a LZW30. There have been several here that thought they were trying to add a Red, when the switch or dimmer was a Black. It was just a simple matter of adding the proper driver for them.