SmartThings Edge Drivers: LZW30-SN, LZW30, LZW31-SN, LZW31, LZW36, LZW41, LZW42, LZW45, LZW60, VZM31-SN, VZM35-SN, VZW31-SN, VZM36, NZW30, NZW31

It is a Red, but no luck pairing it again today.

1 Like


When you said you excluded it, does that mean you did a general exclusion, not just delete the device from ST? (Open the hub in the app, 3-dot, Settings, Z-wave utilities, Z-wave Exclusion)

that’s correct, I did a general exclusion

While an exclusion should have fixed this, can you try holding the configuration button down for 20 seconds until the LED bar flashes red (and then release the config button)? I know you mentioned you factory reset it, but I just wanted to make sure this procedure was followed as sometimes it isn’t.

Also, I possibly ran into this on one of my old SmartThings hubs and unfortunately had to get the hub replaced. What happened was that I could remove any of my Z-Wave devices, but could not re-add them. Just like you, I could add them to any other hub (even another SmartThings hub) but for some reason I couldn’t add them back into that specific hub. This was not just an issue with Inovelli – I had some GE and HomeSeer stuff that had the same problem.

EDIT: What version hub do you have? In my case it was a V2. I also had a problem with a V3 (unrelated to Z-Wave) but it was the WiFi router version.

I tried to add another Z-wave device and that didn’t work, the thought of having to replace my hub (v2) was gut wrenching. So, I thought of anything I had done to create this problem.

I had used the z-wave stick to to try it as a secondary controller for home assistant, I don’t think it was totally removed from the z wave network so I removed it again (lucky IDE is still around) and everything seems back to normal.

Thanks for talking me through this.


This is resolved in the SmartThings iOS app v1.6.97, released yesterday.


Nice, I can confirm. I actually bought an old iPhone SE so that I could monitor this problem. Looks like it has been fixed!

1 Like

For clarity, is the the " deselecting see disables further selections" in notifications issue?


For clarity - you could always deselect the switch state, but in the previous 2 versions of the iOS app it would remove the notification options if you did so. This is resolved in the current version and you can select notification options without selecting a switch state.

Edit: Whoops, this was supposed to be a reply to @Bry


I also experienced this using SmartLight and mirroring virtual Dimmers, both would turn on but only the fan or light would turn off (which every one it was mirrored too, switch1 or switch2)

Right now my only work around seems to be making virtual Switches and mirroring them. Now I can at least turn them on/off with Google home.

Just waiting for the fix and I’ll make virtual dimmers again.

Ok i need some help!!! I updated my wifi went to a mesh network and combined my wifi. Now my Red switches won’t work with smart things because i can’t pair them with the new app. Does anyone have any instruction on what to do? I didn’t reset my switches but i did reset my hub. I had a bunch of routines run in alexa with controlling the lights and would really like to get that function back.

Any help would be greatly appreciated.


Having an issue with red series dimmer lzw31-sn and edge driver, have tried different firmwares 1.57 and 1.61.
When set up in smartlighting to mirror actions of the dimmer. When I physically turn/toggle off the red dimmer it completes. But then immediately turns back on. If I load a smarthings generic driver the switch behaves normally.

Video of switch toggle off and mirrored actions on other switches. And then it turning back on. (and other switches mirroring back on)

Are you using the new SmartLighting?

Yes. And also shows local execution.

1 Like

@EricM_Inovelli let me know what other information I can provide to help you review the edge driver issue.

Re-engaging on features for my inovelli switches after having a happy functional eco-system for 2ish years because I moved to a new house.

I am trying to configure zwave assocIation from my red series dimmers to the inovelli smart bulbs and that is when I stumbled into this edge driver convo.

I have moved my dimmer onto the latest beta driver and was trying to use the zwave association driver that was linked in this thread however when I hit “action button 2” I never get any information back from the switch and the association doesn’t take.

I’ve got a temp solution using the new smart lighting app to mirror switch status but it’s kinda slow and I also see weird behavior like I will tell the switch to turn off via the smart things app and it takes 5-10 seconds, I see it dim to 0 and turn off, but then it snaps back to previous state and turns the bulb back on. Never had these problems with association operations in the past.

Any advice appreciated, either to fix the issues in the new smart lighting app or to get my associations working.


See my video above. Same issue with edge driver and mirrored behaviour. It is an issue with the edge driver but haven’t heard back yet. If you use a generic driver it works fine. (but no inovelli features)

How did you get the switch on the default edge driver? I have the inovelli and association drivers installed and if I select drivers in smart things those are the only two options I get. Do I need to install a default edge driver from smart things or just uninstall the two I have set up?

Driver I got from the Smartthings beta channel