Switch completely frozen

So this is kinda scaring me, but I went to turn on my light and nothing. I tried the 8x config button press for relay disabling and nothing, tried the signal test and nothing, even resorted to trying a 20s factory reset and nothing, just a blue notification light and me not being able to see anything in the room :weary: I’m gonna reset the breaker, but what would cause this???

Breaker reset was a success but it’s supposed to act like a light switch… not a computer. Hopefully I’m just too early in the firmware process :thinking:

Also smarthings still saw it as connected but I also couldnt control it from there

1 Like

Yeah, hopefully that’s not a widespread issue. Was it not working even locally? Or was it only not working via z-wave?

What was the uptime of the switch? Mine only has about a week on it since I last pulled the power.

For what it’s worth, you might find that a breaker reset isn’t necessary. There’s that air gap switch you can pull out below the rocker switch; that appears to cut the power to the whole device.

@thetech101 - yeah this is weird and I’m sorry for the frozen switch. That’s not good.

As @wsdavis said, you can actually pull the air-gap out if that happens again.

Can you let me know what configuration settings you have on the switch and what your switch is connected to (ie: load)?

I’d love to collect as much data as possible here.

Hopefully it’s a one-off situation, but please keep me posted as well!

I’ll have to try the air gap, but its got 4 led bulbs pulling 42 watts, I’m using a 3rd gen smart things hub, the only part of the config that isnt default is the indicator light is set to 20% and the state after power restored is set to previous, dont remember if that’s default. If you need more info let me know. Thx

Found the air gap switch, that’s pretty handy, I saw it in the instructions but I guess I misread that part :man_facepalming:

Interesting, OK that is weird!

Are you familiar with IDE at all? The spot where you would install device handlers?

If not, I can explain further, but if you are, can you send me a PM with a screenshot of the device? Don’t share it here as it has some sensitive data.

What I’m most curious about is whether it says S0 Downgrade or S2 Failed.

@Eric_Inovelli I just recently had this happen twice.

The first time only one of the switches froze, but the second time both did. I have two black switches on two different breakers, but sharing the same box. They are located in an pole building on a sub-panel. They are not a 3-way. One is controlling 12 T8 LED Tubes, and the other is 10 15w LED Bulbs



When they locked up these switch were on a smartthings hub, but just yesterday I finished my migration to Hubitat and these were the last to move. In both hub configurations I was using a basic light automation to turn the lights on/off based upon contact sensors/delay, but when locked up they don’t response to hub commands or a physical interactions.

Interesting, this is not good. Has it locked up on Hubitat?

I have only had the switch on hubitat for about 30 hours, without a single lockup. I had originally just written off the lockup with smartthings due to the reduction it my z wave matrix…

I unfortunately have seen this with multiple switches. Trying to work with inovelli to figure out the cause


I have been tracking this now for 10 days and have not had a single lockup with the two switches that originally locked up during my smartthings->hubitat transition… At the time they locked up i only had two other nodes left on the smart things hub, but now on the Hubitat hub with about 30 nodes for 10 days without any troubles…

1 Like

I have 5 Red Series switches on Hubitat 4 of them have been on for more than 2 weeks and I haven’t had any of them lock up, the last one I just installed this weekend. Now time to buy more Red Series switches and a few dimmers. Seems strange that ST could cause the physical switch to stop responding though.

I installed one more red series switch yesterday and it locked up and required an air gap pull. I was messing with settings so I was blaming that. Other switches that were locking up have not since original post.

However, I still have one switch that will occasionally turn on then off then on when the physical switch is pressed. Happened yesterday again.

Eric feels my house is haunted. I feel this switch may be possessed. I plan to swap it out when I get a free moment.

Interesting, thanks for following up here! For Hubitat, I’m assuming you included it as insecure?

I’m starting to wonder if it’s a ST issue with their security implementation. It’s almost like the switch and Hub can’t talk to each other due to some sort of bug. What I don’t understand is why local control would go down.

But a similar thing happened last year and it only happened on ST Hubs.

It is re-assuring that it hasn’t happened on Hubitat.

Haha, either way we’ll take care of it!

That sounds like a good place to start on this one, Hubitat’s default is secure communications for locks and garage door controllers only, which is how mine is currently setup. ST will connect securely to anything if presented with a secure connection (I think that is why some manufacturers have one method of pairing their devices secure and another for pairing it unsecured)

You are correct the Hubitat install has these as insecure, right now only the two garage door controllers are paired secure…

I have 5 red switches using smartthings and 2 of them are locking up frequently. I have 2 of them on a motion control activation and built in timer to turn off. One switch on this scene has never had a problem. The other 2 completely lock up and require a reset at the breaker.

Another me too… My red switch locked up today with similar symptoms. All my other Z-wave switches are ok… ie, responsive manually or via classic smartthings app.

Mine is in a 3-way switch setup. Neither the red switch or the dumb switch works and a reset at the breaker did the trick. @Eric_Inovelli, lemme know if there’s any test you want me to run or data to collect.

1 Like