Switches have stopped activating scenes

I woke up this morning to both of my switches no longer sending scene_activated commands. I’m pretty new to all of this so I’m not sure what troubleshooting steps I’ve missed…

Looking at the OZW logs in Home Assistant, I see no activity when I double tap the switch. I’ve rebooted HA many times, tried flipping the breaker to reset the switch, and have removed and re-added the switch to the network. My config file has the added values specified in Home Assistant - 2nd Gen Switch RGB working!, but, oddly, it didn’t this morning… I had to add them back in. So, something weird happened overnight.

I just installed OZWCP and I’m not seeing any scene commands being sent in those logs, either.

I’m out of ideas… I think it’s unlikely that both my switches malfunctioned overnight…

You’re right that it’s unlikely that both switches failed at the same time. So it sounds more like a problem with your home assistant installation or your z-wave controller. Do you have any other z-wave devices configured? If so, are they working? Also, a new version of HA was released recently; did you happen to update last night?

You might try doing a factory reset on your switches, then re-including them in your z-wave network.

Thanks for the suggestions!

According to my understanding of the manual, removing the switch from the network should have factory reset it. I just tried forcing a factory reset (hold config for 20s) and I’m still not getting scene commands.

The only other device on my network right now is an August lock and it doesn’t do any scene things so it’s not much help for troubleshooting this. I’m still able to control the switches over zwave and also send notifications so they’re not completely dead.

My HA is in a docker container which gets restarted (and possibly updated) every night. I’m thinking now that this is a bad idea, because of this and also because of how flakey it is when starting up the network. I’ll look into disabling that.

Maybe I’ll try a complete reset of my HA and the controller… It’s not like I have a lot set up right now that I’ll need to re-do.

Well, I did a fresh install of Home Assistant and factory reset my Z-Stick controller and I’m still not getting scene commands. Not sure what else it can be at this point.

Yeah that’s super weird that the switches were sending scenes and then just stopped as it’s a command class inside the switch. While I’m no firmware engineer, I can’t imagine firmware deteriorating over time, but I’ve seen weirder things, so who knows!

I’m happy to swap these out and take a look at them for you if you’d like?

Thanks for the offer!

I was actually planning on picking up a dimmer once they show up on Amazon CA so that’ll probably be a good way to check if it’s the switches or something else on my network. If the dimmer works then it’s definitely a problem with the existing switches and I would love to get them exchanged. Will let you know!

Have you tried looking in your zwcfg_0xxxxxxxxx.xml file? There should be a few lines in there that look like this:

		<CommandClass id="91" name="COMMAND_CLASS_CENTRAL_SCENE" version="1" request_flags="4" innif="true" scenecount="0">
			<Instance index="1" />
			<Value type="int" genre="system" instance="1" index="0" label="Scene Count" units="" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="-2147483648" max="2147483647" value="2" />
			<Value type="int" genre="user" instance="1" index="1" label="Bottom Button Scene" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="-2147483648" max="2147483647" value="7860" />
			<Value type="int" genre="user" instance="1" index="2" label="Top Button Scene" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="-2147483648" max="2147483647" value="7860" />
			<Value type="int" genre="user" instance="1" index="3" label="Config Button Scene" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="-2147483648" max="2147483647" value="7680" />

I remember reading something about the version of open-zwave built in to Home Assistant not properly supporting scenes. If these config lines somehow got removed from your xml file, it might be the reason why your scenes no longer work

Well… This is awkward.

I had definitely added, double, and triple checked the config file, and rebooted HA numerous times when troubleshooting this before, but I just went and checked and no, they had been deleted again.

I re-added them and we’re up and running.

One odd thing worth noting, however, is that this time around, without the added lines, my logs were showing that the scene was attempting to be activated but was being dropped:

No ValueID created for Scene 1

This was not happening before. The network was completely silent when I was attempting to activate the scenes.

A tip for anyone troubleshooting weird things like this in the future: When in doubt, use the “Save Config” button in the Z-Wave settings for HA. It’ll write the current config to disk and you can verify that your manual changes have been recognized.

Thanks for forcing me to quadruple check the config!

I have a red series switch that is behaving just like this now while the rest of the switches are working fine as far as scene activation is concerned for HA. Any idea how this can be fixed?